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[bookmark: _Toc197154763][bookmark: _Ref292955801][bookmark: _Ref311730046][bookmark: _Ref311730051][bookmark: _Ref337626341][bookmark: _Toc401319340][bookmark: _Toc37306904][bookmark: _Toc98422730][bookmark: _Toc389644572]Introduction
The version 2022.1.0 release resolves known issues and includes enhancements to team and user maintenance, security, performance and the Windows Designer. It also includes small compliance updates for Australia and New Zealand.
This release also replaces the Internet Explorer control used for displaying PDFs and web content with the Microsoft WebView2 component. This has environmental requirements which are explained in the Upgrade instructions section.
The sections below provide full information on all of the changes included in this release.


[bookmark: _Toc98422731]Note about Greentree Browser support
In August 2020, Microsoft began retiring Internet Explorer. 
As a result, Greentree no longer supports the use of Greentree Browser with Internet Explorer 11. If you use Greentree Browser with Internet Explorer 11, you must start using a supported internet browser before August 2022. 
The Google Maps used in the Greentree Browser will no longer work in Internet Explorer after August 2022. In Greentree Browser, this affects the Organisation and Contact forms.
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[bookmark: _Toc98422732]New Features
[bookmark: _Windows_Designer_update][bookmark: _Toc98422733]Manage menu access without changing companies
The Team and User Enquiry form and menu item have been renamed to Team and User Security.
The form has been enhanced to allow maintenance of menu access. An administrator can now manage menu access for teams and users across all companies on a single form, without changing company.
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[bookmark: _Toc98422734]Faster file importing
Files now import more quickly. This is most noticeable with directories containing 1,000 or more files, such as the directory that holds emails imported by eDocs.


[bookmark: _Toc98422735]Security enhancements
[bookmark: _Toc98422736]Change Password window
When a user wants to change their password, they now need to enter their current password before they can enter a new password.
To change a password, go to the File menu and choose Preferences, then click Change Password. The new Change Password window opens.
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Administrators can still change another user’s password in the same way as previous releases, by going to System > System Setup > User Maintenance and completing the Password and Confirm Password fields.
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[bookmark: _Toc98422737]Improved lockout after failed login attempts
The lockout feature is now more consistent, so if a user tries to log in with the incorrect username and password too many times, they’re prevented from trying again. 
This applies when logging in to Greentree Desktop, the Management console or the Credit Card Maintenance form.
[bookmark: _Toc98422738]Hidden dropdown contents
For read-only dropdown lists, a user can no longer use the dropdown icon to see the dropdown’s contents.
[bookmark: _Toc98422739]Identifiers for Greentree Browser
To improve security, this release changes how identifiers used by Greentree Browser are generated. 
[bookmark: _Toc98422740]Windows Designer enhancements
This release enhances the Windows Designer to better support customisation windows that expand based on the size of the main Greentree desktop window.
1. These enhancements were introduced to resolve issues where customisations could display incorrectly, with forms overlapping each other. To get the benefit of these enhancements, an administrator needs to open a customisation affected by the issue and save it. Then, check that the customisation works correctly by changing the sizes of the main Greentree window and the customised form. 
In the Position & Size section of the Windows Designer, you can edit the new Right and Bottom fields. The Left, Width, Right, Top, Height and Bottom fields are shown or hidden according to which horizontal and vertical alignment options you select. When you save a customisation, only the relevant settings are applied. That way, the customisation appears as you intended, regardless of the form’s size. 
These enhancements resolve an issue where customisations could display incorrectly, with forms overlapping each other.
[bookmark: _Toc98422741]Updated protected earnings
Australia only
The protected earnings table on the HR Module Control form has been updated for 2022.
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[bookmark: _Toc98422742]Payday filing update
New Zealand only
IR now requires that a Tax code line record (TED) is included when sending an Employee details line record (DED). To accommodate this, Greentree now checks to make sure a TED line is included. If a TED isn’t included, you’ll see a new Tax Codes Missing message:
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As part of this update, we’ve also resolved an issue where ESS employer costs were being included in the total gross earnings amount.
[bookmark: _Microsoft_WebView2][bookmark: _Toc98422743]Sending emails with OAuth2
Greentree can now send emails to Exchange servers using Exchange Web Services with OAuth2 or basic authentication. This brings it in to line with the options for email retrieval from Exchange servers.  
For sending, the options are server type SMTP, which is configured using a security option and uses basic authentication, or server type Exchange, with either OAuth2 or basic authentication. The same credential dialogs and token management apply. The release includes new versions of the libraries GreentreeMail.dll, GreentreeMailCore.dll and Aspose.Email.dll. Existing email sending configuration will be converted to use SMTP with basic credentials and security option None or SLL Explicit, according to whether the prior Enable TLS/STARTTLS setting was off or on.

[bookmark: _Toc98422744]Microsoft WebView2
The browser control that Greentree Windows client embeds in some forms has been replaced. The replacement uses the same WebView2 component used by the Microsoft Edge browser. The change removes a dependency on an older, deprecated Microsoft component and provides Greentree with greater security. The change affects only Greentree Windows client, not Greentree Browser client or other web applications.
Client machines must now have Microsoft Edge WebView2 Runtime installed for the Greentree Windows client to display:
· the Greentree end-user licence agreement from Help > About
· the MYOB STP legal notice from Help > About
· web addresses for suppliers, customers etc.
· maps for suppliers, customers etc.
· requests for Lean Engage feedback.
· 3D live workflow desktop panels to display PDFs
· Qlik workflow panels
· eDocs displaying PDFs
· WebView displaying the PDF View panel.
The package adds three files to the file lists for Connection Manager settings groups. These files must be present on client workstations running thin client. The previous library ieframe.dll is no longer required and can be manually removed from file lists. 
[bookmark: _Upgrade_instructions][bookmark: _Toc98422745]Upgrade instructions
Partners should inform sites that client machines will require Microsoft Edge WebView Runtime installed. This is present by default in recent versions of Windows end-user machines, but not in older versions and generally not on servers. IT departments may have their own policies for configuring user machines, but in the absence of their guidance our recommendation is to download and run the Evergreen Bootstrapper at WebView2 - Microsoft Edge Developer. IT departments may choose to implement policies that control the location of the local cache, which defaults to jade.exe.WebView2 in the client’s binaries directory, as detailed in the Microsoft Edge WebView2 Policy Documentation. 
Partners should also run the Connection Administration application, confirm that file lists include Microsoft.Web.WebView2.WinForms.dll, Microsoft.Web.WebView2.Core.dll and WebView2Loader.dll, and confirm the embedded browser is working: log in using Connection Manager, select Help > About and click on the licence link. 


[bookmark: _Toc98422746]Troubleshooting WebView2
“Creation of browser control failed” error
This error message indicates files are missing from the client’s bin directory. If you’re running thin client, the remedy is to ensure the files are present in the server’s bin64 directory and included on the file list in Connection Administration.
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“Installation of browser control failed” error
This error indicates the WebView2 Runtime is not present on the client machine. The remedy is to download and run the Evergreen Bootstrapper at WebView2 - Microsoft Edge Developer.
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To confirm, open Windows Apps & features and search for WebView:
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Known issue
eDoc PDF not scaling with window size
To display an eDoc PDF at full size, click Fit to Width on the toolbar, or press Ctrl + \ on your keyboard.
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[bookmark: _Toc98422747]Resolved Issues 
[bookmark: _Toc98422748]Greentree Desktop
	Service Request ID 
	Description

	00011187
	(AU only) As part of STP Phase 2, the allowance detail code for a private vehicle was incorrectly set to ND. This has been resolved. The code has been corrected and is now V1.

	00011182
	(NZ only) When entering leave without pay (LWOP), an error occurred: “(14079) The text size exceeds maxLength.” This has been resolved.

	00011067
	After using the gtINStockItemSupplier FREE function, quantity break pricing was removed from stock items on the Inventory Supplier Detail Maintenance screen. This has been resolved.

	00010691
	When using Windows Designer to make Parent aspect customisations, those customisations could display incorrectly, with forms overlapping each other. This has been resolved through enhancements to the Windows Designers. For more information, see the Windows Designer update section.

	-
	On the Security tab of the HR Employee Maintenance screen, clicking Create to open the Sales Person Maintenance screen could cause an error: “(1310) Key already used in this dictionary.” This has been resolved.

	00011179
	When using Microsoft Query to retrieve data from the ODBC Exposure Tool, an error could occur: “An attempt was made to perform an operation that is prohibited in this context.” This has been resolved.

	00006187
	When creating a CRM contact on the HR Employee Maintenance screen, an error could occur: “(14079) The text size exceeds maxLength.” This has been resolved. You can now create and maintain an HR person with a surname of 30 characters.

	00010564
	When using the Data Import Manager to import a purchase order, the import adds tax for lines that are already inclusive of tax, causing the line total to calculate incorrectly. This has been resolved.

	00005949
	The AP Aged Balances report could incorrectly display current invoice values as negative. This has been resolved. Now, when applying AP Payment, Journal or Credit Note to invoices in current, previous or future periods, the Total Outstanding value is correct in the Total column.

	11257
00011302
00011418
	When importing pays, the Maintain Pay Run screen wouldn’t open even if the pays were successfully imported. This has been resolved.

	00011262
	When attaching an email file to a service request, the file could be empty and not include any of the email’s contents. This has been resolved.

	00011103
00011153
	When entering information in a search field, if there wasn’t enough area on a monitor screen to display the full table of options for the field, then the columns on the left of the table would be cut off. This has been resolved. The right edge of the table now aligns with the right edge of the monitor.

	00011021
	Opening the AR Credit Note Entry and AR Invoice Entry forms could take a long time. This has been resolved.

	00010643
	When using the Data Import Manager (DIM) to import AP credit notes, three issues would occur if negative lines were converted to invoices and the Create unapplied transaction if invoice doesn’t exist option is selected:
· The unapplied transaction for the credit note line wasn’t created.
· Details in the log file were incomplete.
· GL AP Credit Note batches were out of balance.
This has been resolved.

	00010243
00010654
00011071
00011198
	(NZ only) Employees could be overtaxed for extra pays, including bonuses, back pays and termination payouts. This has been resolved. To ensure the correct tax code is applied when creating pays, the annualisation calculation now excludes any transaction types that are set as extra pays.

	00009396
00002543
	If a sales order had a kitset with an item that hasn’t been assigned a serial/lot number, an error would occur when taking the sales order off hold: “Serial/Lot number was not found for the total line item quantity”. This has been resolved.

	00010792
	During an eReporting run that generates AR statements, an Accounts Receivable user could experience locking issues. This has been resolved. The report writer method that determines whether to include each customer has been updated to avoid locking the customer’s transaction collection.

	00010958
	(NZ only) When creating a payday lodgement from the EI amendment post 1/04/2020 interface file, the Earnings not liable for ACC Earners’ Levy field was in the incorrect position. 
This has been resolved with a new Interface Name called EI amendment post 1/04/2022. This is now the default interface on the Other tab of the Inland Revenue Reporting Configuration form.

	00011271
	The JCSalesLineItem.myJCJobSalesCode was being populated incorrectly. This has been resolved, so that the myJCJobSalesCode always includes the sales code.

	00011227
00011303
00011339
	Opening a form from the Favourites or Bookmark lists could cause an error: “You do not have privileges to this form.”

	00011309
	Depreciation values could be incorrect. In a year when an asset fully depreciated, its value would be zero. However, depreciation would continue for the following year, creating an incorrect negative value. This has been resolved.


[bookmark: _Toc98422749]Greentree Browser
	Service Request ID 
	Description

	00011127
	For a HR user, the HR & Payroll menu could be missing. This has been resolved.


[bookmark: _Toc98422750]eDocs
	Service Request ID 
	Description

	00011145
	When creating an AP invoice on the eDoc AP Invoice screen, an error could occur: “(1035) String too long.” This has been resolved.

	00010771
	Scraping a sales order could incorrectly add the customer’s purchase order number to the Order Number and Sales Order No fields, instead of just the Order Number field. This has been resolved. An updated rule is now available on FTP.

	00011031
	On the eDoc SO Sales Order form, lines on the Stock tab would not automatically match after entering a stock code and quantity. This has been resolved.

	00009295
00010208
00011281
	When copying multiple lines in an eDocs AP invoice, an error could occur: “An error has occurred (14051) Invalid Table row .”. This has been resolved.
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