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User Guide

Accountants Enterprise in Australia only

With MYOB Accountants Enterprise (AE) Reporter you can quickly and easily produce 
sophisticated reports for your practice and your clients that draw on your General 
Ledger data. Reporter will enable you to meet statutory reporting requirements with 
confidence. It is flexible enough for you to customise reports to your requirements 
and to create reports to meet your clients’ management needs. 

The key benefits of Reporter are:

 Easy to produce reports to view and access details. 

 MYOB AE Reporter uses MYOB charts, so there is no need to learn a new one. 

 Full statutory Master reports and notes provided so you can be confident of 
meeting the compliance requirements. 

 MYOB provide Management Reports to assist with your reporting requirements. 
These reports are denoted with a $ sign.

 You can design your own reports, giving you the added benefit of being able to 
provide another value-added service to your clients. 

 Graphical report designer using familiar spreadsheet functions and look and feel. 

 Ability to drag and drop accounts into reports. 

Reporter enables you to produce statutory reports for:

 Companies 

 Partnerships 

 Trusts 

 Sole Traders 

 Superannuation Funds

 Associates. 

MYOB AE Reporter includes standard reports that have been carefully designed to 
meet compliance requirements. These Masters reside on your system but are 
protected from accidental editing or deletion. They are made available to you, and to 
all the team members in your practice to use.

Most often, you launch Reporter from within your General Ledger, and you will 
operate at the Client level. You will notice that the title bar displays your client code 
to reinforce this. You are able to customise reports to suit practice wide or client 
specific needs.

When changes are made at the Practice level and saved they are known as Practice 
Masters. When changes are made from within a client ledger and saved they are 
known as Client Reports. 
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Depending on whether you are generating reports or designing and editing reports, 
you will either work in the: 

 Generating Reports window

This component of Reporter is used to run reports for your clients. 

 Report Designer window

This component of Reporter is used to design and edit the various hierarchy 
levels of reports and their components. 

Related topics

Reporter hierarchy

Designing reports

Generating reports

Maintaining Reporter
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Reporter hierarchy

Accountants Enterprise in Australia only

Each report stored within MYOB AE Reporter sits at a certain hierarchy level. There 
are three levels of hierarchy: 

 Master 

Master level reports are provided with the Reporter software. These cover the 
AASB reporting requirements for certain entity types and sizes. Master level 
templates cannot be created or edited. They can be used as a basis for creating 
Practice or Client level report templates. Each year MYOB will provide you with 
updated Master report templates to cover any AASB changes that have been 
introduced. 

Master reports and templates are distinguished by the red M icon next to the 

report name in the Report Designer or Generating Reports windows, . 

 Practice 

Practice level reports are those designed by the report designer within your 
practice and which can be used to produce reports for all the practice’s clients. 
Practice reports can be created from scratch or based on a Master or Practice 
level report template. 

Practice reports and templates are distinguished by the yellow P icon next to the 

report name in the Report Designer or Generating Reports windows, . 

 Client 

Client level reports are those created for the reporting purposes of a specific 
client. The client report will only be available for use within the Generating 
Reports window for the particular client the template was created for. Client 
report templates can be created from scratch or based on an existing report 
template of any level. 

Client reports and templates are distinguished by the blue C icon next to the 

report name in the Designer or Generating Reports windows, . 

Related topics

Designing reports

Generating reports

Maintaining Reporter
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Generating reports

Accountants Enterprise in Australia only

Reports are produced so you can:

 meet statutory reporting obligations

 be prepared for the management of a client business

 fulfil contractual obligations. 

Once all transactions and adjusting journal entries have been recorded in the General 
Ledger for a client, you can generate reports for them. 

When you open the Generating Reports window, the title bar displays the name of 
the current client ledger. The reports that are listed when the Generating Reports 
window is first opened for a client are all those that are available for the client’s 
business entity. 

You can export, print or preview more than one report at a time. 

When you launch the Generating Reports window for a client ledger, a list of 
available reports for the selected client and their business entity are displayed.

The reports are displayed in the following order:

 Compliance Reports (denoted by a hash (#)) 

 Management Reports (denoted by a dollar sign($))

 all other reports. 

All report types are listed in alphabetical order.

From the Reports list, you can: 

 Preview reports

Within the Report Preview window you can export, print, navigate through the 
report and drill down to get more information on items within the report. You 
can also refresh the ledger data to re-preview the report with the latest data.

 Print reports

You can print a report without previewing it first.

 Export report information

You can export reports to disk in *.doc, *.xls and *.pdf format.

 Deselect All

You can deselect all selected reports.

Selecting reports 

A report can be selected (or de-selected) by clicking the checkbox to the left of the 
report. 
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As soon as one report is selected, the Preview, Print, Export and Deselect All buttons 
are enabled. 

Navigation in the Generating Reports window

The Generating Reports window contains a toolbar and several elements for easy 
navigation of reports and formatting features.

Each element can be expanded and contracted using the  button.

You can show or hide the left hand pane, by clicking the  button from the toolbar.

The right-hand pane toggles the Reports element (this will show the Reporter year).

Ensure that all the elements are listed in the related topics.

Related topics

Reporter hierarchy

Generating report options

Report settings

Selecting years

Presentation of a report

Favourites

Previewing reports

Printer setup

Exporting reports

Emailing reports

Report properties

Column templates

Getting more information from reports

Non-transaction data

Searching

Masters updates

Generating report options

Accountants Enterprise in Australia only

The following options are available on the Generating Reports window:

Main menu options

The menu bar is the horizontal bar below the title bar that contains the names of 
menus. A menu is a list of commands that is displayed when you click on a name in 
the menu bar.
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The following menus and options are available from the Generating Reports window:

Option Description

File

Print Setup Select printer to use and change the printer properties.

Exit Close MYOB AE Reporter.

View

Reports Select this option to display the list of available reports.

Favourites Select this option to display the list of favourite reports 
set up for the current ledger.

Non-transaction Data Select this option open the Database Map for non-
transaction data to be entered.

Column Template 
Editor

Select this option to view, modify or delete existing 
Column Templates and create new ones.

Tools

Current Ledger 
Configuration

Select this option to specify the ledger(s) to use when 
retrieving the current ledger balances.

Ledger Year Select this option to choose a different ledger year and / 
or period to report on.

Reporter Year Select this option to choose a different Reporter year to 
use.

Report Listing Select this option to choose the reports to be displayed 
in the Generating Reports window.

Style Editor Select this option to edit the default styles.

Refresh Ledger Data Select this option to update Reporter with the current 
account balances in the general ledger.

Help

Contents Open and view the Table of Contents in the MYOB AE 
Reporter Help window.

Index Open and view the Help Index in the MYOB AE Reporter 
Help window.

About MYOB AE 
Reporter

View information about the currently installed Reporter 
product, e.g., version number. 

Click Close to return to the Reporter Generator window.
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Generating Reports window options

The Generating Reports window contains the following options in the left-hand pane: 

Option Description

Report Settings

Apply Rounding Select this option to display all figures in a report as 
rounded. This feature is dependent on the underlying 
general ledger. When a report with applied rounding is 
previewed, printed or exported, the amounts provided by 
the General Ledger system are rounded in accordance with 
the General Ledger system’s rules. 

Note: The Rounding option is only displayed if the 
underlying General Ledger is able to round 
balances. 

See “Applying rounding” on page 17.

Show page numbers Select this option to display the page numbers on the 
report below any footer content when it is printed. If this 
option is not selected, then the page numbers are not 
displayed.

See “Showing and hiding page numbers” on page 18.

Show account codes Select this option to display the account codes on the 
report when printed. If this option is un-ticked then the 
account codes does not display. 

Note: The account codes will only be included on a report 
if that option is included in the design of the report 
you select. They will display in the left-hand side 
margin for the Masters. 

See “Showing and hiding account codes” on page 19.

Report Options This option enables you to set run time parameters.

See “Setting the report options” on page 20.

Years

The Years option is used to specify the year against which the currently selected 
report(s) are run. 

See “Selecting years” on page 22.

Presentation
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Related topics

Reporter hierarchy

Report settings

Selecting years

Presentation of a report

Favourites

Previewing reports

Printer setup

Exporting reports

Emailing reports

Report properties

Column templates

Getting more information from reports

Non-transaction data

Searching

Masters updates

Font Select this option to set the font for the report. The 
selected font is used by every cell in every format used 
throughout every report. The Use Default sub-option 
indicates that the font is not to be altered during a 
preview. The font selection is saved as a user preference. 

See “Setting the font” on page 25.

Apply Watermark Select this option to toggle a watermark on and off. Click 
the ellipsis to locate a watermark to add or edit. Use the up 
and down arrow keys to select the watermark you want to 
use from the list. Click the Update Preview button to 
update the preview with the chosen watermark.

See “Adding a watermark” on page 27.

Page scaling The Page scaling drop-down list contains the following 
values: 100, 80, 75, 50 and 25%. The default is 100%. 
When you alter the scaling percentage it applies the new 
value to all previewed or printed reports from this point 
onwards. If the preview window is currently open, any 
previewed reports will be adjusted immediately to the new 
scaling percentage.

You are also able to enter any valid scaling percentage in 
the Page scaling field and press [Enter] to apply the 
scaling. The valid scaling range is 0 to 400%.

See “Scaling reports” on page 30.

Option Description
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Report settings 

Accountants Enterprise in Australia only

The first available option on the left-hand pane of the Generating Reports window is 
Report Settings.

Within Report Settings, you can:

 “Applying rounding” (see page 17)

 “Showing and hiding page numbers” (see page 18)

 “Showing and hiding account codes” (see page 19)

 “Setting the report options” (see page 20).

Related topics

Reporter hierarchy

Generating report options

Selecting years

Presentation of a report

Favourites

Previewing reports

Printer setup

Exporting reports

Emailing reports

Report properties

Column templates

Getting more information from reports

Non-transaction data

Searching

Masters updates

Applying rounding 

Accountants Enterprise in Australia only

The Apply Rounding feature is dependent on the underlying general ledger of the 
selected report. The figures provided by the general ledger system are rounded in 
accordance with the General Ledger system’s rules.

Note: The Apply Rounding option is only available if the underlying general ledger 
is able to round balances.
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To apply rounding to report figures

1. Within your General Ledger software, and with the required client ledger open, 
select Reports > Reporter > Generate reports. 

The Generating Reports window opens for the client. 

2. Select a report by clicking the adjacent checkbox in the Select column. 

3. Click the Report Settings option. 

4. Select the Apply Rounding checkbox.

There is a tick in the Apply Rounding checkbox.

5. Click the Preview button to view your report. 

To not apply rounding to report figures

1. Within your General Ledger software, and with the required client ledger open, 
select Reports > Reporter > Generate reports. 

The Generating Reports window opens for the client. 

2. Select a report by clicking the adjacent checkbox in the Select column. 

3. Click the Report Settings option. 

4. Deselect the Apply Rounding checkbox.

There is no tick in the Apply Rounding checkbox.

5. Click the Preview button to view your report. 

Related topics

Report settings

Showing and hiding page numbers

Showing and hiding account codes

Setting the report options

Showing and hiding page numbers

Accountants Enterprise in Australia only

Page numbers can be displayed on a report below any footer content, when printed.

To show page numbers on reports

1. Within your General Ledger software, and with the required client ledger open, 
select Reports > Reporter > Generate reports. 
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The Generating Reports window opens for the client. 

2. Select a report by clicking the adjacent checkbox in the Select column. 

3. Click the Report Settings option. 

4. Select the Show page numbers checkbox.

There is a tick in the Show page numbers checkbox.

5. Click the Preview button to view your report. 

To hide page numbers on reports

1. Within your General Ledger software, and with the required client ledger open, 
select Reports > Reporter > Generate reports. 

The Generating Reports window opens for the client. 

2. Select a report by clicking the adjacent checkbox in the Select column. 

3. Click the Report Settings option. 

4. Deselect the Show page numbers checkbox.

There is no tick in the Show page numbers checkbox.

5. Click the Preview button to view your report. 

Related topics

Report settings

Applying rounding

Showing and hiding account codes

Setting the report options

Showing and hiding account codes

Accountants Enterprise in Australia only

You can display account codes on a report when printed. 

Note: The account codes will only be included on a report if that option is included 
in the design of the report you select. They will display in the left-hand side 
margin for the Masters. For example, a Detailed Balance Sheet or Detailed 
Profit and Loss.
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To show account codes on reports

1. Within your General Ledger software, and with the required client ledger open, 
select Reports > Reporter > Generate reports. 

The Generating Reports window opens for the client. 

2. Select a report by clicking the adjacent checkbox in the Select column. 

3. Click the Report Settings option. 

4. Select the Show account codes checkbox.

There is a tick in the Show account codes checkbox.

5. Click the Preview button to view your report. 

To hide account codes on reports

1. Within your General Ledger software, and with the required client ledger open, 
select Reports > Reporter > Generate reports. 

The Generating Reports window opens for the client. 

2. Select a report by clicking the adjacent checkbox in the Select column. 

3. Click the Report Settings option. 

4. Deselect the Show account codes checkbox.

There is no tick in the Show account codes checkbox.

5. Click the Preview button to view your report. 

Related topics

Report settings

Applying rounding

Showing and hiding page numbers

Setting the report options

Setting the report options

Accountants Enterprise in Australia only

The Report Options edit box displays a short description summarising the options that 
have values. When there are no options specified, the edit box displays None, 
otherwise the summary displays a list of fields that have been filtered or altered.

Clicking the Report Option button displays the same report options as the Properties 
window. Any setting specified in this area override the settings specified for each 
report.
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The settings specified here are ledger-specific, any changes made will be saved on a 
per ledger basis.

The settings available vary between different General Ledgers. When you make 
changes to the report options, the settings are stored separately to the report. The 
changes made in the Generator are applied to the current session only. It is available 
for all reports in both the Generator and Designer.

To set the report options from the Generating Reports window

1. Within your General Ledger software, and with the required client ledger open, 
select Reports > Reporter > Generate reports. 

The Generating Reports window opens for the client. 

2. Select a report by clicking the adjacent checkbox in the Select column. 

3. Click the Properties button.

The Properties window opens.

4. Click the Report Options tab.

or

Click the ellipsis next to the Report Options drop-down list in the Report 
Settings option. 

The Report Options window opens.

5. Enter the appropriate information:

a. For MAS — type in the Account code and/or Division

b. For Accounts — type in the Account code, Branch and/or Division.

6. Click OK.

Tip: Report Options can also be set in the Report Designer window by selecting 
Tools > Report Settings, then click on the ellipsis next to the Report Options 
edit box.

Related topics

Report settings

Applying rounding

Showing and hiding page numbers

Showing and hiding account codes
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Selecting years

Accountants Enterprise in Australia only

The Years option on the left-hand pane of the Generating Reports window is used to 
specify the year against which the currently selected report(s) are run. 

Reporter will default the Ledger Year to the current financial year (and current 
financial period for periodic ledgers) using reports for the current year.

Reporter enables you to generate a report for a year other than the current financial 
year, and for a period other than the current period for periodic ledgers. The General 
Ledger determines which ledger years /periods are available for reports. The periods 
are taken from the General Ledger, therefore if the General Ledger is a quarterly 
ledger, four periods display in the list. The Reporter Year can also be changed to 
produce reports using the designs from earlier years.

Note: The Years option is only available where the General Ledger system is able to 
provide account balances for more than one year. 

Within the Years option, you can:

 “Selecting the reporter year” (see page 23)

 “Selecting the ledger year” (see page 23).

Related topics

Reporter hierarchy

Generating report options

Report settings

Presentation of a report

Favourites

Previewing reports

Printer setup

Exporting reports

Emailing reports

Report properties

Column templates

Getting more information from reports

Non-transaction data

Searching

Masters updates
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Selecting the reporter year

Accountants Enterprise in Australia only

To select a reporter year from within the Generating Reports window

1. Within your General Ledger software, and with the required client ledger open, 
select Reports > Reporter > Generate reports. 

The Generating Reports window opens for the client. 

2. Select a report by clicking the adjacent checkbox in the Select column. 

3. Click the Years option. 

4. Click the ellipsis at the end of the Reporter Year field to view the available 
reporting years.

The Reporter year selection window opens with the currently selected year 
highlighted in the list box.

5. Select the reporting year, that you want to use to provide the client data for the 
reports, from the list box

6. Click OK.

7. Click the Preview button to view your report.

To select a reporter year using the Tools main menu option

1. In the Generating Reports or Report Designer window, select Tools > Reporter 
Year.

The Reporter year selection window opens with the currently selected year 
highlighted in the list box.

2. Select the reporting year, that you want to use to provide the client data for the 
reports, from the list box

3. Click OK.

Related topics

Selecting years

Selecting the ledger year

Selecting the ledger year

Accountants Enterprise in Australia only
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To change the current ledger year from within the Generating Reports window

1. Within your General Ledger software, and with the required client ledger open, 
select Reports > Reporter > Generate reports. 

The Generating Reports window opens for the client. 

2. Select a report by clicking the adjacent checkbox in the Select column. 

3. Click the Years options. 

4. Click the ellipsis at the end of the Ledger Year field to view the available ledger 
years.

The Ledger year selection window opens with the currently selected year 
highlighted in the list box.

5. Select the ledger year you want to use to provide the client data for the reports, 
from the list box. 

6. Select the period that you use as the current period when obtaining ledger 
balances.

If the ledger year has more than one period, the Period drop-down list is 
enabled. 

7. Click OK. 

8. Click the Preview button to view your report.

To select the ledger year using the Tools main menu option

1. In the Generating Reports or Report Designer window, select Tools > Ledger 
Year.

The Ledger year selection window opens with the currently selected year 
highlighted in the list box.

2. Select the ledger year you want to use to provide the client data for the reports, 
from the list box. 

3. Select the period that you use as the current period when obtaining ledger 
balances.

If the ledger year has more than one period, the Period drop-down list is 
enabled. 

4. Click OK. 

Related topics

Selecting years

Selecting the reporter year
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Presentation of a report

Accountants Enterprise in Australia only

The third option on the left-hand pane of the Generating Reports window is 
Presentation.

Within the Presentation option, you can:

 “Setting the font” (see page 25)

 “Using the style editor” (see page 27)

 “Adding a watermark” (see page 27)

 “Scaling reports” (see page 30).

Related topics

Reporter hierarchy

Generating report options

Report settings

Selecting years

Favourites

Previewing reports

Printer setup

Exporting reports

Emailing reports

Report properties

Column templates

Getting more information from reports

Non-transaction data

Setting the font

Accountants Enterprise in Australia only

The specified font is used in every cell of every format for every report. This can be 
configured for an individual report or for all reports or for a favourite.

Note: The default font is Arial. 

To change the default font for a report from the Generating Reports window

1. From the Reports or Favourites view, click the ellipsis in the Properties column. 

The Properties window for the report or favourite opens. 



Generating reports

MYOB AE Reporter | Version 3.4 User Guide | 26

2. Click the General tab.

3. Select the font from the Font drop-down list.

4. Click OK.

The changes are saved.

To change the default font for all reports from the Generating Reports window

1. From the Reports or Favourites view, select a font from the Font drop-down list 
in the Presentation option. 

The selected font will override all fonts configured for individual reports.

To change the default font for a report from the Report Designer window

1. Open the report in Report Editor. 

The Properties window opens for the report. 

2. Select the report name.

The report name is highlighted.

3. Click Properties on the toolbar.

The Report element properties window opens for the report. 

4. Click the Element tab.

5. Select the font from the Font drop-down list.

6. Click OK to save the change.

To change the default font for all reports from the Report Designer window

1. Select Tools > Font Selection from the main menu.

2. Select the required font from the Font drop-down list. 

The selected font selected will override all fonts configured for individual 
reports.

Related topics

Presentation of a report

Using the style editor

Adding a watermark

Scaling reports
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Using the style editor

Accountants Enterprise in Australia only

To edit a default style from the Generating Reports window

1. Within your General Ledger software, and with the required client ledger open, 
select Reports > Reporter > Generate reports. 

The Generating Reports window opens for the client.

2. Select Tools > Style Editor from the main menu.

The Style Editor window opens. 

3. Select the style to be edited from the list on the left. 

4. Work your way through the tabs in the window editing the format of the style as 
required. 

For more information, see: 

 “Category tab” (see page 168)

 “Text tab” (see page 170)

 “Alignment tab” (see page 167)

 “Font tab” (see page 169)

 “Border tab” (see page 168)

 “Pattern tab” (see page 169)

5. Click Apply to save the style.

6. Click Close.

You are returned to the Generating Reports window. 

Related topics

Presentation of a report

Setting the font

Adding a watermark

Scaling reports

Adding a watermark

Accountants Enterprise in Australia only

When you add a watermark to a report, the watermark will appear when you:

 preview the selected report
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 print the selected report

 export the report to PDF.

Note: All watermark settings are saved and are then loaded whenever Reporter is 
launched. The settings are saved by ledger, therefore they are a ledger setting 
not a user setting.

To add a watermark to a report from the Generating Reports window

1. Within your General Ledger software, and with the required client ledger open, 
select Reports > Reporter > Generate reports. 

The Generating Reports window opens for the client. 

2. Select a report.

3. Within Generator, click the Presentation option.

4. Select the Apply Watermark checkbox.

Tip: To remove a watermark, deselect the Apply Watermark checkbox.

5. Click the ellipsis.

The Watermark Editor window opens.

6. Click  to create a new watermark.

7. Click the Type tab.

8. Select the watermark type.

There are 2 types:

a. Text

If you selected Text, enter the text that you want to use as your watermark.

Select a colour by clicking on the down arrow under colour.

Select a Font, Size and whether you want it to be bold or italic.

Set the rotation.

b. Picture

If you selected Picture, select the picture location. The drop-down list 
displays the names of picture files that have been stored in the directory 
specified in the Location field in the Share picture on server section of the 
Picture location window.
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Click the ellipsis to select a new location.

Select the Share picture on server checkbox, if you want other team 
members to access it and set the location and filename.

The watermark appears in the list, .

9. Click the Location tab.

10. Set the location of the watermark by clicking any of the blue squares under 
Alignment.

or

You can Fine Tune the location of the watermark by entering in the vertical 
offset and the horizontal offset in centimetres.

11. Click the Page Range tab.

12. Select the page range the watermark is to appear on.

The options are: 

 All Pages

 First Page Only

 Odd Pages Only

 Even Pages Only

 Last Page Only

 Pages (if you select this you must enter the page numbers).

13. Click Apply.

14. Click Close.

In the Presentation section, a list of configured watermarks is displayed. The 
arrow buttons along the right-hand side of the list box enable you to control the 
order in which watermarks are drawn on the page. The drop-down list displays a 
list of watermarks.

15. Click the Update Preview button to apply the new watermark to any previewed 
reports without having to re-preview them.

Tip: The Update Preview button is enabled when a change has been 
made to the watermark and a report is being previewed. 

Related topics

Presentation of a report

Setting the font
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Using the style editor

Scaling reports

Adding a watermark to a report using the Designer

Scaling reports

Accountants Enterprise in Australia only

Altering the scale of a report changes the size of the print in relation to the paper. 
Therefore, if the print does not fit on the page initially, adjusting the scale will change 
the size of the print to fit on the page.

Altering the scaling percentage applies the new value to all previewed and printed 
reports from this point onwards. If the preview or print window is currently open, 
reports will be adjusted immediately to the new scaling percentage.

Note: Reports are designed for best presentation across one page. It is 
recommended that scaling be used for this purpose.

To scale a report from the Generating Reports window

1. Within your General Ledger software, and with the required client ledger open, 
select Reports > Reporter > Generate reports.

The Generating Reports window opens for the client. 

2. Click the Presentation option. 

3. Click the drop-down list next to Page scaling and select the new value (100, 80, 
75, 50 and 25). 

You can also enter a value ranging from 1 to 400.

4. Select a report.

5. Click Preview.

To scale a report from the Report Designer window

1. Select Tools > Scaling.

Related topics

Presentation of a report

Setting the font

Using the style editor

Adding a watermark
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Favourites

Accountants Enterprise in Australia only

The Favourites feature enables you to create a custom list of reports with different 
column templates. Favourites only exist at the Client level and are only available from 
the Generator window.

The Name field must be unique for all favourites. The Report field must indicate 
which reports to run. 

The View Column Template By Template Name option enables you to change the 
formats with column template with just one click using the template name. The View 
Column Template By Format option enables you to reassign the template for 
individual formats.

Any changes that are made using the Properties window for any favourite will be 
saved with the associated favourite.

On the left hand side of the favourites area is a list of all the favourites that have been 
created.

To use a favourite

1. Select the checkbox next to the favourite.

2. Click Reports to return to the Report List.

To view the properties of the favourite

1. Click .

To delete a favourite

1. Select the checkbox next to the favourite.

2. Click .

Related topics

Creating a favourites list

Reporter hierarchy
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Creating a favourites list

Accountants Enterprise in Australia only

To create a favourites list from the Generating Reports window

1. Within your General Ledger software, and with the required client ledger open, 
select Reports > Reporter > Generate reports. 

The Generating Reports window opens for the client. 

2. Click the Favourites button.

The Favourites window is displayed. 

3. Click . 

The Favourite Configuration window opens for you to enter information about 
your new favourite.

4. Enter the Name of the favourite.

The Name cannot be blank and must be unique.

5. Enter the Report to run.

6. Enter the appropriate Font.

7. Select the appropriate View Column Template By option.

a. The Template Name option enables you to alter all formats with column 
templates using the template name. When previewed the report will 
replace the configuration in the left column with the template on the right.

b. The Format option enables you to reassign the template for individual 
formats.

8. Click Apply.
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Related topics
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Presentation of a report

Previewing reports

Accountants Enterprise in Australia only

The Report Preview window displays all the reports selected for previewing. Each 
report has its own tab. The tabs are at the bottom of the Report Preview window. 
Click the tabs to view each report. Previewing reports enables you to see what a 
report will look like before you print it and to review the contents for completeness. 

Previewing a report enables you to see what it will look like and check it for 
correctness and completeness, before either printing or exporting it to another 
format. You can preview more than one report at a time. Reports selected for 
previewing appear one after another in the tabs of the Report Preview window, in 
the order in which they appear in the list. Be aware that the more reports you select, 
the longer it takes for the Report Preview window to display. 

How the report displays on screen, in regard to bolding, margins, page breaks, 
borders and colours used on your report is how it will look when you print it. 

Report Preview window toolbar options 

Option Description

Print Report

 

Prints the report currently being previewed. The 
settings in the Printer option are used for the 
print job.

Email Report Select this option to open the Email Report as 
an Attachment window. This enables you to 
enter a filename and select the file type 
(Microsoft Word, Excel or pdf). Clicking the 
Options button enables you to set a password 
for the report, compress the attachment and 
save the attachment.

Export Report Select this option to open the Microsoft 
Windows Select export file window. If you have 
previewed more than one report, you will have 
to export each report individually by selecting 
the appropriate tab.
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To preview a report from the Generating Reports window

1. Select the report(s) you want to preview from report list. 

2. Click the Preview button. 

The Report Preview window opens containing the report(s) you selected to 
preview. Each report has its own tab. 

Refresh ledger data Select this option to refresh report balances 
with any changes that have been made to an 
account since the report was run. Changes are 
retrieved from the ledger accounts on which the 
report is being run and displayed in the report. 

Zoom Use this field to increase the magnification of 
your report preview. Click the drop-down arrow 
and select another magnification setting from 
the drop-down list. The report initially displays 
at Full Page or 100% magnification. 

To zoom in and out of the report, you can also 

use the magnifying glass .

Pages Shows the page number of the page currently 
displayed, relative to the total number of pages. 
Enter any page number into the field to go to 
that page.

Show first page Select this option to display the first page in a 
report. 

Show previous page Select this option to display the page preceding 
the current page. 

Show next page Select this option to display the next 
consecutive page.

Show last page Select this option to display the last page in a 
report. 

Close Closes the Report Preview window and returns 
you to the Generating Reports window. 

Option Description
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Note: If specific rows that you are expecting to see in a report are not 
appearing, check whether it is because there is a reference (either 
a direct reference to a database field or a print condition, which are 
accessible from the Report Designer) to a database field that has 
not been populated. You may need to work with the person 
responsible for designing reports to determine whether this is the 
case. If required, you can enter any required data from the 
Generating Reports window. 
There will not be anything in a report to indicate that a database 
reference did not return any data.

To view the attributes of a report

1. Click the Set Report Attributes button.

The Report Attributes window opens.

2. View the attributes for the reports listed within the Report Designer window.

If you have the required access rights, you can change the following attributes of 
the report:

 Disclosure Level (reporting or non-reporting)

 Entity Size (small or large)

 Reporting Period (select the applicable year).
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Searching

Accountants Enterprise in Australia only

To search for a Format, Database Map table or field, Chart Map folder or account 
range within Report Designer

1. Click the Search button.

The Search window opens.

2. Type the item you wish to search for (Format, Database Field, Chart Map folder 
or account) in the Type field.

or 

Select the item from the Type drop-down.

3. Enter the value for the item you are searching for in the Value field, or make a 
selection from the list box. 

If the Type selected is Format, Database Field or Chart Map folder, then the 
Value list box contains all of the available items of the selected type. 

If the Type selected is Account, the list box contains the last 10 values searched 
for. 

The Look In area contains four checkboxes labelled Chart Map, Database Map, 
Formats and Reports. These are enables as follows: 

 if the Type selected is Format, the Report checkbox is selected and the 
others are disabled. 

 if the Type selected is Database Field, the Database Map, Formats and 
Reports checkboxes are enabled and selected while the Chart Map 
checkbox is disabled and not selected. 

 if the Type selected is Chart Map folder, the Chart Map, Formats and 
Reports checkboxes are enabled and selected while the Database Map 
checkbox is disabled and not selected. 

 if the Type selected is Account, the Chart Map, Formats and Reports 
checkboxes are enabled and selected while the Database Map checkbox is 
disabled and not selected. 

You can deselect some of the checkboxes if you want to only search in one or 
two areas. 

4. When you have defined your search criteria, click the Search button. 

The results will be displayed in the Search Results area. 

You can click on a column heading in the Search Results area to sort the list by 
that column in either ascending or descending order. 

Double–click on an item in the Search Results area to open that item in the 
appropriate editor and highlight it in the Explorer pane. 
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Accountants Enterprise in Australia only

Within the Generating Reports window you can set which printer to print to and the 
number of copies required. 

Tip: The Printer Setup can also be changed from the Report Designer window by 
selecting File > Print Setup. 

To define the print settings from the Generating Reports window

1. Within your General Ledger software, and with the required client ledger open, 
select Reports > Reporter > Generate reports.

The Generating Reports window opens for the client with the default tab 
displayed. 

2. Select a report by clicking the adjacent checkbox in the Select column. 

3. Click File > Print Setup. 

The Printer setup window opens.

4. Select the required printer from the Printer drop-down list. 

The drop-down list contains the list of printers that have been set up on your PC 
in Windows. 

5. Enter the number of Copies you want to print.
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6. Select the Collate checkbox, if required.

If this option is selected, your copies will be collated during printing.

7. To change other printer settings such as the paper source, click Properties.

The selected printer Properties window opens. The tabs and options available in 
the window will depend on the printer being selected.

a. Change the printer settings as required.

b. Click OK.

The printer Properties window closes.

8. Click OK to print your report. 

Related topics
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Printing reports 

Accountants Enterprise in Australia only

Reports can be printed from the Generating Reports window or from the Preview 
window. 

Tip: It is good practice to always review a report on screen before printing it. The 
Preview button enables you to do this. 
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To print a report from the Generating Reports window

1. Within your General Ledger software, and with the required client ledger open, 
select Reports > Reporter > Generate reports.

The Generating Reports window opens for the client with the default tab 
displayed. 

2. Select a report by clicking the adjacent checkbox in the Select column. 

3. Check that the printer selection is correct in the File > Print Setup.

4. Enter the number of Copies required.

5. Select the Collate checkbox, if you want the copies to be collated during printing.

6. Click the Print button. 

To print a report from the preview option

1. Within your General Ledger software, and with the required client ledger open, 
select Reports > Reporter > Generate reports.

The Generating Reports window opens for the client with the default tab 
displayed. 

2. Select a report by clicking the adjacent checkbox in the Select column. 

3. Click the Preview button on the Reports window. 

The selected reports are displayed in the Report Preview window. 

4. Click the Print button  on the toolbar.

The report(s) will be sent to the printer specified in the Print Setup. 
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Column templates
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Exporting reports

Accountants Enterprise in Australia only

You can save the contents of a report to another application format, e.g.,Microsoft 
Word or Excel. This enables you to save a client’s reports with their other documents 
in your Practice Management system. 

If you select more than one report in the list, the export process will ask you to save 
each report as a separate file. 

You can export to the following formats: 

 *.doc

 *.xls

 *.pdf

Reports can be exported from the Generating Reports window or from the Report 
Preview window. 

To export a report from the Generating Reports window

1. Within your General Ledger software, and with the required client ledger open, 
select Reports > Reporter > Generate reports.

The Generating Reports window opens for the client with the default tab 
displayed. 

2. Select a report by clicking the adjacent checkbox in the Select column. 

3. Click the Export button. 

The Select Export File window opens.

4. Select the folder in the Save in field to which the exported file will be saved.

5. Enter the File name of the export file.

6. Select the export format type from the Save as type field.

7. Click OK to begin the export. 
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This may take some time, depending on the size and number of reports selected. 
The hourglass cursor displays while processing is taking place. When the cursor 
returns to the pointer, this indicates that your export has completed. 

8. Go to the directory to which you saved the exported file and locate the file you 
specified. 

To export a report from the Report Preview window

1. Preview the report that you want to export.

2. Click .

The Select Export File window opens.

3. Select the folder in the Save in field to which the exported file will be saved.

4. Enter the File name of the export file.

5. Select the export format type from the Save as type field.

6. Click OK to begin the export. 

This may take some time, depending on the size and number of reports selected. 
The hourglass cursor displays while processing is taking place. When the cursor 
returns to the pointer, this indicates that your export has completed. 

7. Go to the directory to which you saved the exported file and locate the file you 
specified. 
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Masters updates

Emailing reports

Accountants Enterprise in Australia only

When you are previewing a report you have the option to email it as an attachment 
using your email application, such as Microsoft Outlook and Lotus Notes. You can 
select to attach the report as an Microsoft Excel spreadsheet, a Microsoft Word 
document or a PDF. 

When you click the Options button on the Email Report as an Attachment window, 
you have the options to secure the report with a password, compress the attachment 
using WinZip and to save the attachment.

To email a report from the Generating Reports window

1. Within your General Ledger software, and with the required client ledger open, 
select Reports > Reporter > Generate reports.

The Generating Reports window opens for the client with the default tab 
displayed. 

2. Select a report by clicking the adjacent checkbox in the Select column. 

3. Click Preview.

4. Click .

The Email Report as an Attachment window opens.

5. For the Attachment Settings:

a. Enter a File Name.

You can also choose to keep the default name.

b. Select a File Type from the drop-down list.

6. Click the Options button. 

Select the following options as required:

a. Select the Password protect the attachment option to secure your report. 

Enter the password and re-type it to confirm.

b. Select the Compress the Attachment option, to compress the email 
attachment using WinZip.

c. Select the Save the attachment option to save the attachment.
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Click the ellipsis to change the default directory.

7. Click Email.

An Untitled email message will open with the report attached.

8. Enter or select the recipient's email address and if necessary type a message (as 
you normally would).

9. Click Send.
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Report properties

Accountants Enterprise in Australia only

Certain properties for a selected report can be viewed and changed within the 
Properties of <report name> window. This window is accessed from the Reports 

option in the Generating Reports window by clicking the Properties button,  for a 
particular report. 

The Properties of <report name> window contains the following tabs: 

 General 

The General tab displays information about the report. The information you can 
view here covers the following:

 Type — whether it is a Master, Practice or Client level report.
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See “Reporter hierarchy” on page 11.

 Reporting Period — the year(s) for which the report is applicable.

 Entity Type — the business structure that distinguishes companies, 
partnerships, trusts and so on.

 Description — displays any notes that were entered by the report designer. 

 Font — lists the available fonts or the default font can be used.

See “Setting the font” on page 25.

 Column Templates — this drop-down enables you to change the column 
template for the report. 

 Default Format Column Template(s) — contains a list of unique names of all 
column templates used in any format in the report. 

 Page Setup 

The Page Setup tab is where you define the page orientation required for the 
selected report when it is previewed or printed. 

See “Changing the orientation for generated reports” on page 45.

 Margins 

You can view and edit the top, bottom, left and right margins for the reports. 

See “Setting the margins for generated reports” on page 46.

 Watermarks

This is where you can apply a watermark that has been previously created. 

See “Adding a watermark to generated reports” on page 46.

 Report Options

See “Setting the report options” on page 20.
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Changing the orientation for generated reports

Accountants Enterprise in Australia only

The Page Setup tab is where you define the page orientation required for the selected 
report when it is previewed or printed. You can choose portrait or landscape. By 
default the system selects the orientation options which best suit the selected report 
based on the current page orientation settings. 

Note: Any change to the default page orientation setting is only valid for the current 
session. 

To change the orientation of a report from the Generating Reports window

1. Open the Generating Reports window.

2. Click the Properties button for the report whose orientation is to be changed.

3. Click the Page Setup tab.

4. Select Portrait or Landscape, as required.

5. Click OK.
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Setting the margins for generated reports

Accountants Enterprise in Australia only

You can view and, if required, edit the top, bottom, left and right margins for the 
reports. The default margin settings as previously designed for the report are initially 
displayed. These defaults are restored at the beginning of each session. 

You can set the Unit of Measurement by clicking the ellipsis and choosing either 
Centimetres, Inches or Millimetres.

If you change the margin settings, then want to set them back to the default without 
closing and re–opening Reporter, simply click the Restore Defaults button. 

To set the margins of a report from the Generating Reports window

1. Open the Generating Reports window.

2. Click the Properties button for the report whose margins are to be changed.

3. Click the Margins tab.

4. Enter a value for Left, Right, Top and Bottom margins.

You can use the arrow buttons or type in a value for the margins.

5. Click OK.
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Adding a watermark to generated reports

Accountants Enterprise in Australia only

You can apply a watermark that has been previously created. You can also add a 

condition for the watermark and click  to check the syntax of the condition.

To add a watermark from the Generating Reports window using the Properties 
window

1. Open the Generating Reports window.
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2. Click the Properties button for the selected report.

3. Click the Watermarks tab.

4. Select the Watermark that you want to add to the report from the drop-down 
list. 

Use the arrow keys on the right to change the order of the watermarks. The 
watermark at the top of the list will appear on top of the other watermarks...and 
so on.

5. Enter a condition for the watermark and click .

If you leave the condition blank the watermark always prints.

6. Click OK.
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Column templates

Accountants Enterprise in Australia only

Creating a Column Template makes setting up the columns that you want to appear 
on a report easier. It enables you to create columns based on actuals, receipts, 
payments, cash and budget for different periods and different years. You can apply 
headings and create formulas for each column within your template.

Once a Column Template has been created you can apply it to any report that appears 
in your report list. Therefore, you do not need to format each report’s columns.

You can only create Client level templates in the Reporter Generator. If you want to 
create templates at the Practice level you have to use the Reporter Designer. MYOB 
have included Master level templates.

From the Generator window you can edit or delete existing templates or create new 
client templates. 

The Use Default template selects the default column template that is specified for the 
report. 
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Note: A test configuration drop-down is available on the Report Editor toolbar in 
the Report Designer. This drop down enables you to preview the report using 
a saved column template. The default selection is Use Default.
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Creating and editing column templates

Accountants Enterprise in Australia only

To create or edit column templates

1. Within your General Ledger software, and with the required client ledger open, 
select Reports > Reporter > Generate reports. 
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Note: For MAS users: To access reports at the Practice level, select 
Reports > Reporter > Design Practice Reports. 
For Accounts users: Open the Configuration window, Start > 
Programs > MYOB Accountants Enterprise > Configuration. Then 
select Configure > Accounts > Report Designer.

2. From the Generating Reports window, click the Column Template Editor button 
on the toolbar.

or

From the Report Designer window, click Tools > Column Template Editor.

3. Click the New column template  icon to create a new column template.

4. Complete the required details. 

5. Click Apply.

Note: You must click Apply after you have completed the details for each 
column. 

6. When you have completed the template, click Close.

Related topics
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Deleting column templates

Accountants Enterprise in Australia only

To delete a column template from the Generating Reports window

1. Within your General Ledger software, and with the required client ledger open, 
select Reports > Reporter > Generate reports. 

The Generating Reports window opens for the client. 
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2. Click the Column Template Editor button on the toolbar.

3. Select the column template that is to be deleted.

4. Click .

Related topics

Column templates
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Column template properties

Accountants Enterprise in Australia only

Column template properties include:

 Column template name

This appears to the left of the report list in the Report Generator for you to apply 
it to the selected report. 

Note: The column template name must be unique.

 Columns defined by

The following options are available for Columns defined by:

 The User option enables you to define a specific number of columns to meet 
the needs of a particular client.

 The Ledger option enables you to create a column template that will vary 
the number of columns based on the structure and state of the ledger with 
which it is being used.

For example, a user-defined column template containing 4 columns, one for 
each period from 1 to 4, would only be usable with a 4-period ledger. To 
achieve a similar result for a 12-period ledger, a second column template, 
containing 12 columns, would have to be created.

Alternatively, a single, ledger-defined column template could be created at 
the practice level for use with both ledgers. This column template would 



Generating reports

MYOB AE Reporter | Version 3.4 User Guide | 51

automatically adjust the number of columns based on the number of 
periods being used in the ledger.

 Insert page break for each

Select this checkbox to insert a page break between columns that have been 
filtered to display different values for the item listed in the adjacent field.

For example, if you select Division in the adjacent field, a page break will be 
inserted between columns that have been filtered to display accounts with 
different divisions.

 Number of columns per page

Select the checkbox to insert a page break after the number of columns 
indicated in the adjacent field.

For example, if you enter 2 into the adjacent field, a page break will be inserted 
after every 2 columns.

Related topics
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Defining column headings

Accountants Enterprise in Australia only

Heading variables can be used when you want a cell in a format to be able to display 
different values in the different columns generated by a column template.

When you add a heading variable to one column in a column template, it will 
automatically be added to all other columns in the template.

To add a heading variable to the template

1. Click  or .

2. Enter the Name by which the heading variable will be referenced in a format.

By default, the heading variables will be named %HEADING1%, %HEADING2%, 
%HEADING3% and so on. These names can be edited if required.
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The name of a heading variable must begin and end with percentage signs (%). If 
you enter a name that does not begin and end with percentage signs, they will 
be inserted automatically.

3. Enter the Value/Formula that will be shown in the cell on the format or the 
formula used to derive the value.

The contents of the Value/Formula field will be inserted into any cell in which 
the heading variable is referenced when this column is generated as part of a 
previewed report or format.

If the contents of the Value/Formula field are preceded by an equal sign (=), 
they will be evaluated as a formula and the results of the formula will be 
displayed in the preview.

If the contents of the Value/Formula field are not preceded by an equal sign (=), 
they will be displayed in the preview as text.

4. Enter the Style to apply to the heading.

Style changes can be applied to a heading variable if you require the heading 
variable to be displayed with different formatting from the rest of the column.

To apply specific style formatting to a heading variable, click  and make the 
required changes in the Column style dialog. The changes made here will 
override any style settings that have been specified for the column.

When you click OK in the Column style dialog, the  will change to  to 
indicate that style changes have been made.

To undo the style changes and revert to the formatting of the column, right-click 

on  and select Remove style.

See “Working with styles” on page 163.

To apply style changes to columns and headings

Style changes can be applied to a particular column within a column template, if you 
require the column to be displayed with different formatting than what might be 
specified in the Format Editor.

To apply specific style formatting to a column:

1. Click .

The Column style dialog opens.

2. Make the required changes.

Note: The changes made here will override any style settings that have 
been specified in the Format Editor.
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3. Click OK.

The contents of the Style field will change from Specified by cell to Altered for 
current column.

To undo the style changes and revert to the formatting specified in the Format 
Editor

1. Right click on the Style field and select Remove style.

To repeat left-hand columns on overflowed pages

The Repeat Lefthand columns item is visible if the Lefthand format columns item is 
selected in the Column Definition listing.

Select the checkbox to have the contents of the Lefthand format columns appear on 
multiple pages, if the columns generated by the column template exceed one page.

To remove a heading variable

1. Click .

When you remove a heading variable from one column in a column template, it 
will automatically be removed from all other columns in the template.

To reference a heading variable in a format

Enter the name of the variable into a cell. Make sure that you precede the heading 
variable name by an equal sign. For example, =%HEADING1%.F1.

Related topics
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Columns defined by user

Accountants Enterprise in Australia only

Available options for Columns Defined by User.
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Left-hand format columns

This item represents the column(s) to the left of the column(s) to which the template 
has been applied in a format.

For example, in a format where the column template is applied to columns C and D, 
the Lefthand format columns item represents columns A and B. Moving the Lefthand 
format columns item up and down in the Column Definition listing allows you to 
position these columns on the page relative to the columns generated by the 
template.

To add a new column

1. From the Generator window, click the Column Template Editor button on the 
toolbar.

or

From the Designer window, click Tools > Column Template Editor.

2. For the Columns defined by field, select the User option.

3. In the Column Definition section, click the New column button.

At the bottom of the Column Definition section, fields become available. 

See “General column properties” on page 55 for more details.

4. Enter the Name of the column.

The Name must be unique within the column template.

5. Specify the Balance type for this column.

6. Specify the Year to use when retrieving balances for this column.

Option Description

New Adds a new column to the template.

Delete Deletes the selected column from the template.

Move Up Moves the selected column up one place in the list.

Move Down Moves the selected column down one place in the list.
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7. To have the figures set as Year to Date, the Period Start is set to Period 1 which 
cannot be changed.

8. To have the figures Movement based, both the Period Start and Period End are 
enabled.

9. Click the Advanced button to launch the Advanced column properties dialog.

See “Advanced column properties” on page 58.

10. Click Apply.

Related topics

Column templates

Creating and editing column templates

Deleting column templates

Column template properties

Defining column headings

General column properties

Advanced column properties

Column defined by ledger

General column properties

Accountants Enterprise in Australia only

Available column property options:

Option Description

Advanced 
Column 
Properties

Click this button to launch the Advanced column properties 
dialog. This dialog has four tabs:

•  General

•  Filtering

•  Condition 

•  Ledger. 

See “Advanced column properties” on page 58.
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Balance Type Specify the balance type of the general ledger values that you 
want to be displayed in the selected cell(s) or column. The default 
balance type is Actuals.

For example, if you select Division in the adjacent field, a page 
break will be inserted between columns that have been filtered 
to display accounts with different divisions.

The balance types available for Accounts are:

•  actuals

•  opening balance

•  closing balance

•  cash

•  receipts

•  payments

•  non-cash movements

•  quantity

•  opening balance (quantity)

•  closing balance (quantity)

•  budget year to date

•  budget period.

The balance types available for MAS are:

•  actuals

•  receipts

•  payments

•  cash

•  bal2

•  budget (current)

•  budget-bal2 (current)

•  budget (projected)

budget-bal2 (projected).

Movement To have the figures Movement based. Both the start and end 
periods are enabled.

Name Specify a name for the column. The name must be unique within 
the column template.

This name can be referred to in the Formula field under the 
General tab of the Advanced column properties dialog to create 
calculation columns.

Option Description
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Related topics

Column templates

Creating and editing column templates

Deleting column templates

Column template properties

Defining column headings

Columns defined by user

Advanced column properties

Period End When a ledger contains more than one period and the 
Movement option is selected, this drop-down menu is enabled to 
specify the ending period to be used when retrieving balances for 
this column.

The drop-down menu contains an item for each available period 
as well as Current Period and Final Period items. The Current 
Period and Final Period items are relative i.e. the periods they 
represent will vary depending on the structure and state of the 
ledger. 

The Current Period item refers to the period selected in the 
Period field in the Ledger year selection dialog (Tools > Ledger 
Year). This may or may not be the same as the current period in 
the underlying General Ledger product. The Final Period item 
refers to the last period in the selected year.

Period Start When a ledger contains more than one period and the 
Movement option is selected, this drop-down menu is enabled to 
specify the starting period to be used when retrieving balances 
for this column.

The drop-down menu contains an item for each available period 
as well as Current Period and Final Period items. The Current 
Period and Final Period items are relative i.e. the periods they 
represent will vary depending on the structure and state of the 
ledger. 

The Current Period item refers to the period selected in the 
Period field in the Ledger year selection dialog (Tools > Ledger 
Year). This may or may not be the same as the current period in 
the underlying General Ledger product. The Final Period item 
refers to the last period in the selected year.

Year Specify the year to use when retrieving balances for this column.

Year To Date To have the figures set as Year to Date. The start period is set to 
Period 1, which cannot be changed.

Option Description
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Column defined by ledger

Advanced column properties

Accountants Enterprise in Australia only

To set the properties for style, formula and headings of columns

1. Click the General tab.

2. Apply style changes required for the column if it has to vary from the style 
specified in the Format Editor. 

3. Enter the formula to calculate any derived value, if required.

4. Specify heading variables. 

Filtering

To place restrictions on the account balances to be used in a column, click the 
Filtering tab.

For example, you might want to create a filter that will restrict the column to accounts 
from a particular division.

Note: MAS users can create filters based on Main Code, Sub Code, Division, Prefix 
and Level.
Accounts users can create filters based on Branch, Division, Main Code, Sub 
Code and Level.

To add a new filter, click  and enter the details of your filter.

For example, to create a filter that will use control accounts only, you would enter C 
in the Level field.

To delete a filter, click .

Select the Include credits checkbox to use credit account balances from the client’s 
ledger in the column.

Select the Include debits checkbox to use debit account balances from the client’s 
ledger in the column.

Condition

To set a condition that will determine whether or not a column is displayed in a 
report, click the Condition tab.
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Enter a formula in the Formula field. The column will not be displayed, if the result of 
the formula is false. The column will be displayed, if the result of the formula is true 
or if the formula is invalid or blank.

For example, you might set the condition PeriodNumber(CurrentPeriod)=3 for a 
particular column. In this case, the column would only be displayed if the current 
period is period 3.

The formula can be entered with or without a leading equal sign.

For example, =PeriodNumber(CurrentPeriod)=3 and PeriodNumber(Current 
Period)=3 are both valid formulas that will return the same result.

The formula cannot contain references to cells, driver fields (e.g. AMOUNT), heading 
variables (e.g. %HEADING1%) or the names of other columns within the column 
template.

To check the syntax of the formula in the Formula field, click .

Ledger

To create a column that displays values from a different ledger, click the Ledger tab.

 Ledger drop-down list

The drop-down list in the Ledger column contains a list of available ledgers.

Select the ledger from which you want the column to retrieve Chart Map 
balances and Database Map values.

To display the combined values from more than one ledger, add a new item to 

the list by clicking .

To remove an item from the list, click .

Note: The <Current Ledger> item in the drop-down list refers to the 
ledger(s) specified in the Current Ledger Configuration dialog 
(accessed via Tools > Current Ledger Configuration).

 Name

To specify a name for the ledger in the Formula field, enter a name in the Name 
column.

By default, ledgers will be given the names L1, L2, L3 and so on. These names can 
be edited, if required.

 Properties

To launch the Ledger Properties dialog, click .

Specify the Year, Period Start, Period End and Balance Type for the account 
balances to be retrieved from the selected ledger in the Ledger Properties 
dialog.
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Click OK to save your changes.

Note: The settings in the Ledger Properties dialog will default from the 
settings in the corresponding fields in the Column Definition 
section of the main Column Template Editor screen.

 Formula

The Formula field will be enabled when there are two or more items in the 
Ledger list. Each ledger in the Ledger list is represented in the formula by the 
value that has been specified for it in the Name column. A formula will be 
automatically generated to add the ledger values together (e.g., L1+L2). This 
formula can be edited, if required, to achieve a different result (e.g., (L1-L2)/L1).

Related topics

Column templates

Creating and editing column templates

Deleting column templates

Column template properties

Defining column headings

Columns defined by user

General column properties

Column defined by ledger

Column defined by ledger

Accountants Enterprise in Australia only

The following options are available for Column Defined by Ledger:

 Specify the Style to apply to the column. 

 Select the Repeat lefthand format columns on overflowed pages checkbox to 
have the contents of the column(s) to the left of the column(s) to which the 
template is applied in a format to appear on multiple pages, if the columns 
generated by the column template exceed one page.

 Define the Headings required for the column template. 

Column type

Column type specifies the way in which the number of columns and the values 
displayed in those columns will be determined when a format or report to which this 
template has been applied is previewed.

The options available in the Column type drop-down list may vary depending on the 
underlying General Ledger product.
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Columns for MAS

 Period 1: Current Period

Generates a column for each period in the current year from the first period up 
until the current period, as specified in the Ledger year selection dialog.

 All Periods

Generates a column for each period in the current year from the first period up 
until the final period.

 Maincode

Generates a column for each main account code referenced in the format or in 
any format contained in the same group.

 Subcode

Generates a column for each sub account code referenced in the format or in 
any format contained in the same group.

 Divisions

Generates a column for each division referenced in the format or in any format 
contained in the same group.

 Prefix

Generates a column for each prefix referenced in the format or in any format 
contained in the same group.

Columns for Accounts

 Period 1: Current Period 

Generates a column for each period in the current year from the first period up 
until the current period, as specified in the Ledger year selection dialog.

 All Periods

Generates a column for each period in the current year from the first period up 
until the final period.

 Branches and Divisions

Generates a column for each branch and each division that exists in the ledger.

 Branches

Generates a column for each branch that exists in the ledger.

 Divisions

Generates a column for each division that exists in the ledger.

 Maincode

Generates a column for each main account code referenced in the format or in 
any format contained in the same group.
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 Subcode

Generates a column for each sub account code referenced in the format or in 
any format contained in the same group.

Related topics

Column templates

Creating and editing column templates

Deleting column templates

Column template properties

Defining column headings

Columns defined by user

General column properties

Advanced column properties

Getting more information from reports

Accountants Enterprise in Australia only

When you have a report with financial information that was provided by your General 
Ledger, you can click on the figures within the Report Preview window to access the 
Drill Down window. This displays how the figures in the report are derived. You can 
record the source details and then make corrections or adjustments to the figures as 
required.

The Drill Down window shows the following:

 Code — displays the account codes that make up the item.

 Description — displays the description of each code that make up the item.

 Amount — displays the amounts for each code that make up the item.

 Period — displays the period that the amount is shown for the item.

 Balance Type — information for all the account codes which make up the figure 
you drilled down into on the Report Preview window. 

To return to the Report Preview window, click Close.

While previewing a report, simply move the cursor over the figures in the report. If 
the cursor changes to a hand you can click on that figure to access the Drill Down 
window. 

Note: The total will not always be equal on the report total because the total is the 
sum of all balances, but the report may be made up of some balances 
subtracting.
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Related topics

Reporter hierarchy

Generating report options

Report settings

Selecting years

Presentation of a report

Favourites

Previewing reports

Printer setup

Exporting reports

Emailing reports

Report properties

Column templates

Getting more information from reports

Non-transaction data

Searching

Masters updates

Troubleshooting errors in reports

Accountants Enterprise in Australia only

When previewing a report you can get details regarding the design of any information 
on the report by right-clicking on the information. A cell properties window will be 
displayed showing details including the format the information comes up, the 
formula used to produce the content, style applied and position on the page.

This is particularly useful for troubleshooting when an error message such as #REF or 
#ERR is shown or when any text needs adjusting. If previewing the report in Report 
Designer, clicking the icon to the left of the text Formula will open the Format Editor 
with the relevant format. The cursor will be positioned in the cell as per the report, 
ready for any edits to be made. 

Related topics

Previewing reports

Getting more information from reports

Reporter hierarchy

Generating report options

Report settings

Selecting years

Presentation of a report

Favourites

Printer setup
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Exporting reports

Emailing reports

Report properties

Column templates

Getting more information from reports

Non-transaction data

Non-transaction data

Accountants Enterprise in Australia only

Within Reporter the term non-transaction data is used to refer to the specific 
disclosure items required for a report that are not provided by the underlying General 
Ledger. For example, the statutory details for your client (such as lease details) have 
to be entered using the database tables within Reporter in order to incorporate them 
into reports. Before you run a report for a client you have to enter these values for 
the non–transaction data fields so they can be used when reports are generated. 

When a data field is designed by MYOB or the report designer in your practice, they 
assign a type to it. The type of field selected controls how data is entered into that 
field. For example, whether it is a numerical field, text field or Yes \ No field; the 
maximum number of characters that can be entered, etc. You are only able to enter 
the correct type and number of characters into a Value field. 

There are several ways of accessing the non-transaction data area: 

 If you are a MAS user, select Reports > Reporter > Enter non-transaction data. 

 If you are an Accounts user, select Enter > Other Data > Non Transaction Data.

 From within the Generating Reports window, click on the Non–transaction data 
option to display the tables that support the currently selected reports. 

 From within the Report Designer window. 

Tip: If you are denied access to the database tables for a client, this is probably 
because another employee in the practice is making changes in this area. 

The database tables are deliberately extensive, to provide for all sorts of practice 
reporting requirements. The fields are logically grouped into tables, and the tables 
into folders where the folder names logically identify the related financial 
statements. For example, the Notes folder contains all the tables and fields that are 
referenced by the Notes Formats. All the tables required for the Statement of Cash 
Flow report are into a folder called CashFlow and so on.

You may find that you rarely use many of the tables and fields, however it is 
mandatory to complete the #EntityDetails.ClientDetails table for all entities and the 
#EntityDetails.ReportingExtraDetails for reporting entities.
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Some tables will be completed at the Practice level since the data values will be 
appropriate for all reports produced within the practice. For example, some of the 
fields in the CompilationReport table, e.g., FirmName and the AuditReport 
table,e.g., AuditorFirmName will be updated at Practice level and will deliver 
appropriate data to reports in relation to the Practice details.

The Reporter Database window is divided into a left-hand pane where a number of 
tables are displayed, and a right-hand pane where you are able to add and/or update 
details for a particular table. This editing section of the window contains four 
columns: 

 Name 

This column displays the name of the fields in the selected table. 

 Level 

This column displays two icons, side by side. The first icon (on the left) indicates 
the level at which that field has been defined, either Client, Practice or Master. 
The second icon (on the right) shows the level at which data has been entered 
for that field. Where no data has been entered for a field, the second icon will be 
the same as the first. 

For example, in the following picture you will see that the database field is the 
original Master version supplied by MYOB, but the value for that field was 

entered at the Client level.  

Note: When a report is generated for a client, if the field being referenced 
does not contain any client level data, then data entered at the 
Practice level is used instead. 

 Value 

This column displays the current data for that field. In the case of fields where 
the value must be selected from a defined list, a drop-down list is available. To 
enter a value either select it from the drop-down list options, or type the value 
directly into the Value field. Either way, once data is entered in a field, it is saved 
to the database as soon as the cursor leaves that field. In other words, you do 
not need to specifically save, it occurs automatically as you move from one field 
to another. 

 Null 

This column allows you to set a field value to be empty. The field still exists but 
holds no value for that client. 

If you select a multi record table in the list on the left, the right side of the window 
will display with an extra section at the top where the multiple records for the fields 
are displayed. 
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Note: Just below the data entry area, you will notice that as you select a field, an 
explanation of the field is displayed to assist you with data entry. 

Related topics

Entering non-transaction data

Reporter hierarchy

Generating report options

Report settings

Selecting years

Presentation of a report

Favourites

Previewing reports

Printer setup

Exporting reports

Emailing reports

Report properties

Column templates

Getting more information from reports

Non-transaction data

Adding client and practice non-transactional data to the database

Searching

Masters updates

Entering non-transaction data 

Accountants Enterprise in Australia only

You can enter non–transactional data through the Generating Reports window or the 
Report Designer window using the Database Map. These instructions refer to 
entering data using the Generating Reports window. 

Note: You can also add data from your General Ledger software main menu:
For MAS users, select Reports > Reporter > Enter non–transactional data 
For Accounts users, select Enter > Other Data > Non Transaction Data.

To enter data into a table from the Generating Reports window

1. Within your General Ledger software, open the client ledger you want to enter 
non–transaction data for and select Reports > Reporter > Generate Reports. 

The Generating Reports window opens. 
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2. Click the Non–transaction data button on the toolbar.

or

Select File > Non-transaction Data.

3. Select the table you want to enter data for in the Explorer pane on the left of the 
window. 

You may need to expand the branches to get to the table you require. 

The fields defined for the selected table will be displayed on the right of the 
window. 

4. In the Value column, enter the specific value for the selected client against the 
fields in the table. 

If you are entering data into a multi record table, you will need to click the Apply 
button after entering the values for one record.

5. Click Apply. 

Related topics

Non-transaction data

Adding client and practice non-transactional data to the database

Masters updates

Accountants Enterprise in Australia only

Note: The following is only recommended steps. Some practices may have their own 
steps to update their Reporter systems.

When you receive a new version of the Masters, there could be 2 possible scenarios:

You are installing for a new financial year

1. Perform a backup.

See “Maintaining Reporter” on page 241.

2. Install the new version and review the Release Notes for more information.

3. Review the Retain Values for the Practice.

See “Reviewing the retain value settings” on page 237.

4. Roll forward the Practice level in Reporter.

The roll forward should only be done by your system administrator.

5. Review the Trash Can at the Practice level.
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See “Restoring from the trash can” on page 241.

6. Back up your general ledger.

7. Review the Retain Values for the Client.

See “Reviewing the retain value settings” on page 237.

8. Roll each client forward in your general ledger software.

The Year End rollover within your general ledger forces Reporter to roll forward 
at the Client level for that particular ledger.

Note: Ensure that you close all sessions of Reporter.

9. Review the Trash Can at the Client level.

See “Restoring from the trash can” on page 241.

You are installing in a year

1. Perform a backup.

See “Maintaining Reporter” on page 241.

2. Install the new version and review the Release Notes for more information.

3. Review the Trash Can at the Practice level.

See “Restoring from the trash can” on page 241.

4. Review the Trash Can at the Client level.

See “Restoring from the trash can” on page 241.

Related topics

Entering non-transaction data

Reporter hierarchy

Generating report options

Report settings

Selecting years

Presentation of a report

Favourites

Previewing reports

Printer setup

Exporting reports

Emailing reports

Report properties

Column templates
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Getting more information from reports

Non-transaction data

Adding client and practice non-transactional data to the database

Searching

How do I...

How do I create a report showing values from multiple ledgers?

Accountants Enterprise only

Reporter provides the ability to retrieve financial data from multiple ledgers and 
display the combined results in any of the reports. The financial figures from all the 
specified ledgers are combined and reported. This method is also known as simple 
consolidation.

To achieve a report combining values from multiple ledgers:

 Specify the required ledgers in the Current Ledger Configuration.

 Preview the consolidated report.

To specify the required ledgers

1. Open the primary ledger and click Reports > Reporter > Generate Reports.

The Reporter window opens.

2. From the Tools menu, select Current Ledger Configuration.

The Current Ledger Configuration window appears with the primary ledger 
selected.

3. Click the drop-down arrow on the Ledger field and select the subsequent 
ledger(s) from the list.

The subsequent ledger(s) is added to the list of current ledgers.

4. Click OK.

The additional ledgers are added to the values retrieved for the reports.

Note: The setting applied in the above steps remain in effect for the 
primary ledger until changed. To remove this setting, repeat the 
above steps 1 and 2 to access the Current Ledger Configuration, 
select the subsequent ledger(s) to remove and click the Remove 
Ledger icon.
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To preview the consolidated report

1. Click Reports.

The reports list appears in the right-hand pane.

2. Select the required report and click Preview.

The preview is generated and displayed.

3. In the report preview, click on a common financial figure that reports a 
consolidated amount (for example, Cash at Bank).

The drill down window appears showing the components from the different ledgers. 
The total of the components equals the consolidated figure.
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Designing reports

Accountants Enterprise in Australia only

The report templates available when producing reports consist of those provided 
with Reporter by MYOB. These are referred to as Masters. In addition to the Masters 
are any report templates which have been created within your company, Practice or 
Client level report templates. 

If you are the person within your company responsible for designing reports, you will 
use Report Designer to make changes to existing report templates or to create new 
report templates. Report templates can be created for use practice–wide, or 
customised for specific clients. 

Each report template stored within Reporter sits at a certain hierarchy level. There 
are three levels of hierarchy:

 Master 

Master level report templates are provided with the Reporter software. These 
cover the AASB reporting requirements for certain entity types and sizes. Master 
level templates cannot be edited or created, however you can use them as a 
basis for creating Practice or Client level report templates. Each year MYOB will 
provide you with updated Master report templates to cover any AASB changes 
that have been introduced. 

Master reports and templates are distinguished by a red icon in the Report 

Designer and Generating Reports windows, . 

 Practice 

Practice level report templates are those you create within your practice and 
which can be used to produce reports for all the practice’s clients. Practice 
reports can be created from scratch or based on a Master or another Practice 
level report template. 

Practice reports and templates are distinguished by a yellow icon in the Report 

Designer and Generating Reports windows, . 

 Client 

Client level report templates are those created for the reporting purposes of a 
specific client. The client report will only be available for use within the 
Generating Reports window for the particular client the template was created 
for. Client report templates can be created from scratch or based on an existing 
report template of any level. 

Client reports and templates are distinguished by a blue icon in the Report 

Designer and Generating Reports windows, . 
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Note: Within the Report Designer window you can only see reports that exist at and 
above the hierarchy level you entered the software through. That is, if you 
enter Report Designer from your General Ledger software at the Practice 
level then you will only see Master and Practice level reports listed. If you 
enter via the Client level then you will see all three levels of reports. 
In addition, you will only see the reports designed for the entity type that 
match the entity type of the selected client ledger. For example, if the 
selected ledger is for a company, you will only see those reports which have 
been designed for the entity type, Company.

When creating or editing reports you will work with “Formats” on page 123. These 
are the building blocks you use to create the content of the reports. Formats can be 
made up of any combination of the following: 

 “Chart Map” on page 185 items

 “Database Map” on page 208 items

 Standard text 

 Pictures 

 Formulas. 

Note: Where you see the following icon displayed, , click on it to view 
information on the particular window or field you are in. 

Related topics

Reporter hierarchy

Generating reports

Maintaining Reporter

Working with formats

Working with formulas

Chart Map

Database Map

Designing reports

Opening the Report Designer window

About reports

Creating new reports

Previewing reports from the Report Editor

Groups and formats

Report element properties

Tools options

Formats
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Opening the Report Designer window 

Accountants Enterprise in Australia only

When you open Report Designer you can choose to open it at either the Practice level 
or the Client level. Which one you choose depends on whether you want to work on 
reports for a particular client, or whether you want to work on reports which will then 
be available for use throughout the practice. 

To open the Report Designer at the client level (for both Accounts and MAS users) 

1. Open the ledger of the entity type that you want to design reports for. 

2. Select Reports > Reporter > Design Client reports…. 

The Report Designer window opens. 

All Master level reports and Practice level reports are available in addition to 
those reports designed at the Client level for the selected client. 

When you work in the Report Designer at the Client level, all the changes you 
make or any new items you add will only be available for use for the specific 
client ledger you opened in Report Designer. For example, any reports you create 
or save at the Client level will only be available for use for the particular client 
the report was created for. You will not be able to use or view Client level items 
for any other client other than the one the item was created or edited for. If you 
want an item to be available for all client ledgers in the practice, you will need to 
create it or save it at the Practice level.

To open the Report Designer at the Practice level (for MAS users)

1. Open the ledger for a client. 

This client’s information will be used when you preview and print the reports. 

2. Select Reports > Reporter > Design Practice reports…. 

The Report Designer windows opens. 

Any changes you make or new reports you create are displayed in the Report 
Designer and Generating Reports window for all clients of the same entity. 

To open the Report Designer at the practice level (for Accounts users)

1. Select Start > Programs > MYOB Accountants Enterprise > Configuration.

The Configuration window opens.

2. Select Configure > Accounts > Report Designer.

3. Select the entity that you want to design the reports for.

4. Click Next.
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The Report Designer windows opens. 

Any changes you make or new reports you create are displayed in the Report 
Designer and Generating Reports window for all clients of the same entity. 

As you are at the Practice level, any changes you make to data, reports, Formats, 
Chart Map or Database Map items will be available for use to any other people 
when they also open Report Designer or Report Generator at the Practice level. 
This is different to designing reports at the Client level, as anything done at the 
Client level is only available to the specific client ledger that you opened in 
Report Designer.

Related topics

Reporter hierarchy

Generating reports

Maintaining Reporter

Designing reports

About reports

Creating new reports

Previewing reports from the Report Editor

Groups and formats

Report element properties

Tools options

Formats

Making changes to master reports

About reports 

Accountants Enterprise in Australia only

The Reports tab on the Reports Designer window contains the Master reports 
provided with Reporter, along with any reports you have created at a Practice level 
and the Client level reports created for the selected client.

Note: Only those reports that apply to the selected entity type are displayed at each 
hierarchy level. 

From the Reports tab you can: 

 Create new report templates

 Edit existing report templates

 Delete report templates

 Preview and print reports

 Add Groups and Formats to reports
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 Define report element properties. 

When working in the Reports tab there are two work areas:

 the left hand Explorer pane

 the right hand Design pane. 

Related topics

Reporter hierarchy

Generating reports

Maintaining Reporter

Designing reports

Opening the Report Designer window

Creating new reports

Previewing reports from the Report Editor

Groups and formats

Report element properties

Tools options

Formats

Making changes to master reports

Report editor

Right-click menu

Displaying a master level report

Displaying the practice level report

Right-click menu

Accountants Enterprise in Australia only

In addition to the toolbars, there is a right-click menu available in the Explorer pane 
of the Reports Designer window. This contains the same options as the toolbar, plus 
the extras listed in the following table.

Note: The cut, copy paste functionality is to provide you with the ability to cut or 
copy reports between ledgers.

Option Description

Copy This is standard Windows copy functionality.

This option is not available for Master level items.

You can copy and paste between reports and also between 
different ledgers.
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Copy to Client / 
Practice

Use this menu item to save the currently selected report to 
the level at which you opened Report Designer (Client or 
Practice). This menu option reads Copy to Client if you 
opened Report Designer at the Client level, allowing you to 
save a Practice level or Master level item at the Client level. 

If you opened Report Designer at the Practice level it reads 
Copy to Practice, allowing you to save a Master level item at 
the Practice level. 

The new level version of the report conceals the higher level 
version until such a time that the lower level version is 
renamed or deleted.

Copy to Clipboard This option enables you to copy Reports to the clipboard and 
paste them into Microsoft Word. This enables you to view 
the properties of all the Reports without having to open 
each Report's Properties window.

Cut This is standard Windows cut functionality.

Paste This is standard Windows paste functionality.

Print Report Sends the report to your default Windows printer.

Properties Select this option to access the Report Properties window 
where you can add, view or edit the notes that have been 
added to the selected item. To add or edit notes simply type 
into the Description field and then click the Apply button to 
save your entry. If Report Designer is not open at the 
required hierarchy level to edit the properties, then the 
window will open as read–only. 

Rename Use this menu item to rename the selected report or group.

Save As Use this menu item to create a copy of the currently selected 
report. The copy is saved to the level at which Reporter is 
currently open (Practice or Client level). You can then edit 
the name as required.

Show Master / 
Practice Report

This option displays the matching Master or Practice level 
report for the currently selected report. The Practice level 
report or Master level report window opens, with the 
report tree displayed to show the location of the Master 
level item. 

If Report Designer is open at the Practice level, this option 
displays View Master. If Report Designer is open at the 
Client level, this option displays View Practice. 

Option Description
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Related topics

Reporter hierarchy

Generating reports

Maintaining Reporter

Designing reports

Opening the Report Designer window

About reports

Creating new reports

Previewing reports from the Report Editor

Groups and formats

Report element properties

Tools options

Formats

Making changes to master reports

Report editor

Displaying a master level report

Displaying the practice level report

Report editor 

Accountants Enterprise in Australia only

The Report Editor is the work area in which you create, edit and preview a report. 
When you are working in the Reports tab, the Report Editor area is on the right-hand 
side of the Report Designer window. 

When you select a report for editing or create a new report, the Report Editor 
window opens. 

There are various ways to open the Report Editor window: 

 Double-click an item in the list within the Reports tab. 

 Click either the New Report or Edit Report button on the toolbar. 

 Select a report and press the [Enter] key. 

 Right-click an item in the Reports tab and select Edit.

The name of the new or selected report displays in the title bar of the Report Editor 
window. You can have multiple Report Editor windows open at once. Each instance 
of the window has its own toolbar. 

When you open the Report Editor window, a list of all the Groups and Formats that 
make up the report is displayed. Formats can be organised into Groups within the 
report. 
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Groups

A folder icon, , identifies a Group. You can expand or collapse these for easier 
viewing. The Groups, Sections and Formats are listed in the Report Editor window in 
print order. Use the up and down buttons on the toolbar to move the Groups, 
Sections and Formats around within a report. 

See “Groups and formats” on page 96.

Sections

A section icon, , identifies a Section in which multiple formats can be placed 
together. A condition set for the section will apply to all formats in the same section. 

Formats

There are three types of Formats which can be used in reports:

 Header, 

 Body, 

 Footer, .

Each Format in a report is preceded by an icon which tells you which type it is. This 

icon may also have a C on it, , indicating that a condition has been applied to the 
Format. 

When you right click a Format in the Report Editor, you have the option to change the 
type of Format (Header, Body and Footer). You also have the option to Edit Format, 
which takes you straight to the Format Editor. You can then cut, copy and paste 
Formats to other Groups and to other Ledgers.

See “Groups and formats” on page 96.

Resize window

The Report Editor window can be resized, minimised, maximised and moved around 
within the Report Designer window. 

Related topics

Reporter hierarchy

Generating reports

Maintaining Reporter

Designing reports

Opening the Report Designer window

About reports

Creating new reports
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Previewing reports from the Report Editor

Groups and formats

Report element properties

Tools options

Formats

Making changes to master reports

Report editor

Right-click menu

Displaying a master level report

Displaying the practice level report

Adding a group to a report

Setting conditions for the elements

Making changes to master reports 

Accountants Enterprise in Australia only

Master reports can be used as the basis for creating a new report. You cannot save 
changes to the Master reports themselves. When you save a Master level report, 
Reporter saves the report to the level at which you opened Reporter (e.g., Practice 
or Client). The edited Master report can be saved with the same name or a different 
name. 

When you edit and save a Master report to the Practice or Client level with its original 
name, the Master report no longer displays in the Reports tab. It is replaced by the 
Practice or Client report. The Master report remains in the background and is 
reinstated if the Client and/or Practice reports are deleted or renamed. The Master 
report displays when Reporter is opened from a client ledger, where a client level 
component of the report has not been created. 

Note: If you create a Practice level version of a Master report, it will be effective for 
all the client ledgers. The Master will not be displayed in the list of reports 
while a practice version of the same report exists. 

Be aware, that if you create a Practice or Client copy of a Format, Chart Map or 
Database Map that is used by a report, this will not cause the report itself to become 
a non-Master. A Master report can contain non-Master items. If you make changes to 
items that a Master report uses, your resulting reports differ from those produced by 
a Master report whose constituent items are also at the Master level. 

Also, if you create non-Master versions of Formats or Database Map items, or add 
items to a Master level Chart Map, the Master report that uses the changed items will 
continue to be a Master report. A Client copy of a Master item will be used by a 
Master report when that report is run from a client ledger for which a Client version 
of the Master item has been created. 
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Related topics

Reporter hierarchy

Generating reports

Maintaining Reporter

Designing reports

Opening the Report Designer window

About reports

Creating new reports

Previewing reports from the Report Editor

Groups and formats

Report element properties

Tools options

Formats

Report editor

Right-click menu

Displaying a master level report

Displaying the practice level report

Making changes to the Chart Map

Making changes to the Database Map

Displaying a master level report 

Accountants Enterprise in Australia only

When you are working with reports, it is sometimes useful to be able to view the 
corresponding higher level report for the one you are currently viewing. For example, 
if you are editing a Client level report, you may want to know which Groups and 
Formats are included in the Master level version of the same item. Using the Master 
level report window you can quickly and easily view the higher level version. 

The Master level report window is accessed by selecting the View Master option on 
the right-click menu within the Explorer pane of the Reports tab. Just select the 
Practice or Client level report you want to view the corresponding Master 
information for, then click the menu option. The Master level report window will 
open, with the tree list expanded to show the location of the Master level item which 
corresponds with the selected Practice or Client level item. 

You can also copy items from the Master level report window by selecting the 
required item in the window, then clicking Copy on the right-click menu. You can then 
paste this at the Client or Practice level (depending on the level at which you opened 
Report Designer) at the desired location of the report tree in the Explorer pane. 

Related topics

Reporter hierarchy
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Generating reports

Maintaining Reporter

Designing reports

Opening the Report Designer window

About reports

Creating new reports

Previewing reports from the Report Editor

Groups and formats

Report element properties

Tools options

Formats

Report editor

Right-click menu

Making changes to master reports

Displaying the practice level report

Making changes to the Chart Map

Making changes to the Database Map

Displaying the practice level report 

Accountants Enterprise in Australia only

When you are working with reports, it is sometimes useful to be able to view the 
corresponding higher level report. For example, if you are editing a newer, Client level 
version of a report, you may want to know what Groups and Formats are included in 
the Practice level version of the same report. Using the Practice level Report window 
you can quickly and easily view the original Practice level version and compare the 
two. 

The Practice level report window is accessed by selecting the View Practice option on 
the right-click menu within the Explorer pane of the Reports tab. Just select the Client 
level report you want to view the corresponding Practice one for, then click the menu 
option. The Practice level report window will open, with the tree list expanded to 
show the location of the Practice level item which corresponds with the selected 
Client level item. 

You can also copy items from the Practice level report window by selecting the 
required item in the window then clicking Copy on the right-click menu. You can then 
paste this at the Client level at the desired location of the report tree in the Explorer 
pane. 

Note: This option is not available if Report Designer is open at the Practice level. 
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Related topics

Reporter hierarchy

Generating reports

Maintaining Reporter

Designing reports

Opening the Report Designer window

About reports

Creating new reports

Previewing reports from the Report Editor

Groups and formats

Report element properties

Tools options

Formats

Report editor

Right-click menu

Displaying a master level report

Making changes to master reports

Making changes to the Chart Map

Making changes to the Database Map

Creating new reports

Accountants Enterprise in Australia only

If there are no existing reports on which you can base a new report, you will need to 
create your report from scratch. You do this using the Report Designer window. 

Note: You must have the required security permissions to be able to design reports. 
You cannot design reports if someone else is designing reports for the same 
entity type or for the same client. In this case a message will be displayed to 
inform you. 

To create a new report from scratch

1. Open the Report Designer window from your ledger software.

See “Opening the Report Designer window” on page 73.

The Report Designer opens. 

2. Select the Reports tab. 

3. On the toolbar of the Reports tab, click the New Report button, . 
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The Report Editor window opens. 

A default name for the report is displayed in the Report Editor window. The 
name is automatically highlighted when the Report Editor opens, enabling you 
to over type the name. You can edit a report name at any time from the Report 
Element Properties window. 

4. Use the Add New Group  and Add New Format  buttons to add the 
required elements to your report. 

5. When all the Groups and Formats have been added to the report, use the 
Preview button to check the report. 

6. Click the Save  button.

or

Select File > Save from the main menu.

To save your changes. Once saved, the new report appears in the list of reports 
in the Explorer pane. 

Related topics

Reporter hierarchy

Generating reports

Maintaining Reporter

Designing reports

Opening the Report Designer window

About reports

Creating a new report based on an existing template

Previewing reports from the Report Editor

Groups and formats

Report element properties

Tools options

Formats

Making changes to master reports

Making changes to the Chart Map

Making changes to the Database Map

Creating a new report based on an existing template 

Accountants Enterprise in Australia only

When creating reports based on higher level report templates than that at which you 
opened Reporter, the new report is automatically saved down to the current 
(Practice or Client) level. For example, if you open Report Designer at the Client level, 
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then use a Practice level report on which to base a new report, the new report will be 
saved to the Client level. This new report will replace the higher level one until such 
time as the new report is renamed or deleted, when the higher level one will be 
reinstated. 

If your new report is to be based on an existing report at the same level (e.g., you 
want to use a Practice level report to create another Practice level report) you will 
need to create a copy of the existing report, using the Save As function on the right-
click menu. 

Note: You must have the required security permissions to be able to design reports. 
You cannot design reports if someone else is designing reports for the same 
entity type or for the same client. In this case a message will be displayed to 
inform you. 

To create a report based on an existing report at a higher level to that which you 
opened Reporter

1. Open the Report Designer window from your ledger software.

See “Opening the Report Designer window” on page 73.

The Report Designer opens. 

2. In the list of reports displayed in the Explorer pane, select the report you want to 
base the new report on. 

3. If you have opened Reporter at the Client level and are: 

 using a Master or Practice level report as the basis for your new report, 
then: 

a. On the toolbar of the Reports tab, click the Edit Report button, . 

 using a Client level report as the basis for your new report, then: 

a. Select Save As from the right-click menu in the Explorer pane. 

b. Enter the name for the new report in the Name of Report field. 

c. Click OK. The new report will be listed in the Explorer pane. 

d. Double–click the report or click the Edit Report button, . 

4. If you have opened Reporter at the Practice level and are: 

 using a Master level report as the basis for your new report, then:

a. On the toolbar of the Reports tab, click the Edit Report button, . 
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 using a Practice level report as the basis for your new report, then:

a. Select Save As from the right hand menu in the Explorer pane. 

b. Enter the name for the new report in the Name of Report field. 

c. Click OK. The new report will be listed in the Explorer pane. 

d. Double–click the report or click the Edit Report button, . 

The Report Editor window opens. 

5. In the Report Editor window make the required changes to the Groups and 
Formats in the report. 

6. When you have made the required changes, use the Preview button, , to 
check and view the report. 

7. Click the Save,  button.

or 

Select File > Save from the main menu.

To save your changes. The saved report appears in the list of reports in the 
Explorer pane. 

Note: When you create a Practice and/or Client version of a report, a 
Show Master/Show Practice function on the right-click menu will 
enable you to view Master or Practice versions of the reports. 

Related topics

Reporter hierarchy

Generating reports

Maintaining Reporter

Designing reports

Opening the Report Designer window

About reports

Creating new reports

Previewing reports from the Report Editor

Groups and formats

Report element properties

Tools options

Formats

Making changes to master reports
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Making changes to the Chart Map

Making changes to the Database Map

Working with reports

Accountants Enterprise in Australia only

With reports you can:

 “Copying a report to the client or practice level” (see page 86)

 “Viewing the master or practice report” (see page 87)

 “Adding a section to a report” (see page 87)

 “Deleting a report” (see page 88)

 “Reverting to a master report” (see page 89).

Copying a report to the client or practice level

Accountants Enterprise in Australia only

Use the Copy to Client or Copy to Practice menu items to save the currently selected 
report to the level at which you opened Report Designer (Client or Practice). This 
menu option reads Copy to Client if you opened Report Designer at the Client level, 
allowing you to save a Practice level or Master level item at the Client level. If you 
opened Report Designer at the Practice level it reads Copy to Practice, allowing you 
to save a Master level item at the Practice level. 

The new level version of the report conceals the higher level version until such a time 
that the lower level version is renamed or deleted. 

To copy a report to the client or practice level

1. Within the Report Editor window on the Reports tab, right-click the Practice or 
Master report. 

2. Select Copy to Client or Copy to Practice.

The report is saved at the level you selected.

Related topics

Right-click menu

Working with reports

Viewing the master or practice report

Adding a section to a report

Deleting a report

Reverting to a master report
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Viewing the master or practice report

Accountants Enterprise in Australia only

The Show Master Report or Show Practice Report option displays the matching 
Master or Practice level report for the currently selected report. The Practice level 
report or Master level report window opens, with the report tree displayed to show 
the location of the Master level item. 

If Report Designer is opened at the Practice level, this option displays Show Master. 
If Report Designer is opened at the Client level, this option displays Show Practice. 

To show the master or practice report

1. Within the Report Editor window on the Reports tab, right-click the Practice or 
Client report. 

2. Select either Show Master Report or Show Practice Report.

The View window opens displaying the report.

Related topics

Right-click menu

Working with reports

Copying a report to the client or practice level

Adding a section to a report

Deleting a report

Reverting to a master report

Adding a section to a report

Accountants Enterprise in Australia only

A section in Reporter is similar to a section in a Microsoft Word Document. It allows 
you to break your Report into different sections and then elect to keep the section 
together.

To add a section to a group in the currently open report

1. Within the Report Editor window on the Reports tab, select the Group to which 
you want to add a section. 

2. Click the Insert Section button , on the Report Editor toolbar. 

A new section, labelled SectionN is added to the report tree. 

3. Overtype the section name with the name of your choice. 

The name must be unique within the Group under which it resides. 
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4. Click Save to keep your changes. 

Note: Once you have added the section to the Group of the Report, you 
can use the Report Element Properties window to edit the section 
name, if required. 

Related topics

Right-click menu

Working with reports

Copying a report to the client or practice level

Viewing the master or practice report

Deleting a report

Reverting to a master report

Report element properties

Deleting a report 

Accountants Enterprise in Australia only

If a report is no longer required you can delete it from Report Designer. Once deleted, 
the report is no longer available in the Generating Reports window or Report 
Designer window. 

Note: If you delete a Practice or Client level report that has a corresponding higher 
(Master or Practice) level report, then the higher level report is reinstated 
when the lower level one is deleted. 
You cannot not delete a report that is currently open for editing. You will first 
need to close the report and then delete it.
There is no undo facility in the Report Designer. 

Master reports cannot be deleted. You also cannot delete: 

 Master Chart Map items, or any of the related master ranges or mappings

 Master Database Map items

 Master Formats.

To delete a client or practice report 

1. Open the Report Designer.

To delete a Client level report, open Report Designer from the client ledger. 

To delete a Practice level report, open Report Designer at the Practice level for 
the correct entity. 

2. Select the Reports tab in the Explorer pane. 
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3. Select the report you want to delete.

4. Click the Delete button,  on the toolbar. 

The confirmation message Delete report <report name>? opens. 

5. Click OK to delete the report. 

The report no longer appears in the Reports tab. 

Related topics

Right-click menu

Working with reports

Copying a report to the client or practice level

Viewing the master or practice report

Adding a section to a report

Reverting to a master report

Restoring from the trash can

Making changes to master reports

Using the trash can

Reverting to a master report 

Accountants Enterprise in Australia only

If at any stage you no longer require a Client or Practice version of a report, you can 
return to the original Master report by deleting or renaming the Client or Practice 
version. 

The icon for the report in question re-displays as the Master icon , indicating that 
the Master report has been re-instated. 

If you are deleting a Client report, where a version of the Master report has been 
saved to both the Client and the Practice levels, you will see the Practice version re–
instated, not the Master. You will need to delete the Practice version if you want to 
revert to the Master version of the report. 

Related topics

Right-click menu

Working with reports

Copying a report to the client or practice level

Viewing the master or practice report

Adding a section to a report

Deleting a report
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Making changes to master reports

Copying Practice Level customisations to another Reporter Year

In MYOB Reporter, you can make Practice Level customisations to Chart Maps, 
Database Maps, Formats or Reports.

Customisations are applied in a specific Reporter Year which are then carried forward 
into future years as you balance forward Reporter. 

To copy the customisations to a prior Reporter year, you need to copy the relevant 
item from the year with the change and paste it into the prior year as required.

To copy components to another Reporter Year

1. Open the Practice Level Report Designer — see Opening the Report Designer 
window.

2. Click on the Reporter Year.

The pick-list of years appears.

3. Select the relevant Reporter Year where the changes are evident and click OK.

The Reporter Year changes as selected.

4. Click the relevant tab at the bottom of the left-hand pane where the changes 
are. For example, Chart Map.

The list of components appears.

5. Right-click on the required component and select Copy.

The item is copied to the clipboard.

6. Click on the Reporter Year.

The pick-list of years appears.

7. Select the relevant prior Reporter Year and click OK.

The Reporter Year changes as selected.

8. Click on the tab where from which the item was copied. For example, Chart Map.

The information relating to the selected component appears.

9. Right-click and select Paste.

The item is coped to the selected Reporter Year.

Note: Repeat steps 1 to 8 for each component you require to copy to the 
prior Reporter Year.
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10. Click Close to close Reporter.

Previewing reports from the Report Editor

Accountants Enterprise in Australia only

Previewing a report from the Report Editor enables you to see what the report will 
look like and check it for correctness and completeness. The report as previewed on 
screen is what you will see when you print the report, including all bolding, margins, 
page breaks, borders and colours used on your report. 

When you preview a report the data comes from the client ledger through which you 
accessed Report Designer. 

Note: If you have opened Report Designer at the Practice level, Database Map 
references only pick up Practice level data, not Client level data.
If you want to test the report using the Client data, open Report Designer at 
the Client level. 

It is recommended that you preview all the “Formats” on page 123 that are used in a 
report in the “Previewing formats” on page 157 before previewing the report. 
Formats previewed on their own display faster, and you will be able to easily switch 
to the Design view of the Format Editor to correct any errors you find. However, be 
aware that note references, cross-references and references to named ranges will 
not display correctly in the Format preview, and therefore can only be checked when 
you preview the full report. 

Things to look out for when previewing reports are: 

 Page breaks appear where they should.

 Report elements are only being included when they should. 

 Note references and note numbering are working correctly. 

 References to named ranges are working correctly. 

 Margins are appearing correctly. 

As with previewing a Format, you can click on a Chart Map value to bring up a Drill 
Down window (see “Getting more information from reports” on page 62) containing 
the underlying account information. 

Related topics

Controlling page breaks

Margins in reports

Notes and references

Creating notes and cross-references

Named cell ranges
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Setting conditions for the elements

Previewing reports from the Report Designer

Exporting a report from the Preview view

Emailing a report from the Preview view

Printing a report from the Preview view

Refreshing a report preview

Previewing reports from the Report Designer

Accountants Enterprise in Australia only

To preview a report from the Report Designer (on the Reports tab) 

1. Open the Report you want to preview from the tree list in the Explorer pane of 
the Reports tab in the Reporter window. 

2. Click the Preview button,  on the Report Editor window toolbar. 

The Report Editor window changes to the Preview view, displaying the selected 
Report. 

Note: A progress bar appears at the bottom of the Report Editor to show 
how the loading of the preview is progressing. 

3. To move between pages in the Preview, use the arrows on the toolbar or type a 

page number in .

4. To return to the Design view, click the Design button, , on the toolbar. 

Related topics

Previewing reports from the Report Editor

Exporting a report from the Preview view

Emailing a report from the Preview view

Printing a report from the Preview view

Refreshing a report preview

Exporting a report from the Preview view

Accountants Enterprise in Australia only
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To export a report from the Preview view within Report Designer (on the Reports 
tab)

1. Open the Report you want to preview from the tree list in the Explorer pane of 
the Reports tab in the Designer window. 

2. Click the Preview button,  on the Report Editor window toolbar. 

The Report Editor window changes to the Preview view, displaying the selected 
Report. 

3. Click the Export button,  on the toolbar.

The Select Export File window opens.

4. In the Save in field, select the folder in which you want the exported file to be 
located.

5. Type the File name of the export file.

6. In the Save as type field, select the type of format you want to export the report 
to.

7. Click OK to begin the export. 

This may take some time. The hourglass cursor displays while the export is 
processing. When the cursor returns to the pointer, this indicates that your 
export is complete. 

Related topics

Previewing reports from the Report Editor

Previewing reports from the Report Designer

Emailing a report from the Preview view

Printing a report from the Preview view

Refreshing a report preview

Emailing a report from the Preview view

Accountants Enterprise in Australia only

To email a report from the Designing Reports window within Report Designer (on 
the Reports tab)

1. Open the report you want to email.

2. Click Preview.
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3. Click .

The Email Report as an Attachment window opens.

4. For Attachment Settings:

a. Enter a File Name or simply keep the default name.

b. Select a File Type from the drop-down list.

The file type can be Microsoft Word, Excel or PDF.

5. Click the Options button. 

a. Select the Password protect the attachment option to secure your report. 

Type in a password and then re-type it to confirm.

b. Select the Compress the Attachment option if you want to compress the 
email using WinZip.

c. Select the Save the attachment option if you want to save the attachment.

If you want to change the directory, click the ellipsis button.

6. Click Email.

An Untitled email message appears with the report attached.

7. Type in or select the recipient's email address and if necessary type a message 
(as you normally would).

8. Click Send.

Related topics

Previewing reports from the Report Editor

Previewing reports from the Report Designer

Exporting a report from the Preview view

Printing a report from the Preview view

Refreshing a report preview

Printing a report from the Preview view

Accountants Enterprise in Australia only

To print a report from the Preview view within Report Designer (on the Reports tab)

1. In the Report Editor window, click . 
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The Report Editor window changes to the Preview view, displaying the selected 
Report. 

2. Click the Print button on the toolbar, .

The Print window opens.

3. Enter the number of copies.

4. Select the Collate checkbox, if you want the copies to be collated.

5. Select to print All, Current or a Page range.

To specify a page or page range to print you must enter the page number as it 
relates to the page number within the report from the page x of y within the 
preview rather than the page number that appears on the bottom of the report. 
This is important when printing a job stream as the page numbering starts at 
page 1 on the 3rd page.

6. Click Print.

Related topics

Previewing reports from the Report Editor

Previewing reports from the Report Designer

Exporting a report from the Preview view

Emailing a report from the Preview view

Refreshing a report preview

Refreshing a report preview

Accountants Enterprise in Australia only

If any changes have been made to the client ledger that you are previewing reports 

for, you can click the  button.

This updates the accounts without you having to close out of the preview or Reporter.

Related topics

Previewing reports from the Report Editor

Previewing reports from the Report Designer

Exporting a report from the Preview view

Emailing a report from the Preview view

Printing a report from the Preview view
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Groups and formats

Accountants Enterprise in Australia only

Groups

Groups are used in reports to keep sets of Formats together. Once they have been 
grouped, they can have header and footer Formats applied. Only those Formats in the 
Group take on the headers and footers, rather than the report as a whole. This 
enables you to effectively break your report into Groups with different headers and 
footers. 

You can also set conditions (see “Setting conditions for a format or group” on 
page 104) for a Group, and that condition applies to all the Formats within the 
selected Group. This saves you having to set the condition for each Format in a Group. 
This also applies to margin settings (see “Margins in reports” on page 107). 

You can add a group to a report or to another group within a report. 

Formats

Formats are the building blocks that are used to create reports. You are supplied with 
a list of Master level Formats which you can edit to your requirements, if necessary. 
Edited Master level Formats are saved at either the Practice or Client level, depending 
on the level at which you opened Report Designer. 

Formats can contain any of the following types of information in order to generate 
the reporting information required for your practice or a particular client: 

 References to Chart Map folders

 References to Database Map fields

 Text

 Pictures

 Functions and formulae.

You can also apply styles or formatting to the contents of a Format. 

All the Formats available to you at the level at which you opened Report Designer are 
listed in the Formats tab.

Related topics

Groups and formats

Adding a group to a report

Renaming a report or group

Adding a format to a group

Format types

Setting conditions for a format or group
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Report element properties

Adding a group to a report 

Accountants Enterprise in Australia only

Note: Once you have added the group to the report, you can use the Report 
Element Properties window to edit the group name, if required. 

To add a group to either a report or a group in the currently open report

1. Within the Report Editor window on the Reports tab, select the report name or 
the group to which you want to add the new group. 

2. Click the Insert Group button,  on the Report Editor toolbar. 

A new group, labelled NewGroupN is added to the report tree. 

3. Overtype the group name with the name of your choice. 

The name must be unique within the report or group under which it resides. 

4. Click Save to keep your changes. 

Related topics

Groups and formats

Renaming a report or group

Adding a format to a group

Format types

Setting conditions for a format or group

Report element properties

Working with formulas

Setting conditions for the elements

Renaming a report or group 

Accountants Enterprise in Australia only

You can rename a Report or Group at any time from within the Report Designer 
window.

Note: A Group name must be unique within the Report or Group under which it 
resides. 
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A Report name does not have to be unique if other Reports of the same name are at 
a higher level in the report hierarchy. In this case, the lowest level of the Report will 
be the one listed, with the higher level Report of the same name hidden behind it 
until such a time as the lower one is renamed or deleted. Reports of the same 
hierarchy level must have unique names. 

To rename a Report or Group from the Report Designer

1. In the Reports tab on the Report Designer window, open the Report containing 
the Group that you want to rename. 

2. Click the Properties button on the Report Editor toolbar. 

The Report Element Properties window opens. 

3. On the Element tab, overtype the contents of the Element Name field with the 
new name. 

4. Click OK to save your changes. 

Tip: You can also select the item you want to rename in the tree list in 
the Explorer pane, then use the Rename option on the right-click 
menu. 

Related topics

Groups and formats

Adding a group to a report

Adding a format to a group

Format types

Setting conditions for a format or group

Report element properties

Adding a format to a group

Accountants Enterprise in Australia only

To add a format to a group in the currently open report from the Report Designer 
(on the Reports tab)

1. Within the Report Editor window, select the Group to which you want to add the 
new Format. 

2. Click the Insert Format button,  on the Report Editor toolbar. 

The Report Element Properties window opens.
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3. Select the type of Format: Body, Header or Footer.

See “Report element properties” on page 101 for more information on how to 
complete the fields.

4. Click OK. 

Related topics

Groups and formats

Adding a group to a report

Renaming a report or group

Format types

Setting conditions for a format or group

Report element properties

Format types

Accountants Enterprise in Australia only

There are 3 format types:

Header

Header Formats function similar to headers in common word processing applications. 
They appear at the top of each report page to which they have been applied. 

Any Format can be used as a header. However, Formats intended for use as headers 
typically only occupy the first one or two rows in the Format Editor grid, allowing 
sufficient space on the page for any Body Format to be displayed. 

Note: If more than one header is to appear on a Report page, you may want to leave 
row 1 of the grid blank in any header Formats that are located below another 
header Format. This provides some white space between the headers on the 
report page. You can adjust the row height if too little or too much white 
space is appearing. 

In the Master Formats supplied by MYOB, the headers that have been created contain 
Page Header in their name. A Format that has been added to a report for use as a 

header, displays as  in the Design view of the Report Editor. 

You can use multiple header elements in a Group to facilitate various combinations 
of page headers. For example, you may want to use two header Formats to print both 
the Client Name and Balance Sheet Formats as page headers. 

A page header can have conditions (see “Conditional formatting” on page 171) 
associated with it. 
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For example, in the Company – Small Non Reporting report, there are mutually 
exclusive conditions set on 2 page headers. The Page Header – Compilation Report 
page header Format has the condition =DB.ClientDetails.Audited=NO, while the Page 
Header – Audit Report page header Format has the condition 
=DB.ClientDetails.Audited=YES. 

If the Audited field in the ClientDetails Database Map table contains a value of NO, 
then the Page Header – Compilation Format is used. If the field is set to YES, then the 
Page Header – Audit Report Format is used. 

Once you have added a Format to a Report, you can use the Report Element 
Properties window to change the Format type, if required. 

Body 

A Format that has been added to a report for use as a body Format displays as  in 
the Design view of the Report Editor. 

Assigning a Format as a body Format in a report inserts it on the page below any 
headers used and above any footers used. A body Format contains the main flow of 
text on a report page. 

Page breaks between body Formats can be controlled using the Page Break option in 
the Report Element Properties window. If you are not happy with the page breaks 
that are occurring within a body Format, you can change the pagination by leaving 
blank rows in the Format and by adjusting the margins. If you change the Format, 
make sure that this does not cause problems for any other reports that use that 
Format. 

You can also set conditions (see “Conditional formatting” on page 171) as to when a 
body Format is included in a report. 

Footer 

Footer Formats function similar to footers in common word processing applications. 
They appear at the bottom of each report page to which they have been applied. 

Any Format can be used as a footer. However, footer Formats typically only occupy a 
couple of rows in the Format Editor grid, allowing sufficient space on the page for the 
Format that has been assigned the role of body Format to display. You can use blank 
rows to provide some white space between the body Format and the footer Format 
on the report page. 

In the Master Formats supplied by MYOB, the footers contain Page Footer in their 

name. A Format that has been added to a report for use as a footer displays as  in 
the Design view of the Report Editor window. 

You can use multiple footer Formats in a Report Group to facilitate various 
combinations of page footers, if required. 
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A page footer can be added to the Report as a whole or to a group within a report. If 
added to a group, a page footer prints at the bottom of each page generated for that 
Group. 

A footer Format can have conditions (see “Conditional formatting” on page 171) 
associated with it. 

For example, in the Company – Large Non Reporting report, there are mutually 
exclusive conditions set on 2 page footers. The Page Footer – Audited Format has the 
condition =DB.ClientDetails.Audited=YES, while the Page Footer – Unaudited Format 
has the condition =DB.ClientDetails.Audited=NO. 

If the Audited field in the ClientDetails Database Map table contains a value of NO, 
then the Page Footer – Unaudited Format is used. If the field is set to YES, then the 
Page Footer – Audited Format is used. 

Once you have added a Format to a report, you can use the Report Element 
Properties window to change the Format type, if required. 

Related topics

Groups and formats

Adding a group to a report

Renaming a report or group

Adding a format to a group

Setting conditions for a format or group

Report element properties

Report element properties

Accountants Enterprise in Australia only

The Report Element Properties window is accessed from the Properties button on 
the Report Editor window. It consists of four tabs from where you can define the 
following for the “Groups and formats” on page 96 included in a report.

The Elements tab contains the following:

 The type of element 

The types of elements are:

 Report

 Group

 “Header” (see page 99)

 “Body” (see page 100)

 “Footer” (see page 100). 
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For Reports and Groups that contain Formats, this field cannot be changed. For 
Formats (Body, Header and Footer) and Groups that do not contain any Formats, 
you can use this field to change the element type, if required. When you change 
the type of element, you may also need to type in or select a different name in 
the Element name field. 

 Element name 

If you have selected either a Report or a Group, you can use this field to rename 
it. When Body, Header or Footer is selected in the Type of element field, this 
field becomes a drop-down listing the Format names.

You can replace the existing Format by selecting a Format from the drop-down 
list. 

By typing the first letter of the desired Element name you will go directly to that 
section of the alphabetically ordered list. 

 Font 

Choose a different font to be used for the report, if required. 

 Default column template

You can set the default column template for a report. The value selected here 
changes the default behaviour for the report when used in the Generator. The 
default selection is <use format definition> which uses the default column 
template specified in any format that uses column templates.

The same format can be used in the same or different reports with a different 
column template. This is achieved by applying a non default column template 
(e.g., 5 Year Trend) to the same format.

The default column template properties can be changed at the individual Format 
level or at the Group or Report level. 

 Format column template

This displays the name of the default column template, i.e., the column template 
that was applied to the format when the format was setup. Therefore, if you 
change the default, you know what it was.

The default column template is also available for groups, sections, body items, 
headers and footers.

 Condition

This is a criteria that must be met for a Group or Format to be included in a 
report. An element will automatically be included in the report if no condition is 
set.

See “Setting conditions for the elements” on page 103.

Related topics

Setting conditions for the elements

Setting conditions for a format or group
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Deleting an element from a report

Controlling page breaks

Margins in reports

Changing the page setup

Applying a watermark to a report

Setting conditions for the elements 

Accountants Enterprise in Australia only

Conditions can be set for a Group, Format or Section in a report. If a condition is 
applied, the criteria defined in the condition must be met for that Group, Format or 
Section to be included in a report. An item will automatically be included if it does not 
have a condition. 

Where a condition is set for a Group, that condition is tested before any conditions 
are set for Formats, Groups or Sections within that Group. Therefore, if a condition 
set for a Group is not met, then the conditions for the Formats within that Group are 
ignored, regardless of whether the condition for any of the Formats is true. 

The criteria within a condition must be met (i.e., is true) for the Group, Format or 
Section to be included in the report. For example, 

 The condition set for the Format Page Footer – Audited in the Company – Large 
Non Reporting is =DB.#EntityDetails.ClientDetails.Audited="Yes" 

 In contrast, the condition set for the Format Page Footer – Unaudited in the 
Company – Large Non Reporting is 
=DB.#EntityDetails.ClientDetails.Audited="No" 

A condition might be a simple check that a Database Map field contains a specified 
value. For example, 

 =DB.#EntityDetails.ClientDetails.CoverPage="Yes" 

Or it might have more complex conditions, requiring a formula using an AND or 
an OR operator, e.g.: 

 =AND(DB.#EntityDetails.ReportingExtraDetails.SFPEDatabase="Yes",DB.#EntityDet
ails.ReportingExtraDetails.SFPENatureOrFunction="Nature") 

Where a condition has been set for a Group, Format or Section, a small C displays in 

the top left corner of that item’s icon, , when the report is opened in the Design 
view of the Report Editor. 

Note: If the system cannot work out if a condition is true or not (e.g., if an invalid 
formula is entered), then the item will be included in the report. 
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Related topics

Report element properties

Setting conditions for a format or group

Deleting an element from a report

Controlling page breaks

Margins in reports

Changing the page setup

Applying a watermark to a report

Making changes to master reports

Working with formulas

Setting conditions for a format or group 

Accountants Enterprise in Australia only

Conditions are used to define the specific criteria that must be met for a Group, 
Format or Section to be included in a Report. An element is automatically included if 
it does not have a condition. 

Note: If the system cannot work out if a condition is true or false (e.g., if an invalid 
formula is entered), the element is included in the report. 

To set conditions for a format, group or section

1. In the Report Editor window on the Reports tab, select the Format, Group or 
Section that you want to set a condition for. 

2. Click the Properties button on the Report Editor toolbar. 

The Report Element Properties window opens.

3. Click the Conditions tab. 

4. In the Formula field, enter the formula for the condition that has to be met for 
the item to be included in the report. 

To check the formula, click .

5. Click OK to apply the changes you have made. 

Note: The changes are not saved until you click the Save button,  on 
the Report Editor toolbar. 
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Related topics

Report element properties

Setting conditions for the elements

Deleting an element from a report

Controlling page breaks

Margins in reports

Changing the page setup

Applying a watermark to a report

Adding a group to a report

Adding a format to a group

Working with formulas

Working with operators

Working with functions

Deleting an element from a report 

Accountants Enterprise in Australia only

You can delete Groups and Formats from Reports within the Report Editor window. 
Be aware that the Report Editor does not contain an undo facility. 

Note: If you delete a group, all elements residing under that group will also be 
deleted. 

To delete a report element 

1. Open the Report Editor window for the report you want to delete an element 
from. 

2. In the Report Editor window, click the Reports tab.

3. Select, by highlighting, the element you want to delete. 

4. Click the Delete button on the Report Editor toolbar. 

The message ‘Delete <element name>?’ appears. 

5. Click OK to delete the element. 

Related topics

Report element properties

Setting conditions for the elements

Setting conditions for a format or group

Controlling page breaks
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Margins in reports

Changing the page setup

Applying a watermark to a report

Making changes to master reports

Using the trash can

Report element properties

Controlling page breaks 

Accountants Enterprise in Australia only

Within the Report Element Properties window you can define settings to control the 
page breaks within your reports. The Page Break tab is where you apply the settings 
for whether a Body Format or Group begins on a new page. 

You can set conditions as to when a page break occurs. The options are: 

 Always 

Select this option to have a group or Format always start on a new page. 

 Never 

Select this option to have a group or Format simply follow on from the preceding 
format, with no page break. This is the default setting. 

 Condition below evaluates to TRUE 

Enter a condition in this field if you want a group or Format to start on a new 
page in a specific circumstances. For example, if you used the formula 
=DB.#EntityDetails.ClientDetails.EntityType="Reporting", and it is true for the 
selected report element, then the auditors report for a reporting entity will start 
on a new page. 

Related topics

Report element properties

Setting conditions for the elements

Setting conditions for a format or group

Deleting an element from a report

Margins in reports

Changing the page setup

Applying a watermark to a report

Working with formulas

Working with operators

Working with functions
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Margins in reports

Accountants Enterprise in Australia only

Standard margin settings are supplied with all the reports. You can override margin 
settings at the Report, Group and Format levels. 

When you set the margins at the report level, they apply to every element contained 
within the report unless specifically overridden by settings on an individual Format or 
Group. For example, if a report contains two Groups (at the same level), and you use 
the default margin settings for the report but change the margin settings for Group1, 
the margins for the report would apply to Group2 also, and any elements under that 
Group, while the margins set for Group1 would override the margins set for the 
report and would apply to any elements under Group1. 

Margins are defined in the Report Element Properties window. Here you can control 
whether the default margin settings that apply to the selected report element are to 
be overridden. Selecting the Override margin checkbox enables the value fields 
where you enter the margin settings you want to apply to the selected element. 

You can define the measurement for the top, bottom, right and left margins. 

Note: If you want to return to the default settings at any time, select the element 
for which you want the default settings to apply and deselect the Override 
margins checkbox. 

To change the margin settings for an element from within the Report Designer (on 
the Reports tab)

1. Select the report in the Explorer pane tree list that you want to change the 
margins for. 

2. Click the Edit Report button on the toolbar . 

The Report Editor window opens. 

3. Select the report element that you want to change.

4. Click the Properties button on the Report Editor toolbar. 

The Report element properties window opens. 

5. Click the Margins tab. 

6. Select the Override margins checkbox.

7. Edit the margin values as required. 

Use the up and down arrow or enter an amount in the fields. 

8. Click OK to apply your changes. 
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Note: Your changes are not saved until you save the report. 

Related topics

Report element properties

Setting conditions for the elements

Setting conditions for a format or group

Deleting an element from a report

Controlling page breaks

Changing the page setup

Applying a watermark to a report

Units of measurement

Changing the page setup

Accountants Enterprise in Australia only

To change the orientation of a report

1. In the Report Editor window on the Reports tab, select the report that you want 
to change the orientation for.

2. Click the Properties button.

The Report Element Properties window opens.

3. Click the Page Setup tab.

4. Select either the Portrait or Landscape option.

5. Click OK.

Related topics

Report element properties

Setting conditions for the elements

Setting conditions for a format or group

Deleting an element from a report

Controlling page breaks

Margins in reports

Applying a watermark to a report

Report element properties
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Applying a watermark to a report

Accountants Enterprise in Australia only

Within the Reporter Designer there are 2 ways to apply a watermark to a report:

Using the Properties window

1. Open a report.

2. Click the Properties button (from the Report Editor toolbar).

3. Click the Watermark tab.

4. Under Apply watermark, select the watermark that you want to apply to the 
report.

5. Under Watermark condition, you can type a condition for the Watermark.

If you do not type a condition the Watermark automatically displays.

Using the Tools menu

1. Select the report.

2. Click Tools > Watermark Setup.

3. Select Apply Watermark.

4. Select the watermark from the drop-down list.

5. Click OK.

Related topics

Report element properties

Setting conditions for the elements

Setting conditions for a format or group

Deleting an element from a report

Controlling page breaks

Margins in reports

Changing the page setup

Adding a watermark to a report using the Designer

Tools options

Accountants Enterprise in Australia only
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The current ledger(s) configuration can be specified when retrieving Current Ledger 
balances. This allows values from multiple ledgers to be combined and reported on 
using the standard report configurations. Ledgers listed here are considered the 
Current Ledger, meaning every value to be reported on for the Current Ledger will 
actually be the sum of the values from these ledgers.

You can:

 “Setting the font” (see page 25)

 “Selecting the ledger year” (see page 110)

 “Selecting the reporter year” (see page 112)

 “Creating column templates” (see page 113)

 “Report listing” (see page 114)

 “Refreshing ledger data” (see page 115)

 “Using the trash can” (see page 116)

 “Units of measurement” (see page 116)

 “Adding a watermark to a report using the Designer” (see page 117)

 “Convert formats” (see page 119)

 “Recalculate dependencies” (see page 120)

 “Report settings” (see page 121).

Related topics

Getting more information from reports

Selecting the ledger year 

Accountants Enterprise in Australia only

Within Report Designer you can select which ledger year you want to use to provide 
the client’s report data. The selected ledger year provides the ledger balances and 
Database Map data for the current values when reports are generated. The ledger 
year can be different to the selected reporter year. 

You can choose which ledger year to use to provide the client’s current ledger 
balances and “Database Map” on page 208 data when you run reports from within 
the Report Designer window. 
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Note: The selected ledger year is displayed in the Status Bar at the bottom of the 
Report Designer window. 
The selected ledger year is only used by Report Designer. When you run a 
report from the Report Designer window to test it, the data comes from the 
selected ledger year. However, when the same report is run from the 
Generating Reports window, the client data comes from the selected ledger 
year within the Generating Reports window and not from the selected ledger 
year in the Report Designer window. 

To change the current ledger year from within the Report Designer window

1. In the Report Designer window, select Tools > Ledger Year.

The Ledger year selection window opens with the currently selected year 
highlighted in the list box.

2. From the list box, select the ledger year you want to use to provide the client 
data for the reports. 

If the ledger year has more than one period, the Period drop-down list is 
enabled. 

3. Select the period that you will use as the current period when obtaining ledger 
balances.

4. Click OK. 

The Ledger year selection window closes and the Status Bar in the Report 
Designer window updates to show the selected ledger year and period. 

Related topics

Tools options

Selecting the reporter year

Creating column templates

Report listing

Refreshing ledger data

Using the trash can

Units of measurement

Adding a watermark to a report using the Designer

Convert formats

Recalculate dependencies

Report settings

Setting the font
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Selecting the reporter year 

Accountants Enterprise in Australia only

Within Report Designer you have the flexibility to choose the year you want to design 
reports for. This means that you can edit the contents of a report that was designed 
in a previous year or that is available in an upcoming year, just by changing one setting 
within Report Designer. 

When you select a reporting year it applies to the reports, Formats, Chart Map items 
and Database Map items you design or edit while that year is selected. If you revert 
to a previous year all these items are returned to the state they were in last time you 
edited them for that year. 

The reporter year is defined in the Reporter year selection window.

When you access the Reporter year selection window, it lists all the reporter years 
available for the selected client or entity type, depending on whether you opened 
Report Designer at the Client or Practice level. 

Note: The reporter year currently selected is displayed in the Status Bar at the 
bottom of the Report Designer window. 

To change the current reporter year within the Report Designer window 

1. In the Report Designer window, select Tools > Reporter Year. 

The Reporter year selection window opens with the currently selected year 
highlighted in the list box.

2. In the list of available reporter years, select the year you want to edit or design 
reports for. 

3. Click OK. 

The Reporter year selection window closes and the Status Bar in the Report 
Designer window updates to show the selected reporter year. All the 
information within the Report Designer window is refreshed to be correct for 
the selected year. 

Related topics

Tools options

Selecting the ledger year

Creating column templates

Report listing

Refreshing ledger data

Using the trash can

Units of measurement

Adding a watermark to a report using the Designer
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Convert formats

Recalculate dependencies

Report settings

Setting the font

Creating column templates

Accountants Enterprise in Australia only

Creating a Column Template makes it easy to set up columns that you want to appear 
on a report. It enables you to create columns based on actuals, receipts, payments, 
cash and budget for the current, previous or future year. You can style, apply 
headings and create formulas for each column within your template.

Once a Column Template has been created you can apply it to any report that 
appears in your report list. Therefore, you do not need to format each report for the 
columns you want to appear on them.

MYOB have included Column Templates at the Master level.

The Use Default configuration selects the default column template that is specified 
for the report. 

A test configuration drop-down list appears on the toolbar, which allows you to 
preview the report using a saved Column Template. The default selection is <use 
format definition>. This selection uses the defaults specified during format design for 
each individual format.

To create or edit column templates

1. Within your General Ledger software, and with the required client ledger open, 
select Reports > Reporter > Generate reports. 

Note: MAS Users: To access reports at the Practice level, select Reports > 
Reporter > Design Practice Reports. 
Accounts Users: Open the Configuration window, by navigating 
Start > Programs > MYOB Accountants Enterprise > Configuration. 
Then select Configure > Accounts > Accounts > Report Designer.

1. From the Generating Reports window, click the Column Template Editor button 
on the toolbar.

or

From the Report Designer window, click Tools > Column Template Editor.

2. Click on the New column template  icon to create a new column template.

3. Complete the details as required. 
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4. Click Apply.

Note: You need to click Apply after you have completed the details for 
each column. When you have completed the template, click Close.

Related topics

Tools options

Selecting the ledger year

Selecting the reporter year

Report listing

Refreshing ledger data

Using the trash can

Units of measurement

Adding a watermark to a report using the Designer

Convert formats

Recalculate dependencies

Report settings

Setting the font

Column templates

Creating and editing column templates

Deleting column templates

Column template properties

Defining column headings

Columns defined by user

Column defined by ledger

Report listing

Accountants Enterprise in Australia only

Report Listing enables you to control the list of reports that shows in the Generating 
Reports window. A practice level user can define the report list for all client level 
users, and client level users can define the list for their own use.

The Report Listing can also be changed from within the Generating Reports window 
by selecting Tools > Report Listing.

To access the Generator Report Listing within the Report Designer window

1. Select the Reports tab.

2. On the toolbar of the Reports tab, click .

or
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Click Tools > Generator Report Listing.

The Generator Report Listing dialog opens.

3. Select the reports that you want to be shown.

4. Click OK.

Related topics

Tools options

Selecting the ledger year

Selecting the reporter year

Creating column templates

Refreshing ledger data

Using the trash can

Units of measurement

Adding a watermark to a report using the Designer

Convert formats

Recalculate dependencies

Report settings

Setting the font

Refreshing ledger data

Accountants Enterprise in Australia only

The Refresh Ledger Data menu option, refreshes the report balances with any 
changes that have been made to a balance since the report was run. Changes are 
retrieved from the ledger balances on which the report is being run and displayed in 
the report. 

Therefore, you can make changes in your General Ledger software when you have 
Reporter open and click Tools > Refresh Ledger Data to update the balances without 
having to close Reporter. The refresh updates the preview.

Related topics

Tools options

Selecting the ledger year

Selecting the reporter year

Creating column templates

Report listing

Using the trash can

Units of measurement

Adding a watermark to a report using the Designer
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Convert formats

Recalculate dependencies

Report settings

Setting the font

Using the trash can

Accountants Enterprise in Australia only

Reporter includes a Trash Can facility. It is like a temporary holding area from which 
you can restore items you have deleted.

During the process of designing new reports you may choose to delete an item. 
Deleted items are stored in the trash can until such time as you access the Trash Can 
to Restore, Restore All, Remove or Empty Trash Can.

To access the Trash Can and use any of its functionality, click Tools > Trash Can. Then 
you are able to use any of the buttons at the bottom of the window.

Related topics

Tools options

Selecting the ledger year

Selecting the reporter year

Creating column templates

Report listing

Refreshing ledger data

Units of measurement

Adding a watermark to a report using the Designer

Convert formats

Recalculate dependencies

Report settings

Setting the font

Units of measurement 

Accountants Enterprise in Australia only

The Units of Measurement window is where you can define the type of units to be 
used when you define the measurement for margins, row height and row width 
within Report Designer. The options are: 

 centimetres 

 inches 

 millimetres. 
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To change the unit of measurement from within the Report Designer window

1. From the main menu in the Report Designer window, select Tools > Units of 
Measurement. 

The Units of Measurement window opens. 

2. In the Unit Type field, select the unit type you want to apply to the Report 
Designer. 

3. Click OK to apply the change and close the window. 

Related topics

Tools options

Selecting the ledger year

Selecting the reporter year

Creating column templates

Report listing

Refreshing ledger data

Using the trash can

Adding a watermark to a report using the Designer

Convert formats

Recalculate dependencies

Report settings

Setting the font

Margins in reports

Setting the row height

Setting the column width

Adding a watermark to a report using the Designer

Accountants Enterprise in Australia only

The Watermark appears when you preview, export or print the selected report. 

They are created at the hierarchy level that you accessed Reporter, that is at the 
Client or Practice level.

To add a watermark from the Designing Reports window

1. For client level (for both MAS and Accounts users), select Reports > Reporter > 
Design Client reports.

or

For practice level MAS users, select Reports > Reporter > Design Practice 
reports.
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or

For practice level Accounts users, open the Configuration window, Start > 
Programs > MYOB Accountants Enterprise > Configuration. Then select 
Configure > Accounts > Accounts > Report Designer.

The Designing Reports window opens for the client or the practice. 

2. Select a report.

3. Click Tools > Watermark Editor.

4. Click  to create a new Watermark.

5. Select the Type tab.

6. Select the type of the Watermark, Text or Picture.

If you select Text:

a. Enter the Text that you want to use as your watermark.

b. Select a colour from the drop-down list.

c. Select a Font, Size and whether you want it to be bold or italic.

d. Set the Rotation.

If you select Picture:

a. Select the Picture location. 

The drop-down lists the picture files that have been stored in the directory 
specified in the Location field in the Share picture on server section of the 
dialog.

Click the ellipsis to select a new location.

b. Select the Share picture on server checkbox, if you want other users to 
access it.

c. Set the location and filename.

7. Click the Location tab.

8. You can set the location by clicking any of the blue squares under Alignment.

Alternatively, you can Fine Tune the location of the watermark by entering in the 
vertical offset and the horizontal offset in centimetres.

9. Click the Page Range tab.

10. Check which page range where you want the watermark to appear.
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The available options are: All pages, First Page Only, Odd Pages Only, Even Pages 
Only, Last Page Only, Pages (if you select this you must enter the page numbers).

11. Click Apply.

The Watermark appears in the list, .

12. Click Close.

The list displays any configured watermarks. The arrow buttons allow you to 
control the order in which watermarks are drawn on the page. The drop-down 
list displays a list of watermarks.

Note: All watermark settings are saved and are loaded whenever 
Reporter is launched. The settings are ledger specific, not user 
specific.

Related topics

Tools options

Selecting the ledger year

Selecting the reporter year

Creating column templates

Report listing

Refreshing ledger data

Using the trash can

Units of measurement

Convert formats

Recalculate dependencies

Report settings

Setting the font

Applying a watermark to a report

Adding a watermark

Convert formats

Accountants Enterprise in Australia only

The Convert Formats menu item runs a routine to update formats created using 
earlier versions of Reporter to work with the current version of Reporter.

Note: You may not have to use this menu option. 
Only use this option when directed to by MYOB Support.
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To convert formats

1. Open the Report Designer.

2. Click Tools > Convert Formats.

Related topics

Tools options

Selecting the ledger year

Selecting the reporter year

Creating column templates

Report listing

Refreshing ledger data

Using the trash can

Units of measurement

Adding a watermark to a report using the Designer

Recalculate dependencies

Report settings

Setting the font

Recalculate dependencies

Accountants Enterprise in Australia only

Recalculate Dependencies reassigns any "lost" dependencies to the correct items.

You can view dependencies for Formats, Chart Map folders, Database Map tables and 
Database Map fields. This will list any formats and/or reports that reference the 
selected item and, in the case of Chart Map folders, any other Chart Map folders that 
contain a shortcut to the selected item.

To recalculate dependencies

1. Open the Report Designer.

2. Click Tools > Recalculate Dependencies.

To view dependencies

1. Click the appropriate tab (Chart Map, Database Map or Formats).

2. Right click the item.

3. Select View Dependencies.

The dependencies will be listed for that item.
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Related topics

Tools options

Selecting the ledger year

Selecting the reporter year

Creating column templates

Report listing

Refreshing ledger data

Using the trash can

Units of measurement

Adding a watermark to a report using the Designer

Convert formats

Report settings

Setting the font

Report settings

Accountants Enterprise in Australia only

To access this option within the Reporter Designer, click Tools > Report Settings. The 
available options for Report Settings are:

 Apply Rounding, which will display all figures in a report as rounded. However, 
this feature is dependent on the underlying General Ledger. When a report with 
rounding applied is previewed, printed or exported, the amounts provided by 
the General Ledger are rounded in accordance with the General Ledger system’s 
rules. 

Note: The Rounding option is only displayed if the underlying General 
Ledger is able to round balances. 

 Show page numbers, displays the page numbers on the printed report below 
any footer content. If this option is deselected the page numbers will not display.

 Show account codes, displays the account codes on the printed report. If this 
option is deselected the account codes will not display. 

Note: The account codes will only be included on a report if that option is 
included in the design of the report you select. They will display in 
the left-hand side margin for Masters. For example, a Detailed 
Balance Sheet or Detailed Profit and Loss.

 Set the Report Options. A summary of the current report options will be shown 
in the field. Click on the ellipsis to change or view the details.
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Related topics

Tools options

Selecting the ledger year

Selecting the reporter year

Creating column templates

Report listing

Refreshing ledger data

Using the trash can

Units of measurement

Adding a watermark to a report using the Designer

Convert formats

Recalculate dependencies

Setting the font

Applying rounding

Showing and hiding page numbers

Showing and hiding account codes

Setting the report options

Changing borders

Changing borders

Accountants Enterprise in Australia only

Click the Borders button to change or apply borders to the cell, row or column 
selection. You can use borders to create the effect of underlining in cells. For 
example, you may wish to apply a border to the bottom of cells containing totals to 
make them easy to spot on a report.

Related topics

Tools options

Selecting the ledger year

Selecting the reporter year

Creating column templates

Report listing

Refreshing ledger data

Using the trash can

Units of measurement

Adding a watermark to a report using the Designer

Convert formats

Recalculate dependencies

Setting the font

Applying rounding



Designing reports

MYOB AE Reporter | Version 3.4 User Guide | 123

Showing and hiding page numbers

Showing and hiding account codes

Setting the report options

Formats

Accountants Enterprise in Australia only

Formats are the building blocks from which reports are created. They are the most 
important and most complex type of item in Reporter. Formats can contain 
references to account information using links to the Chart Map and references to 
Database Map fields, as well as standard text, formulas, styles and layout. 

All the available Formats for the ledger you have open, are listed in a tree view in the 
Formats tab within the Report Designer window. This list can contain Formats at 
different hierarchy levels, depending on the level at which you opened Report 
Designer. 

From here you can:

 View the available Formats.

 Select one for viewing or editing.

 Create a new Format or copy or delete an existing one. 

MYOB provides you with a number of Master Formats. These can be edited and saved 
at a different hierarchy level. You can also create your own Formats at either the 
Practice or Client level. 

As with all items in Report Designer, there are 3 hierarchy levels of Formats. See 
“Reporter hierarchy” on page 11. 

Note: Within the Report Designer window you can only see Formats that exist at the 
hierarchy level you entered the software through and above. That is, if you 
enter Report Designer from your General Ledger software at the Practice 
level then you only see Master and Practice level Formats listed. If you enter 
at the Client level, then you will see all three levels of Formats. 
Only those Formats applicable to the entity type of the selected ledger are 
displayed. 

Related topics

About the Formats tab

About the Formats Editor

Making changes to master formats

Creating new formats

Working with formats
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Previewing formats

Applying column templates to formats

Working with styles

Formatting cells

Notes and references

About the Formats tab 

Accountants Enterprise in Australia only

Formats are displayed on the Formats tab on the Report Designer window. They are 
created and edited in the Format Editor window. 

From the Formats tab you can: 

 Create new formats

 Edit existing formats 

 Delete formats

 Preview (and from there print) reports. 

When working in the Formats tab there are two work areas:

 the left-hand Explorer pane 

 the right-hand Design pane. 

Drag and drop

When inserting Chart Map items and Database Map items into Formats, you can 
simply click on either the Chart Map tab or Database Map tab while the Format 
Editor window is open, then drag the required item from the Explorer pane and drop 
it into a cell in the Format Editor window. 

Right-click formats menu

In addition to the toolbars, there is a right–click menu available in the Explorer pane. 

Option Description

Copy This is standard Windows copy functionality. You can copy and 
paste between formats and also between different ledgers.
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Copy to Client / 
Practice

Use this menu item to save the currently selected Format to 
the level at which you opened Report Designer (i.e., Client or 
Practice). 

This menu option will read Copy to Client if you opened 
Report Designer at the Client level, allowing you to save a 
Practice level or Master level item at the Client level. 

If you opened Report Designer at the Practice level it will read 
Copy to Practice, allowing you to save a Master level item at 
the Practice level. 

The new level version of the Format will conceal the higher 
level version until such a time that the lower level version is 
renamed or deleted. 

Copy to Clipboard This option allows you to copy Formats to the clipboard and 
paste them into Word. This enables you to view the properties 
of all the Formats without having to open each Format's 
Properties window.

Cut This is standard Windows cut functionality. This option is only 
available if the selected Format can be moved at the current 
level (i.e., Master Formats cannot be cut at the Practice or 
Client level). 

Paste This is standard Windows paste functionality. When you paste 
a Format it will be pasted to the current level (i.e., Practice or 
Client). You can copy and paste between formats and also 
between different ledgers.

Properties Select this option to access the Format Properties window 
where you can add, view or edit the notes that have been 
added to the selected item. To add or edit notes simply type 
into the Description field and then click the Apply button to 
save your entry. If Report Designer is not open at the required 
hierarchy level to edit the properties, then the window will 
open as read–only. 

Rename This option is used to rename the selected Format.

Save As Use this menu item to create a copy of the currently selected 
Format. The copy will be saved to the level at which Reporter 
is currently open, that is, Practice or Client. You can then edit 
the name as required.

View 
Dependencies

This option enables you to see which reports use a particular 
format.

Option Description
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Related topics

Formats

About the Formats Editor

Making changes to master formats

Creating new formats

Working with formats

Previewing formats

Applying column templates to formats

Working with styles

Formatting cells

Notes and references

About the Formats Editor 

Accountants Enterprise in Australia only

The Format Editor window is the work area in which you create, edit and preview a 
Format. When you are working in the Formats tab, the Format Editor window is 
displayed on the right-hand side of the Report Designer window. The Format Editor 
window has two views, just like the Report Editor window. The editing is done in the 
Design view, when the window looks like a spreadsheet. When you preview a Format 
the window changes to the Preview view, showing you what the Format will look like 
when it is printed. 

When you select a Format for editing or create a new one, the Format Editor window 
opens in the Design view. 

There are various ways to open the Format Editor window: 

 Double-click a Format in the tree list within the Formats tab. 

 Click either the New Format  or Edit Format  button on the toolbar. 

 Select a Format and press the [Enter] key. 

 Select Edit or New from the right–click menu. 

View Master / 
Practice

Select this option to view the matching Master or Practice 
level Format for the currently selected one. The Practice level 
Format or Master level Format window will be opened, with 
the tree displayed to show the location of the Master or 
Practice level item. If Report Designer is open at the Practice 
level, this option will display View Master. If Report Designer 
is open at the Client level, both options will be displayed. 

Option Description
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The name of the new or selected Format will be displayed in the title bar of the 
window. You can have multiple Format Editor windows open at once. Each instance 
of the window has its own toolbar. 

Drag and drop

When inserting Chart Map items and Database Map items into Formats, you can 
simply click on either the Chart Map tab or Database Map tab while the Format 
Editor window is open, then drag the required item from the Explorer list and drop it 
into a cell in the Format Editor window. 

Right-click Formats Editor menu

In addition to the toolbars, there is a right click menu available in the Design view of 
the Format Editor window on the row numbers or column headings. 

Option Description

Apply Column 
Template

Select this option to access the Apply Column Template 
window, ready for existing column templates to be selected 
for the format or for a column template already applied to 
the format to be altered.

Bookmark Select this option to access the Bookmarking (Note 
reference) window, where you can apply settings to 
bookmark a row for note referencing or cross-referencing 
purposes. 

This option only appears when you right-click on a row 
label.

Clear Contents Select this option to remove the contents of the selected 
cell(s), row or column. You can achieve the same effect by 
pressing the [Delete] key on the keyboard.

Conditioning 
Formatting

Select this option to access the Conditional Formatting 
window to vary the formatting of the cell under specific 
conditions.

Delete Select this option to delete the selected row or column.

Format Cells Select this option to access the Format Cells window to 
change the current formatting of the cell selection. 

This option is not available if the blue Print Condition 
column is selected.

Insert Select this option to add a blank row or column above the 
currently selected row or column.

Insert Picture Select this option to insert a picture into your format. 
When you have chosen the picture, select the alignment 
and whether you want to share it with other users.
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Note: The items on the right–click menu differ depending on whether you right–
click on a grid, a row label or a column label. 

The Format Editor window can be resized, minimised, maximised and moved around 
within the Report Designer window. 

Navigating in the Formats Editor work area 

Once you become familiar with the Design area of the Format Editor window you will 
find quick and easy ways of moving around within it. Below are a number of key and 
mouse combinations which you may find helpful. 

You can move the cell selection by either clicking with the mouse or using the arrow 
keys on the keyboard. Click and drag to select a cell range. Click in a column’s label, 
e.g. B, to select that column. Click in a row’s label, e.g. 4, to select that row. To select 
multiple adjacent rows or columns, click in a row or column label and drag across the 
rows or columns you want to select. 

Keep Section 
Together

This option is only available when multiple rows have been 
selected and none have already had the Keep Section 
Together option applied.

Page Break Select this option to insert a page break before the line it is 
used on.

Repeat Select this option to access the Repeat Settings window 
where you can determine the settings for repeating the 
selected cells for a Chart Map folder or a Database Map 
table. 

This option only appears when you right-click on a row 
label.

Row Height / 
Column Width

Select this option to access the Row Height or Column 
Width windows, depending on whether you have selected 
a row or a column. You can then change the measurements 
for the selected item.

Space Filler Select this option to place a marker in the Format header 
column, which is then used to resize the Format with 
respect to the page size and the amount of information 
shown on the page.

Keyboard Action Description

[Ctrl] + [End] Moves the cursor to the cell at the bottom right of 
the grid area in which data has been entered.

Option Description
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Format properties 

The Format Properties window is where you can add, view or edit the notes that have 
been added to the selected Format. The Format Properties window is accessed by 
selecting the Format in the tree list of the Explorer pane, then the Properties options 
from the right–click menu. 

To add or edit notes, simply type into the Description field and then click the Apply 
button to save your entry. 

Note: If Report Designer is not open at the required hierarchy level to edit the 
properties, then the window will open as read–only. 

Related topics

Formats

About the Formats tab

Making changes to master formats

Creating new formats

Working with formats

Previewing formats

Applying column templates to formats

Working with styles

[Ctrl] + [Home} Moves the cursor to cell A1.

[End] Moves the cursor to the cell at the bottom right of 
the grid area in which data has been entered.

[Home] Moves the cursor to the first column in the currently 
selected row.

Page Down This jumps the current cell selection down one page.

Page Up This jumps the current cell selection up one page.

[Shift] + arrow keys To select a cell range, move the selection to the top 
left corner of the intended selection area. Hold down 
[Shift] and use the arrow keys to select a cell range.

[F2] + [Shift] + arrow keys To select text within a cell, one character at a time, 
select the cell and press [F2], then hold down the 
[Shift] key and use the arrow keys to select the text.

[F2]+ [Shift] + [Ctrl] + 
arrow keys

To select text within a cell, one word at a time, select 
the cell and press [F2], then hold down [Shift] and 
[Ctrl] and use the arrow keys to select the text.

Keyboard Action Description
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Formatting cells

Notes and references

Creating a reference to non-transactional client information (Database Map)

Creating a reference to account information (Chart Map)

Creating notes and cross-references

Bookmarking cells in a format

Clearing contents

Applying a space filler

Working with functions

Working with formulas

Named cell ranges

Setting the column width

Setting the row height

Keeping sections together

Conditional formatting

Repeat settings

Applying formatting to cells

Inserting page breaks

Applying column templates to formats

Making changes to master formats 

Accountants Enterprise in Australia only

Report Designer provides you with a number of Master level Formats. You can 
customise these to suit your practice requirements or the requirements of an 
individual client. There are, however, a few things you should be aware of before you 
start to customise these items. 

Master level Formats can be used as the basis for creating new Formats. As you 
cannot save changes to Master Formats themselves, when you edit a Master Format 
and save the changes Report Designer automatically saves the Format to the level at 
which you opened Report Designer (Practice or Client). 

When you edit and save a Master Format to the Practice or Client level, or use the 
Copy to Practice \ Client right–click menu option, the Master Format no longer 
displays in the Formats tab. It is replaced by the Practice or Client version. The Master 
version remains in the background and is reinstated if the Client and/or Practice 
versions are deleted or renamed. The Master Format displays when Report Designer 
is opened from client ledgers for which a Client version of the Format has not been 
created. 
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Note: If you create a Practice version of a Format, it will be effective for all the client 
ledgers. The Master level version is not displayed in the list of Formats while 
a practice version of the same report exists. 

If you do not want to hide the Master version of a Format, but need to make changes 
to it, use the Save As feature on the right–click menu of the Formats tab Explorer 
pane to rename the Format. It is automatically saved to the current level and the 
Master version will display in the list with the original name. 

Be aware that if you create a Practice or Client copy of an item that is referenced by 
a Format, e.g., you change a referenced Master Chart Map item and save it at the 
Practice level, this does not cause the Format itself to become non-Master. A Format 
only becomes non-Master when it is saved to either the Practice or Client level. 

If you are deleting a Client level Format where a Practice level version also exists, you 
will see the Practice version reinstated first. To get back to the Master Format you will 
also need to delete the Practice version. 

Related topics

Formats

About the Formats tab

About the Formats Editor

Creating new formats

Working with formats

Previewing formats

Applying column templates to formats

Working with styles

Formatting cells

Notes and references

Creating and editing column templates

Creating new formats

Accountants Enterprise in Australia only

If there are no existing Formats on which you can base the new one you require, you 
will need to create your Format from scratch. You do this from the Formats tab in the 
Report Designer window. 

To create a new format

1. Open the Report Designer from your General Ledger software, selecting one of 
the following menu options: 
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 to create a Format for a specific client, select Reports > Reporter > Design 
Client reports. 

 to create a Format for use practice wide for MAS users, select Reports > 
Reporter > Design Practice reports.

 to create a Format for use practice wide for Accounts users, open the 
Configuration window, Start > Programs > MYOB Accountants Enterprise > 
Configuration. Then select Configure > Accounts > Report Designer.

The Report Designer opens. 

2. Select the Formats tab. 

3. On the toolbar of the Formats tab, click the New Format button, .

or 

Select File > New from the menu. 

The Format Editor window opens. 

A default name for the Format will be displayed in the title bar of the Format 
Editor window. 

You will be prompted to change the name when you save the Format. 

4. Define the contents of the Format by using one or a combination of the 
following: 

 Adding Chart Map items by dragging and dropping from the Chart Map tab. 

 Adding Database Map items by dragging and dropping from the Database 
Map tab. 

 Entering text into cells. 

 Entering functions into cells. 

 Applying styles or formatting to the Format contents.

5. When all the required content has been defined, use the Preview button  to 
check what the contents will look like. 

6. Click the Save  button.

or 

Select File > Save from the menu to save your changes.

A window will be displayed where you can enter a name for the new Format. 

7. Enter the new name.

8. Click OK. 



Designing reports

MYOB AE Reporter | Version 3.4 User Guide | 133

Once saved, the new Format will appear in the list of Formats in the Explorer 
pane. 

Creating a new format based on an existing one 

If you want to create a new Format which is substantially similar to an existing one, 
but you want to retain the existing Format, the easiest way is to use the existing 
Format as the basis for the new one. 

When creating Formats based on higher level Formats than the one that you opened 
in Report Designer, the new Format is automatically saved to the current (Practice or 
Client) level. This new Format replaces the higher level one until such time as the new 
Format is renamed or deleted, then the higher level Format is reinstated. 

If you want to base the new Format on an existing one which is at the same level as 
the one that you opened in Report Designer (e.g., you want to use a Practice level 
Format to create another Practice level Format) you will need to create a copy of the 
existing Format using the Save As function on the right–click menu. 

There are three methods for creating a Format based on another Format: 

 Copy a Format from a higher level in the hierarchy to the level at which you are 
currently working. For example, you can save a Master Format to the Client 
level. Select the Format to base the new one on, then use the Copy to client or 
Copy to Practice options on the right–click menu in the Explorer pane.

 Select the Format to base the new one on, then use the Save As option on the 
right–click menu in the Explorer pane. The new Format will be saved to the 
current level (Practice or Client).

 Open a higher level Format so the Format Editor window is displayed, make your 
edits, then save the Format. It is automatically saved to the current level. 

If you create a Practice or Client version of a Master Format, the reports that use that 
Format will use the version you have created. 

Drag and drop

When inserting Chart Map items and Database Map items into Formats, you can 
simply click on either the Chart Map tab or Database Map tab while the Format 
Editor window is open, then drag the required item from the Explorer list and drop it 
into a cell in the Format Editor window. 

Related topics

Formats

About the Formats tab

About the Formats Editor

Making changes to master formats

Working with formats

Previewing formats
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Applying column templates to formats

Working with styles

Formatting cells

Notes and references

Renaming a format

Editing a format

Deleting a format

Undo / Redo in Design View

Working with formulas

Working with operators

Working with functions

Print conditions.

Working with formats

Accountants Enterprise in Australia only

When you working with formats, you can:

 “Renaming a format” (see page 134)

 “Editing a format” (see page 135)

 “Deleting a format” (see page 136)

 “Undo / Redo in Design View” (see page 138)

 “Working with formulas” (see page 139)

 “Working with operators” (see page 141)

 “Working with functions” (see page 143)

 “Print conditions” (see page 154).

Related topics

About the Formats tab

About the Formats Editor

Making changes to master formats

Creating new formats

Previewing formats

Renaming a format 

Accountants Enterprise in Australia only

A Format name must be unique within the entity and level at which it resides. A 
Format name does not have to be unique if other Formats of the same name are at a 
higher level in the hierarchy. In this case, the lowest level of the Format is the one 
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listed, with the higher level one of the same name hidden until the lower one is 
renamed or deleted. 

Note: You can only rename a Format which resides at the same level as that which 
you entered Report Designer. That is, if you are at the Client level, you will not 
be able to rename Practice or Master Formats. 

To rename a format within the Report Designer window (on the Formats tab)

1. Select the Format that you want to rename. 

2. On the right–click menu select Rename.

The Reporter window opens. 

3. Overtype the name with the new name. 

By default the system will have entered the original name suffixed with a 
number. 

4. Click OK to save your changes. 

Related topics

About the Formats tab

About the Formats Editor

Making changes to master formats

Creating new formats

Working with formats

Previewing formats

Editing a format

Deleting a format

Undo / Redo in Design View

Working with formulas

Working with operators

Working with functions

Print conditions

Editing a format 

Accountants Enterprise in Australia only

You can edit a Format at any level of the hierarchy, but if you edit a Format that is at 
a higher hierarchy level than that at which you opened Report Designer (e.g., you 
open Report Designer at the Client level and edit a Master or Practice level 
component) then the edited Format is saved to the level you are working at. When 
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you save your edits the icons change to show the new hierarchy level of the edited 
Format. 

To edit a format within the Report Designer (on the Formats tab)

1. In the Explorer pane, select the Format that you want to edit. 

2. Double–click the item.

or

Click the Edit Format toolbar button, .

or 

Select Edit from the right-click menu. 

The Format Editor window opens showing the contents for the selected item. 

3. Edit the contents as required. 

4. When all the changes have been made, click the Save button . 

The Format saves at the current level. 

Related topics

About the Formats tab

About the Formats Editor

Making changes to master formats

Creating new formats

Working with formats

Previewing formats

Renaming a format

Deleting a format

Undo / Redo in Design View

Working with formulas

Working with operators

Working with functions

Print conditions

Deleting a format 

Accountants Enterprise in Australia only

If a Format is no longer required within your practice you can delete it from the 
Report Designer. The Format is no longer available in the Report Designer window. 
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Note: If you delete a Practice or Client level Format that has a corresponding higher 
(Master or Practice) level Format, then the higher level Format is reinstated 
when the lower level one is deleted. 

Master Formats cannot be deleted. You also cannot delete:

 Master reports 

 Master Database Map items 

 Master Chart Map items or any of the related master ranges or mappings. 

Note: There is no undo facility in Report Designer. 

To delete a client or practice level format within Report Designer (on the Formats 
tab)

1. To delete a client Format, open the Report Designer window from the client 
ledger for whom the Format you want to delete was created. 

or

To delete a practice Format, open Report Designer at the Practice level for the 
correct entity. 

2. Select the Formats tab in the Explorer pane. 

3. Select the Format you want to delete and click the Delete button,  on the 
toolbar. 

The confirmation message Delete Format <report name>? appears. 

4. Click Yes to delete the Format. 

The Format no longer appears in the Formats tab. If the deleted Format was 
based on an existing Format at a higher level, then the original higher level 
Format will appear in place of the one you have deleted. 

Related topics

About the Formats tab

About the Formats Editor

Making changes to master formats

Creating new formats

Working with formats

Previewing formats

Renaming a format

Editing a format

Undo / Redo in Design View
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Working with formulas

Working with operators

Working with functions

Print conditions

Undo / Redo in Design View

Accountants Enterprise in Australia only

If you have made a mistake while designing your Formats you can undo.

When you save a format you cannot undo. However, the actions are not cleared. You 
are able to undo changes made prior to saving.

Undo is restricted to the following actions:

 Bookmarks — new, edit and delete.

 Named Ranges — new, edit and delete.

 Column Templates — new, edit and delete.

 Space Filler — new, edit and delete.

 Page Break — new, edit and delete.

 Repeat — new, edit and delete.

 New / Edit / Delete / Format cells.

 Cut / Paste / Delete and Clear Contents.

 Row Height / Column Width.

 Styles (using the Style Editor).

 Test Configuration.

To undo an action, click .

To redo an action, click .

Related topics

About the Formats tab

About the Formats Editor

Making changes to master formats

Creating new formats

Working with formats

Previewing formats

Renaming a format

Editing a format

Deleting a format
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Undo / Redo in Design View

Working with formulas

Working with operators

Working with functions

Print conditions

Bookmarking cells in a format

Clearing contents

Applying a space filler

Working with functions

Working with formulas

Named cell ranges

Setting the column width

Setting the row height

Keeping sections together

Conditional formatting

Repeat settings

Applying formatting to cells

Inserting page breaks

Applying column templates to formats

Working with formulas 

Accountants Enterprise in Australia only

Formulas are used to either calculate a value (using constants, cell values, named 
ranges, Chart Map or Database Map references and operators) or to compare values 
to produce an outcome of either TRUE or FALSE. 

You can use formulas to: 

 Reference account information using the Chart Map within a Format. 

 Reference non-transactional data in the Database Map within a Format. 

 Set conditions for row inclusion when printing or previewing a Format. 

 Set conditions for including an element in a report. 

 Set conditions for a page break. 

 Calculate values, using references to cells and constants. 

 Create notes and cross–references. 

There is a special kind of formula called a function. A function is a pre-defined formula 
that is used for a specific purpose. Reporter comes with a list of available functions to 
make it easy for you to work with the more common ones. See “Working with 
functions” on page 143 for more information. 
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Formulas can range from very simple references to complex expressions. For 
example, the following are formulas (numbers 1 and 2 will give the same result, as will 
numbers 3 and 4): 

1. =DB.OtherReports.DirectorsReport.SignedDay 

2. {DB.OtherReports.DirectorsReport.SignedDay} 

3. {DB.OtherReports.Director.Title} {DB.OtherReports.Director.FirstName} 
{DB.OtherReports.Director.MiddleName} {DB.OtherReports.Director.LastName} 
{IF(DB.OtherReports.Director.DateRetired<DB.#EntityDetails.ClientDetails.YearEn
dDate, "retired 
{DB.OtherReports.Director.DateRetired}",IF(DB.OtherReports.Director.Appointed
AfterFinYear="Yes", "appointed {DB.OtherReports.Director.DateAppointed}",""))} 

4. =DB.OtherReports.Director.Title&" "&DB.OtherReports.Director.FirstName&" 
"&DB.OtherReports.Director.MiddleName&" 
"&DB.OtherReports.Director.LastName&IF(DB.OtherReports.Director.DateRetire
d<DB.#EntityDetails.ClientDetails.YearEndDate," retired 
"&DB.OtherReports.Director.DateRetired,IF(DB.OtherReports.Director.Appointed
AfterFinYear="Yes"," appointed "&DB.OtherReports.Director.DateAppointed,"")) 

In the examples given above, you will notice that the formulas are not expressed in 
the same way. In the first formula, the expression is surrounded by braces {}. In the 
second formula, the expression begins with an equal sign = and double quotes ". 
Ampersands (&) are used to identify the start and end of a field name. 

Typically, the method using braces is used to provide a referenced value in a text 
string, for example: 

Dated this {OtherReports.DirectorsReport.SignedDay} day of 
{DB.OtherReports.DirectorsReport.SignedMonth},{DB.OtherReports. 
DirectorsReport.SignedYear} 

or

The {DB.Text.Director} {DB.Text.IsAre} solely responsible for the information 
contained in the general purpose financial report. 

However, more complex formulas can be expressed using braces. For example, 

{IF(DB.#EntityDetails.ClientDetails.YearEndDate= 
DB.#EntityDetails.ClientDetails.PeriodEndDate,"year","period")} 

Note: Remember that spaces are static text. 

Any text within the braces must be enclosed in quotes to avoid being confused with 
the names of Chart Map items or Database Map table and field names. For example: 
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Related topics

About the Formats tab

About the Formats Editor

Making changes to master formats

Creating new formats

Working with formats

Previewing formats

Renaming a format

Editing a format

Deleting a format

Undo / Redo in Design View

Working with operators

Working with functions

Print conditions

Creating notes and cross-references

Setting conditions for the elements

Named cell ranges

Working with operators 

Accountants Enterprise in Australia only

Operators are used in formulas to perform basic mathematical operations such as 
addition, subtraction, multiplication, to combine numbers and produce numeric 
results. They are also used to compare values produced, so that an outcome of either 
TRUE or FALSE can be acted on. 

The categories of operators are as follows: 

Arithmetic operators 

Formula These accounts have been prepared using the 
{if(DB.ClientDetails.Disclosure= "Full", "Schedule x", 
"Schedule y")} disclosure requirements. 

Will be displayed as These accounts have been prepared using the Schedule 
y disclosure requirements. 

& 
(ampersand) 

Text string concatenation. Connects two items to create a 
single item. 

+ 
(plus sign) 

Addition (numeric and string values), e.g., 6+7. 
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Reference operators 

Comparison operators 

Comparison operators compare two values and then produce the logical value TRUE 
or FALSE. 

Related topics

About the Formats tab

About the Formats Editor

Making changes to master formats

Creating new formats

- 
(minus sign) 

Subtraction (numeric values only), e.g., 7-6. 

Negation (numeric values only), e.g., -1. 

*

(asterisk) 

Multiplication (numeric values only). 

/ 
(forward slash) 

Division (numeric values only). 

% 
(percentage) 

Percentage, for example =100*20%. 

: 
(colon) 

You can express a range as either B2:B7 or B7:B2. For 
ease of we suggest that you express the range with the 
lowest value first. 

, 
(comma) 

Use the comma to reference cells which are not 
consecutive, e.g., SUM(B2,B12) would add together the 
values in cells B2 and B12, but would not include the 
values from the cells in between. 

= Returns TRUE if two items are equal. 

<> Returns TRUE if two items are not equal. 

> Returns TRUE if the first item is greater than (more than) the 
second item. 

< Returns TRUE if the first item is smaller than (less than) the 
second item. 

<= Returns TRUE if the first item is lesser than or equal to the 
second item. 

>= Returns TRUE if the first item is greater than or equal to the 
second item. 
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Working with formats

Previewing formats

Renaming a format

Editing a format

Deleting a format

Undo / Redo in Design View

Working with formulas

Working with functions

Print conditions

Working with functions 

Accountants Enterprise in Australia only

A function is a specific type of pre-designed formula that performs calculations by 
using values, referred to as arguments, in a particular order or structure. Arguments 
can be numbers, text, logical values such as TRUE or FALSE, error values such as #N/
A, or cell references. The argument you specify must produce a valid value. 
Arguments can also be constants, formulas or other functions. 

There are a number of different functions provided in the Report Designer. To use 
them, simply type the equals sign (=) into a cell in the Format Editor window, then 
enter the name of the function you want to use. For example ‘=Page’ or ‘=If()’. This 
method only works if it is the first entry in the cell. If the cell where you want to enter 
the function already has content, you will need to place the function command within 
braces, e.g., {NOTE(Cash)}. 

Functions can be embedded in more complex formulas, where they can return a 
value or a TRUE/FALSE. For example: 

The {IF(CM.DirectorsReport.NPAT+CM.SFPEF.ExtraordinaryItems <0,"profit","loss")} 
of the company for the financial {yearOrperiod} after providing for income tax 
{IF(CM.SFPEF.ExtraordinaryItems<>0,"and extraordinary items ","")} amounted to 
${CM.DirectorsReport.NPAT+CM.SFPEF.ExtraordinaryItems}. 

In the example above the section {yearOrperiod} is referring to a named range. 

Functions are not case sensitive, e.g., sum(b2:b5) produces the same result as 
SUM(B2:B5). However using capitals aids in easily differentiating cell references and 
function names from any surrounding text. 

Available functions

Function Description

AccountValue =ACCOUNTVALUE(<AccountCode>,<FieldName>)

Returns the specified field value for the specified account 
code, e.g., =ACCOUNTVALUE(680,DESCRIPTION) returns the 
description of account 680. 
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And And(<Argument1>,<Argument2>...) 

All of a number of conditions must be met for the expression 
to be evaluated as being TRUE. 

The structure is AND(<condition to be met>,<condition to be 
met>,<condition to be met>). There is no limit on the number 
of conditions that can be specified. 

For example, 

=AND(DB.SFPE.DatabaseValues="No",DB.SFPE.Expensesby="
Nature") 

For this formula to be evaluated as TRUE, the DatabaseValues 
field in the SFPE table must have a value of ‘No’ and the 
Expensesby field in the same table must have a value of 
Nature. 

Avg Avg(<Cell Range>) 

The Avg function is used to calculate the average of the values 
in a cell range. Any blank cells in the range will not be 
included. 

For example,

=AVG(B1:B5) 

=AVG(B1,B2,B3) 

=AVG(B1+B2+B3) 

Count Count(<Cell Range>) 

Use the Count function to return the number of cells in a cell 
range that are displayed when the Format is previewed (i.e., 
the cells for which a print condition has not been set or for 
which the print condition was satisfied). Cells containing a 
zero will not be included in the count. If any of the cells in the 
range are in a row that is set to repeat, the function includes 
the number of times the cell repeats in the preview with a 
non zero balance. 

For example,

=COUNT(A1:C5) 

Function Description
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Countrows Countrows() 

Use the Countrows function to return the number of rows in 
a range that are displayed when the Format is previewed (i.e., 
the rows for which a print condition has not been set or for 
which the print condition was satisfied). If any of the rows in 
the range have been set to repeat, the function includes the 
number of times the row is repeated in the preview. 

For example,

=COUNTROWS(1:5) 

This function will include rows that contain zero values, e.g., if 
you repeat for a Chart Map item and elect to ‘Show zero 
balances’. 

CURRENTPERIOD =CURRENTPERIOD

Returns the end date of the current period, as specified in the 
Ledger year selection dialog.

CURRENTYEAR =CURRENTYEAR

Returns the end date of the current year, as specified in the 
Ledger year selection dialog.

FIRSTPERIOD =FIRSTPERIOD(<Date>)

Returns the end date of the first period in the year containing 
the specified date.

The date can be supplied directly, via a Database Map field or 
via another function.

For example,

=FIRSTPERIOD(30/11/2005)

=FIRSTPERIOD(DB.OtherReports.Director.DateAppointed)

=FIRSTPERIOD(NOW)

You can also use this function without supplying a date, i.e., 
=FIRSTPERIOD. In this case, it will return the end date for the 
first period in the year for which the cell or column is 
formatted. If the function is used outside of a cell or column, 
it will use the current year, as specified in the Ledger year 
selection dialog.

Function Description
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FINALPERIOD =FINALPERIOD(<Date>)

Returns the end date of the final period in the year containing 
the specified date. 

The date can be supplied directly, via a database map field or 
via another function.

For example,

=FINALPERIOD(30/11/2005)

=FINALPERIOD(DB.OtherReports.Director.DateAppointed)

=FINALPERIOD(NOW)

You can also use this function without supplying a date i.e. 
=FINALPERIOD. In this case, it will return the end date for the 
final period in the year for which the cell or column is 
formatted. If the function is used outside of a cell or column, 
it will use the current year, as selected in the Ledger year 
selection dialog.

FINALYEAR =FINALYEAR

Returns the end date of the latest year for which ledger data 
is available.

FIRSTYEAR =FIRSTYEAR

Returns the end date of the earliest year for which ledger 
data is available.

If If(<Argument>,<Value1>,<Value2>) 

The If function enables you to set conditions for when a 
certain value displays, and to specify what value to display if 
those conditions are not met. 

The structure is IF(<condition to be met>,<value to display if 
condition is met>,<value to display if condition is not met>) 

For example,

=IF(CM.BalanceSheet.Assets.Current.GST>0,CM.BalanceSheet
.Assets.Current.GST,0) 

If the total value in the account or accounts mapped to the 
BalanceSheet.Assets.Current.GST Chart Map item is greater 
than zero, the value in the referenced account or accounts 
will be displayed. If the value is not greater than zero, a value 
of zero will be displayed. 

Function Description
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INOTE INOTE(<Bookmark Name>,<Key>)

Returns the note number assigned to the specified bookmark 
where the bookmark is on a repeating row and the note 
number needs to be incremented for each iteration of the 
repeat. The Key property indicates the field by which the 
repeated note numbers are to be matched to the repeated 
bookmarks, e.g., =INOTE(CashAssets,CODE).

iRepeat iRepeat(<RowNumber>) 

This function is used in conjunction with the RECORDVALUE 
and Repeat function. While RECORDVALUE 
(<FieldName>,<RecordNumber>) returns the value of the 
specified database field for the record of the specified 
number, iRepeat returns the <RecordNumber> based on the 
number of repeats that have occurred at the RowNumber 
specified in iRepeat. 

For example, iRepeat(5) returns the number of repeats that 
have occurred at the row 5 repeat function.

=Recordvalue(DB.MembersInfoStatement.WithdrawalBenefit
.RequiredPreserved,iRepeat(5)) if the repeat at row five has 
looped three times it returns the value in the 
RequiredPreserved field for the 3rd record of the 
WithdrawalBenefit table. 

IsFirstRecord Returns TRUE when used during the first iteration of a repeat, 
otherwise returns FALSE.

IsLastRecord Returns TRUE when used during the last iteration of a repeat, 
otherwise returns FALSE.

LEFT LEFT(text,num_chars)

The LEFT function returns the first character or characters in a 
text string, based on the number of characters you specify. 

For example, LEFT("Sale Price",4) equals "Sale".

Len Len(<Value/Reference>) 

The LEN function enables you to create formulas that obtain 
the length of the entry in a cell or database field. 

For example,

=LEN(DB.DirectorsReport.SignificantChange)>1 

For this formula to be evaluated as TRUE, the 
SignificantChange field in the DirectorsReport table must 
have a length greater than 1. 

Function Description
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LY LY(<Chart Map Folder, Database Map Field or Driver Field>)

This function returns the value for the specified chart map 
folder, database map field or driver field (AMOUNT, 
DESCRIPTION etc.) in the year immediately prior to the year 
the cell is currently formatted to display, e.g., 
=LY(CM.Notes.Cash) returns the Last Year value if the cell is 
formatted to show Current Year values but returns the Year 3 
value if the cell is formatted to display Last Year values.

Max Max(<Cell Range>) 

Use this function to return the highest value in a specified 
range. 

For example,

=MAX(A1:C5) 

Min Min(<Cell Range>)

Use this function to return the lowest value in a specified 
range.

For example,

=MIN(A1:C5) 

MOD MOD(<Value>,<Number>)

The MOD function returns the remainder after the Value is 
divided by the Number. The result has the same sign as the 
Value. For example, MOD(3,2) returns 1.

NEXTRECORD NEXTRECORD(<FieldName>)

This function returns the value of the specified field for the 
item immediately following the current item in the repeat, 
e.g., =NEXTRECORD(CODE) returns the code of the next 
account in a repeat.

Note The Note function will return a sequential note number that 
has been assigned to the specified bookmark based on its 
relative position in the report (i.e., the first bookmark to 
appear in the report is assigned the note number 1, the 
second bookmark is assigned the note number 2 and so on).

Note: This function is commonly used when creating notes 
and cross–references. 

Be aware that if the Format being referenced is not included 
in the report, then #REF will be displayed in the report where 
the reference cannot be located. To avoid this, you can use 
the If() function. 

Function Description
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Now Returns the current system date and time.

ONCEPER =ONCEPER(<FieldName>)

This function, when used within a chart map repeat that is 
grouped by the specified field, returns TRUE for one record in 
each group. For example, if used in a repeat that is grouped 
by division, =ONCEPER(DIVISION) returns TRUE for one record 
per division. It could be used, e.g., as the print condition for a 
row containing a sub-total so that the sub-total appears only 
once per division. 

In a single-row repeat, the ONCEPER function returns TRUE 
for the first record in each group. It returns FALSE for all other 
records.

In a multi-row repeat, the ONCEPER function returns TRUE for 
the last record, in each group, where any of the rows above 
the row containing the function are displayed in the preview. 
It returns FALSE for all other records.

Note: The specified field must be one that is selected in the 
Group Repeat By section of the Repeat Settings 
window. If the specified field is not selected in the 
Group Repeat By section of the Repeat Settings 
window, the function will return TRUE for all records.

Or Or(<Argument1>,<Argument2>...) 

At least one of two or more conditions must be met for an 
expression to be evaluated as being TRUE. 

The structure is OR(<condition to be met>,<condition to be 
met>,<condition to be met>). There is no limit on the number 
of conditions that can be specified. 

For example, 

=OR(CM.SFPO.Assets.Current.Cash.DR<>0,CashLastYear<>0) 

For this formula to be evaluated as TRUE, either the 
SFPO.Assets.Current.Cash.DR item must not be equal to zero, 
or the CashLastYear named range must not be equal to zero. 

Page Use the Page function to provide a page number. This 
function can be used in conjunction with the Pagecount 
function to provide Page x of y, where x is the number of the 
current page and y is the total number of pages. This function 
is typically used in Formats that are used as headers or 
footers. 

Function Description
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Pagecount Pagecount 

Use the Pagecount function to provide the total number of 
pages in a report. This function can be used in conjunction 
with the Page function to provide Page x of y, where x is the 
current page and y is the total number of pages. This function 
is typically used in Formats that are used as headers or 
footers. 

Period Period

This function returns the end date of the period to which a 
cell is formatted.

PERIODEND This function returns the end date of the period containing 
the specified date. 

The date can be supplied directly, via a database map field or 
via another function.

For example,

=PERIODEND(30/11/2005)

=PERIODEND(DB.OtherReports.Director.DateAppointed)

=PERIODEND(NOW)

PERIODNUMBER =PERIODNUMBER(<Date>)

This function returns the number of the period containing the 
specified date.

The date can be supplied directly, via a database map field or 
via another function.

For example,

=PERIODNUMBER(30/11/2005)

=PERIODNUMBER(DB.OtherReports.Director.DateAppointed)

=PERIODNUMBER(NOW)

PERIODNUMBER
DATE

=PERIODNUMBERDATE(<Number>)

This function returns the end date of the period represented 
by the specified number, e.g. =PERIODNUMBERDATE(1).

PERIODSTART This function returns the start date of the period containing 
the specified date. 

The date can be supplied directly, via a database map field or 
via another function.

For example,

=PERIODSTART(30/11/2005)

=PERIODSTART(DB.OtherReports.Director.DateAppointed)

=PERIODSTART(NOW)

Function Description



Designing reports

MYOB AE Reporter | Version 3.4 User Guide | 151

PREVIOUSRECOR
D

PREVIOUSRECORD(<FieldName>)

This function returns the value of the specified field for the 
item immediately preceding the current item in the repeat, 
e.g., 
=PREVIOUSRECORD(DB.OtherReports.Director.LastName) 
returns the last name of the previous record on the Director 
table. 

Recordcount Recordcount(<Table Name>) 

The Recordcount function provides the number of records in 
a database table. 

For example,

=RECORDCOUNT(DB.Director)>1 

For this formula to be evaluated as TRUE, the Director table 
must contain more than one record. 

RecordValue RecordValue(<FieldName>,<RecordName>)

Returns the value of the specified database field for the 
record of the specified number, e.g., 
=RECORDVALUE(DB.OtherReports.Director.FirstName,3) 
returns the value in the FirstName field for the 3rd record on 
the Director table.

Ref Ref(<BookmarkName>) 

The Ref function will return the number of the page on which 
the specified bookmark appears in the previewed report.

Note: If the Format being referenced is not included in the 
report, then #REF will be displayed in the report where 
the reference cannot be located. To avoid this, you can 
use the If() function.

The Ref function returns the number of the pages on which 
the specified bookmark appears in the previewed report.

RepeatPosition RepeatPostition

This function returns the number of the current iteration of a 
repeating row, e.g., 1 if it is the first time the row has been 
repeated, 2 if it is the second and so on.

RIGHT RIGHT(text,num_chars)

The RIGHT function returns the last character or characters in 
a text string, based on the number of characters you specify. 
For example, RIGHT("Sale Price",5) equals "Price".

Function Description
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Sum Sum(<Cell Range>) 

The Sum function is typically used to sum the values in a cell 
range. You can also sum numbers. 

There are two operators you can use when summing single 
values, the comma (,) and the plus (+). These operators are 
interchangeable and will produce exactly the same result. 

For example,

=SUM(B4+D4) 

=SUM(B4,D4) 

When summing a range, use the colon (:) operator: 

=SUM(B4:D4) 

TEMPLATEHASFIL
TERS

=TEMPLATEHASFILTERS

This function returns TRUE if the column template currently 
applied to the format is a user-defined template containing 
columns for which one or more filters have been specified, or 
is a ledger-defined template based on account details (e.g., 
Division, Subcode). Otherwise, it returns FALSE.

Year Year 

This function is used when you want the year end date to be 
displayed in a report. The year specified in the Balances tab of 
the Format Cells window will determine which year (relative 
to the underlying ledger year) you will receive the end date 
for. 

YEAREND =YEAREND(<Date>)

This function returns the end date of the year containing the 
specified date.

The date can be supplied directly, via a database map field or 
via another function.

For example,

=YEAREND(30/11/2005)

=YEAREND(DB.OtherReports.Director.DateAppointed)

=YEAREND(NOW)

Function Description
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Examples of commonly used formulas 

The Master Formats provided to you with the Report Designer will provide a good 
cross section of examples for when you want to create your own Formats. Here are a 
few examples of formulas to give you an idea of how certain types of information can 
be generated. 

 Increasing a number by a percentage 

To increase the value in cell B5 by 10%, you would enter the following formula: 

=B5*(1+10%) 

 Setting conditions [if, then, else] 

{IF(DB.#EntityDetails.ClientDetails.YearEndDate= 
DB.#EntityDetails.ClientDetails.PeriodEndDate,"year","period")} 

YEARNUMBER =YEARNUMBER(<Date>)

This function returns the number of the year containing the 
specified date. Numbers are assigned to years in ascending 
order from earliest to latest, with the earliest year for which 
ledger data is available being assigned the number 1.

The date can be supplied directly, via a database map field or 
via another function.

For example,

=YEARNUMBER(30/11/2005)

=YEARNUMBER(DB.OtherReports.Director.DateAppointed)

=YEARNUMBER(NOW)

YEARNUMBERDA
TE

=YEARNUMBERDATE(<Number>)

This function returns the end date of the year represented by 
the specified number, e.g., YEARNUMBERDATE(1).

Numbers are assigned to years in ascending order from 
earliest to latest, with the earliest year for which ledger data 
is available being assigned the number 1.

YEARSTART =YEARSTART(<Date>)

Returns the start date of the year containing the specified 
date.

The date can be supplied directly, via a database map field or 
via another function.

For example,

=YEARSTART(30/11/2005)

=YEARSTART(DB.OtherReports.Director.DateAppointed) 

=YEARSTART(NOW)

Function Description
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 Calculating a running balance 

You can build a formula to calculate a running balance: 

=SUM(C4:C7,C10)–C15 

Related topics

About the Formats tab

About the Formats Editor

Making changes to master formats

Creating new formats

Working with formats

Previewing formats

Renaming a format

Editing a format

Deleting a format

Undo / Redo in Design View

Working with formulas

Working with operators

Print conditions

Creating notes and cross-references

Setting conditions for the elements

Print conditions

Accountants Enterprise in Australia only

The Print Condition column is the first column in the Display view of the Format 
Editor window. It contains a printer icon. You can use this column to specify the 
conditions in which a row is to be included in a report. For example, you might only 
want to display a row if it contains a value other than zero. Setting a row to never be 
included in a report means you will not be able to use that result in another row. 
However, if the cell is included in a named range, the named range can be referenced 
in another row, even if the print condition is false. 

To use the Print Condition column:

 To always include a row, just leave the Print Condition column blank for that row.

 If a row's inclusion is conditional, enter the condition in the Print Condition 
column for that row.

 If you want a row to be excluded in all conditions, type =FALSE in the Print 
Condition column for that row. You would use this when you want a row to 
contain notes for the designer rather than content that is part of the Format. 
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Note: Any text you type in this column does not display in your reports. A print 
condition on a row that is set to repeat is applied to each of the rows returned. 

Examples 

To add a print condition

To add a print condition to a row from within Report Designer (on the Formats tab):

1. Click on the cell in the Print Condition row.

2. Simply start typing your print condition.

3. Click the Preview icon to preview the report.

Related topics

About the Formats tab

About the Formats Editor

Example Description

=PRINT9 The row will only print if row 9 is also printed. 

=CalculationRow The row will not print but cells on the row will be 
evaluated so the results of the cells can be re-used 
elsewhere in the same format. 

=AND(CM.DirectorsR
eport.NPAT<> 
0,CM.DirectorsReport
. 
ExtraordinaryI 
tems<>0) 

The row will only print if the total of all the accounts 
under the DirectorsReport.NPAT item is not zero and the 
total of all the accounts under the 
DirectorsReport.ExtraordinaryItems item is not zero. 

=OR(C25<>0,D25<>0) The row will only print if either C25 or D25 contains a 
value other than zero. 

=CM.Notes.Associate
s<>0 

The row will only print if the total of all the accounts 
under the Notes.Associates item in the Chart Map is not 
equal to zero. 

=0<LEN(DB.Associate
s1. 
Associate) 

The row will only print if the Associate field in the 
Associates1 table has a length greater than zero. 

=1<RECORDCOUNT(D
B. 
Director) 

The row will only print if the Director table is populated in 
more than one record. 
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Making changes to master formats

Creating new formats

Working with formats

Previewing formats

Renaming a format

Editing a format

Deleting a format

Undo / Redo in Design View

Working with formulas

Working with operators

Working with functions

Print column

Print column

Accountants Enterprise in Australia only

The Print column displays any print conditions that have been applied to the rows in 
a Format. These conditions determine whether a row is to be printed or not when the 
Format is printed, either on its own or as part of a report. If a cell in this column reads 
‘=FALSE’, then that row will not be printed. You would use this when you wanted a 
row to contain notes for the designer rather than content that is part of the Format.

If a row does not contain a print condition, it will be printed.

Note: The Master level reports provided by MYOB contain blue coloured rows in 
addition to the blue coloured Print Conditions column. These blue rows 
indicate a row which contains a note to you on the contents of the Format. 
These rows are all marked ‘=FALSE’ and will not be printed.

Related topics

About the Formats tab

About the Formats Editor

Making changes to master formats

Creating new formats

Working with formats

Previewing formats

Renaming a format

Editing a format

Deleting a format

Undo / Redo in Design View

Working with formulas

Working with operators
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Working with functions

Print conditions

Previewing formats

Accountants Enterprise in Australia only

It is recommended that you first preview all the Formats that are used in a report in 
the Format Editor window before previewing the full report. This is because Formats 
previewed on their own display faster, and you are able to easily switch between the 
Design view and Preview view of the Format Editor to correct any errors you find. 

Note: Note references, cross–references and references to named ranges that are 
not within the Format you are previewing do not display when you preview 
the Format, you only see those that are part of the current Format. When you 
preview a report all note references, cross–references and references to 
named ranges are displayed. 

When previewing a Format, you can check that the following are working as 
expected: 

 References to Database Map fields are returning the expected data. Be aware 
that the field needs to be populated for each client against whom you are 
running a report. If the field is not populated, there is nothing in the preview to 
alert you to this fact. 

 References to account information — including Balance Period and Balance 
Type. 

 Print conditions for the inclusion of a row. 

 Formulas are returning the expected values, e.g., totals. 

 Repeating rows are working correctly. 

 Text formatting is as you would like — font colour, size and weight. 

 Any borders or patterns applied are displaying as expected. 

 Row height and column width. 

 Whether the correct Format has been applied to the cell, e.g., Date/Time, 
Percentage, etc. 

 Whether the text alignment is correct for all cells. 

 Styles.

When you are previewing a Practice level Format and Report Designer is opened at 
the Practice level, you are only able to access Practice level Database Map data. If you 
want to check that any database references you have created in order to reference 
client data are working correctly, you need to open Report Designer from a client 
ledger and then preview the Format. 
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When in the Preview mode use the toolbar buttons at the top of the window to print, 
zoom in and out of the view, and use the arrow buttons to move between pages or 

jump to the first or last page. The Design button  takes you back to the Design 
view. 

To preview a format from within the Report Designer (on the Formats tab)

You can preview more than one Format at a time by opening up the Format Editor 
window for the Formats you want to preview. The Format displayed on screen shows 
what you will see when the Format is printed, including all bolding, borders and 
colours used. 

1. Select the Format you want to preview from the tree list in the Explorer pane.

2. Click the Preview button,  on the Format Editor window toolbar. 

The Format Editor window changes to the Preview view, displaying the selected 
Format. 

Note: A progress bar appears at the bottom of the Format Editor to show 
how the loading of the preview is progressing. 

3. To move between pages in the Preview, use the arrows on the toolbar or type a 

page number in .

4. To return to the Design view, click the Design button,  on the toolbar. 

Related topics

Exporting formats from Preview view

Emailing a format from Preview view

Printing a format from Preview view

Exporting formats from Preview view

Accountants Enterprise in Australia only

To export formats from the Preview view within the Report Designer (on the 
Formats tab)

1. Select the Format you want to preview from the tree list in the Explorer pane. 

2. Click the Preview button,  on the Format Editor window toolbar. 
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The Format Editor window changes to the Preview view, displaying the selected 
Format. 

3. Click the Export button,  from the toolbar.

The Select Export File window opens.

4. Select the folder in which you want the exported file to Save in.

5. Enter the File name of the export file.

6. Select the Save as type format you want to export the report to.

7. Click OK to begin the export. 

Related topics

Previewing formats

Emailing a format from Preview view

Printing a format from Preview view

Emailing a format from Preview view

Accountants Enterprise in Australia only

To email a report from the Designing Reports - Format tab

1. In the Designing Reports - Formats tab, select the Format you want to email.

2. Click Preview.

3. Click .

The Email Report as an Attachment window opens.

4. For Attachment Settings:

a. Enter a File Name or simply keep the default name.

b. Select a File Type from the drop-down list.

5. Click the Options button. 

a. Select the Password protect the attachment option to secure your report.

Enter a password and then re-type the password to confirm.

b. Select the Compress the Attachment option if you want to compress the 
email using WinZip.
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c. Select the Save the attachment option if you want to save the attachment.

Click the ellipsis to change the directory.

6. Click Email.

An Untitled email message opens with the report attached.

7. Type or select the recipient's email address and if necessary type a message (as 
you normally would).

8. Click Send.

Related topics

Previewing formats

Exporting formats from Preview view

Printing a format from Preview view

Printing a format from Preview view

Accountants Enterprise in Australia only

To print a format from the Preview view from within Report Designer (on the 
Formats tab)

1. In the Format Editor window, click . 

The Format Editor window will change to the Preview view, displaying the 
selected Format. 

2. Click the Print button on the toolbar, .

The Print window opens.

3. Click Print.

Related topics

Previewing formats

Exporting formats from Preview view

Emailing a format from Preview view

Applying column templates to formats

Accountants Enterprise in Australia only
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Note: You can only apply one column template to a format.

When you apply a column template to a format, a tag is applied to the top of a 
column. This allows the existing cell contents to be visible and it also alters the 
appearance of the column. You are able to move the mouse over the label to view the 
associated tool tip.

In regard to merged cells and column templates, a restriction needs to be applied. The 
merge must be entirely outside of a column template (i.e., to the left or the right) or 
entirely within the column template range.

When a range is selected across template and non-template columns, the merge cells 
option on the alignment tab of the format cells window is disabled.

A test configuration drop-down list appears on the toolbar, which allows you to test 
the design of your column template against saved column template configurations. 
The default selection is <use format definition>. This selection uses the defaults 
specified during format design for each individual format.

To apply a column template to a Format within Report Designer (on the Formats 
tab)

1. In the Explorer pane, double click the Format that you want to apply the column 
template to. 

2. In the Format Editor, right-click the column header of the column that you want 
to apply the template to.

3. Select Apply Column Template.

The Apply Column Template window opens.

4. From the Column Template Name drop-down list, select the Column Template.

5. Click Apply.

6. Click Close.

Related topics

Removing a column template from a format

Previewing a column template

Creating column templates

Removing a column template from a format

Accountants Enterprise in Australia only
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To remove a column template from a Format within Report Designer (on the 
Formats tab)

1. In the Explorer pane, double click the Format that you want to remove the 
column template from. 

2. In the Format Editor, select the columns that you want to remove the template 
from. 

You must select all columns that the template applies to.

3. Right-click the column header(s) and select Apply Column Template.

The Apply Column Template window opens.

4. Deselect Apply Column Template.

5. Click Apply.

6. Click Close.

Related topics

Previewing a column template

Creating column templates

Applying column templates to formats

Previewing a column template

Accountants Enterprise in Australia only

To preview a report with a specific column template within Report Designer (on the 
Formats tab)

1. From the toolbar next to Test configuration, select the Column Template that 
you want to preview.

2. Click the Preview  button.

The report opens for preview.

Related topics

Removing a column template from a format

Creating column templates

Applying column templates to formats
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Working with styles

Accountants Enterprise in Australia only

Styles also fit in with the hierarchy levels. Styles are available at the Master, Practice 
or Client level. The level you have opened Report Designer at when you create or edit 
a style is the level it becomes when you save it. 

Therefore, if you create a style at the Client level, it is saved at the Client level for the 
selected client ledger and is only available for that client ledger when it is opened at 
the Client level. 

A Practice level style will be available for all client ledgers of the same entity when 
they are opened within Report Designer at the Practice or Client level. 

Master styles are always available. If edited, a Master level style is saved to the 
current level. 

Below is an example of three styles listed in the Styles Editor window, each at one of 
the three hierarchy levels. 

Default

Practice

 Client

Note: You would only be able to see styles at all three levels when Report Designer 
is opened at the Client level. 

Styles can be applied to one or more cells, one or more columns or one or more rows, 
depending on the cell selection in the Format Editor window when you select and 
apply a style. 

Styles are a way of saving a common formatting option so it can easily be reused and 
applied to a cell selection in any Format. 

You can format cells on an ad hoc basis by using the Format Cells window, but if you 
wanted to repeat the formatting for another cell you would have to repeat all the 
selections in the Format Cells window again. If you use a combination of formatting 
commands again, it is advisable to save it as a style. 

The saved style is available in the Styles list box at the top of the Format Editor 
window and you can simply select the cells to apply it to and the category, alignment, 
font, border and pattern selections are applied in one step. 

The Style Editor window is where you can add, edit and delete styles. It is accessed 

from the Styles button, , on the Format Editor window toolbar. The Styles Editor 
window contains the following tabs: 

 “Alignment tab” (see page 167)
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 “Border tab” (see page 168)

 “Category tab” (see page 168)

 “Font tab” (see page 169)

 “Pattern tab” (see page 169)

 “Text tab” (see page 170).

Related topics

Creating a new style

Editing a style

Deleting a style

Formatting cells

Creating a new style 

Accountants Enterprise in Australia only

To create a new style within Report Designer (on the Formats tab)

1. Open Report Designer at the same level at which you want to create the new 
style (i.e., Practice or Client). 

Your new style will be saved to whatever level you select here. 

The Report Designer window opens.

2. Select the Formats tab. 

3. Open the Format Editor window. 

The Format Editor window opens in Design view. 

4. On the Format Editor window toolbar, select the Styles Editor button, . 

The Style Editor window opens. 

5. Click the New Style button, .

If you are adding a style at the Practice level, the icon will be yellow.

The Reporter window appears ready for you to enter the new style name. 

6. Type the name for the new style in the edit field and click OK. 

You will be returned to the Style Editor window and the new style name will be 
listed. Ensure the new style name is selected in the list. 

7. Work your way through the tabs in the window defining the formatting to be 
saved in the new style. 
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See the following for more information: 

 “Alignment tab” (see page 167)

 “Border tab” (see page 168)

 “Category tab” (see page 168)

 “Font tab” (see page 169)

 “Pattern tab” (see page 169)

 “Text tab” (see page 170).

8. When all the required formatting has been defined for the style, click Close to 
save the style and return to the Format Editor window. 

Related topics

Working with styles

Editing a style

Deleting a style

Formatting cells

Editing a style 

Accountants Enterprise in Australia only

To edit a new style within Report Designer (on the Formats tab)

1. Open Report Designer at the same level at which you want the edited style to be 
saved or at the level the style you want to edit was previously saved (Practice or 
Client). 

The Report Designer window opens.

2. Select the Formats tab. 

3. Open the Format Editor window. 

The Format Editor window opens in Design view. 

4. On the Format Editor window toolbar, select the Styles Editor button, . 

The Style Editor window opens. 

5. In the list of styles on the left, highlight the style you want to edit. 

6. Work your way through the tabs in the window editing the formatting of the 
style to that which you require. 

See the following for more information: 

 “Alignment tab” (see page 167)
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 “Border tab” (see page 168)

 “Category tab” (see page 168)

 “Font tab” (see page 169)

 “Pattern tab” (see page 169)

 “Text tab” (see page 170).

7. When all the required formatting has been defined for the style, click Close to 
save the style and return to the Format Editor window. 

The edited style is saved to the level at which Report Designer is currently open. 

Related topics

Working with styles

Creating a new style

Deleting a style

Formatting cells

Deleting a style 

Accountants Enterprise in Australia only

You can only delete styles that were created at the current hierarchy level. That is, 
you can not delete a Practice level style while Report Designer is open at the Client 
level. 

Note: Master level styles cannot be deleted. 

To delete a new style within Report Designer (on the Formats tab)

1. Open Report Designer at the same level at which the style you want to delete 
was created (Practice or Client). 

The Report Designer window opens. 

2. Select the Formats tab. 

3. Open the Format Editor window. 

The Format Editor window opens in Design view. 

4. On the Format Editor window toolbar, select the Styles Editor button, . 

The Style Editor window opens. 

5. In the styles list box on the left of the window, highlight the style you want to 
delete. 
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6. Click the Delete button,  on the toolbar. 

A message will be displayed asking you to confirm your actions. 

7. Click Yes to delete the style. 

The style is removed from the list 

8. Click Close to save the changes and return to the Format Editor window. 

Related topics

Working with styles

Creating a new style

Editing a style

Formatting cells

Formatting cells

Accountants Enterprise in Australia only

You can format cells on an ad hoc basis by using the Format Cells window rather than 
applying pre–defined styles that are created in the Styles Editor window. This allows 
you to make one off changes to a cell, row or column selection if you do not want to 
use all the definitions in one of the available styles. 

The formatting options available in the Format Cells window are the same as those in 
the Styles Editor window, but in addition the window contains an extra tab, the 
Balances tab. 

The Format Cells window is accessed from the right–click menu in the spreadsheet 
area of the Format Editor window, Design view. 

Note: If you are using the Format Cells window to apply the same formatting to cells 
on a number of occasions, it is recommended that you create the common 
formatting combination as a style in the Style Editor window so that it can be 
applied in one step in the future.

The Format Cells window contains the following tabs: 

Alignment tab 

In the Alignment tab, you can define the alignment of the text (horizontal or vertical), 
the indent size (if you have selected left alignment), text orientation and whether to 
wrap the text in the cell(s) or merge cells. 

 If you select the Wrap Text checkbox, when a single line of text exceeds the 
width of its cell, the cell is widened until all the wrapped text fits within it. 
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 Select the Merge Cells checkbox to combine two or more selected cells into a 
single cell. This option can be used with horizontal alignment to create headings 
that are centred across a number of merged cells. 

Be aware that if you merge two cells that both contain values, only the value in 
the upper left cell in the selection is used. The values are retained in all the cells 
involved, the cells are overlaid with the value in the upper left cell. If you 
deselect the Merge Cells checkbox, the values in the cells will re-display. 

 The Orientation option enables you to set the angle at which text is to be set for 
the current cell(s) selection. To rotate clockwise, enter a positive value. To rotate 
anticlockwise, enter a negative value.

Balances tab 

The Period Start and Period End drop-downs both contain the same list of values. To 
specify year to date values, the Period Start should be set to Period 1 and the Period 
End should be set to the Current Period. To specify periodic values, the Period Start 
and Period End values should be identical.

Specify if you want the figures to be Year to Date (therefore the start period is set to 
Period 1 and you cannot change it) or Movement based (therefore both the start and 
end periods are enabled).

You can also define whether the balance type is displayed in the selected cell(s). 
Different balance types are available from different General Ledger software.

Border tab 

The Border tab is where you can define the border. There are three presets available; 
none, outside or inside. Use the Line section to select a single line or a double line 
border. The drop-down Colour list enables you to choose a colour for the border.

You are also able to set your own border preference by using the Border section and 
selecting the sides that you want to have a border.

Category tab

In the Category tab, you define the type of information to be entered in cells which 
have this style applied. You could therefore set up a style for each information type 
to be entered into a report. For example, you may want dates in a report to always 
be bold and italic, so you could create a style called Date and define these formatting 
requirements. You could then do the same for percentages and heading rows, etc. 

Available category types:

 General 

This the default selection. Any type of information can be entered into a cell 
defined with this category. 

 Numeric 
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The numeric category type is used for cells displaying numeric values. You can 
define:

 the number of decimal places (up to 30)

 a currency symbol (select $ from the list or enter a symbol using the 
keyboard)

 how negative and positive numbers are to be displayed 

 how zero values are to be shown. 

Select the Use 1000 Separator: checkbox if you want to use a comma to 
separate thousands, e.g., 456,845. 

 Date / Time 

Select from the Type list the way you want dates and times to be represented, or 
define your own in the Custom field. Custom designed date and time formats 
will be displayed in the list box for future selections. 

 Percentage 

Select the number of decimal places you want to display. The default setting is 2. 
Rounding takes place if the value contains more decimal places than you select 
in the currency settings. 

Additional formatting can be applied to Text without affecting the style of other types 
of information such as dates.

Font tab 

In the Font tab, you can select common Windows font definitions (font, size, bold, 
underline, certain effects and font colour) to apply to the selected style or cell(s). 

Pattern tab 

The Pattern tab is used to define the pattern style and colour. You are also able to set 
the background colour.

Protection tab

The flexibility that Column Templates provide may require some restrictions for 
certain formats. You can apply protection to prevent others from changing the 
balance type, the year / period and the style.

Any cell that has some form of protection displays a padlock icon. This icon makes you 
aware of the protected cell as it affects or alters the behaviour of the cell when used 
with Column Templates.

Note: If you are using the Format Cells window to apply the same formatting to cells 
on a number of occasions, it is recommended that you create the common 
formatting combination as a style in the Styles Editor window so that, in 
future, it can be applied in one step. 
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Text tab

In the Text tab, select the type of format (e.g., uppercase or capital initial letters) to 
be applied to text entered in cells with this setting applied. Numerical entries or dates 
in such cells will be not be affected.

Related topics

Applying formatting to cells

Conditional formatting

Repeat settings

Inserting page breaks

Keeping sections together

Setting the row height

Setting the column width

Named cell ranges

Applying a space filler

Clearing contents

Working with styles

Applying formatting to cells 

Accountants Enterprise in Australia only

Formatting cells is independent of hierarchy levels. However, if you change the 
formatting of a cell selection in a Format that is at a higher level in the hierarchy than 
that at which Report Designer is currently open, then the Format is saved to the 
current level (Practice or Client). 

Tip: If your formatting changes will be required on a regular basis, it would 
possibly save time to create a new style or edit an existing one. 

To format a cell selection within Report Designer (on the Formats tab)

1. In the Report Designer window select the Formats tab. 

2. Open the Format Editor window for the Format you want to apply the changes 
to. 

The Format Editor window opens in Design view. 

3. Select the cell(s), row(s) or column(s) that you want to make formatting changes 
to. 

4. Select Format from the right–click menu. 

The Format Cells window opens. 



Designing reports

MYOB AE Reporter | Version 3.4 User Guide | 171

5. Work your way through the tabs in the window editing the formatting of the 
style to that which you require. 

See the following for more information: 

 “Alignment tab” (see page 167)

 “Balances tab” (see page 168)

 “Border tab” (see page 168)

 “Category tab” (see page 168)

 “Font tab” (see page 169)

 “Pattern tab” (see page 169)

 “Protection tab” (see page 169)

 “Text tab” (see page 170).

6. When all the required formatting has been defined for the style, click OK to save 
the style and return to the Format Editor window. 

The edited style is saved to the level at which Report Designer is currently open. 

Related topics

Formatting cells

Conditional formatting

Repeat settings

Inserting page breaks

Keeping sections together

Setting the row height

Setting the column width

Named cell ranges

Applying a space filler

Clearing contents

Working with styles

Conditional formatting

Accountants Enterprise in Australia only

To access the Conditional Formatting window

1. Right-click on any cell (excluding heading row and numbered columns) in the 
Design view of the Format Editor window. 

The Conditional Formatting window opens.

2. Enter a condition to determine if the style changes listed in the Style changes 
box are to be applied or not. 
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By default, the condition field is empty. 

3. You are able to apply changes by clicking the Style Editor button.

By default, the Style changes listing displays No style changes.

Any style changes made are then summarised and displayed in the Style 
Changes listing.

Related topics

Formatting cells

Applying formatting to cells

Repeat settings

Inserting page breaks

Keeping sections together

Setting the row height

Setting the column width

Named cell ranges

Applying a space filler

Clearing contents

Working with styles

Repeat settings 

Accountants Enterprise in Australia only

Repeat settings are used to insert additional rows into a Format when multiple values 
need to be accommodated from a referenced Database Map field or multiple 
accounts from a referenced Chart Map folder. You will be able to view the repeated 
rows when the Format is previewed or a report in which the Format is included is 
previewed or generated. 

 indicates that repeating has been set for a row. 

You can set a print condition on the row you have set to repeat. This condition is 
applied individually to each row that is returned. 

Repeating rows is applied through the Repeat Settings window, accessed from the 
right–click menu when one or more rows are selected within the Format Editor 
window in the Display view.

To sum repeated rows, make the cell which contains the reference, the object of the 
SUM. For example, if you set row 4 to repeat and you want to sum the amounts in 
column B, you sum the cell containing the reference, e.g., =SUM(B4). 

To apply repeat settings within Report Designer (on the Formats tab)

1. Open the Format Editor window for the Format you want to repeat rows in. 
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2. Click in the row label area (the grey left–hand column containing the row 
number) to select the row or adjoining rows that you want to repeat. 

3. From the right–click menu, select Repeat.

The Repeat Settings window opens. 

4. Select the Apply repeat checkbox. 

5. In the Repeat For area, select either the Chart Map Folder or Database Map 
Table radio button to define what you want to apply repeat settings to. 

6. From the list box, select the path to the Chart Map folder or Database Map table 
to be repeated in the selected row. 

7. In the Number of rows to group field, enter the number of rows to be grouped 
together. 

If you selected more than one row in the Format Editor window, this field 
defaults to the number of rows selected. 

8. If you are repeating rows for a Chart Map folder, you have the following 
additional options: 

 Show sub–codes 

Select this checkbox if you want sub-codes for any control accounts in the 
range you have specified to display in your Format. When sub-codes are 
displayed, the control account to which the sub-codes belong is also 
displayed. If you do not want the control accounts to display, you will need 
to set a print condition, e.g., =level<>"C". 

 Show zero balances 

Select this checkbox if you want accounts containing a zero balance to 
display in the Format. 

 The advanced settings that can be accessed by clicking the More… button 
are:

choices by which to group the repeat (e.g., Code, Main Code, SubCode, 
Division, Description, AltDescription) 

Group Order— allows multiple sort orders to be specified (e.g., if the repeat 
needs to be grouped by SubCode and then by MainCode, the Group Order 
value for the SubCode is 1 and the MainCode is 2).

9. When all the settings have been defined, click OK to save your actions and 
return to the Format Editor window. 

The first repeated row has a  icon with a line showing any following rows 
included in the grouping. 
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To turn off repeating rows within Report Designer (on the Formats tab)

If you no longer want a repeat setting that has previously been applied to a row 
selection to be maintained, you can turn it off in the Repeat Settings window. 
Although the repeating rows no longer apply to the Format, the settings are retained 
in the Repeat Settings window, so you can easily apply them again in the future if 
required. 

Note: If you are turning off repeating for a Chart Map reference, you need to 
remove certain references, e.g., =amount and =description from your 
spreadsheet, otherwise they will display as #NAME when you preview the 
Format.
If you turn off repeating rows for a Database Map reference, the reference 
continues to work after you have turned it off. However, it will only provide 
you with the first record in the database. If this is not what you desire, remove 
the Database Map reference from the spreadsheet. 

1. Open the Format Editor window for the Format you want to remove repeat rows 
from. 

2. Click in the row label area (the grey left–hand column containing the row 
number) to select the row currently containing the repeat. 

If you are turning off the repeat setting for a group of rows, select the first row in 
the group. 

3. From the right–click menu, select Repeat.

The Repeat Settings window opens. 

4. Deselect the Apply repeat checkbox. 

5. Click OK to apply your changes. 

Note: Your changes are not saved until you save the Format. 

The row(s) for which you have turned off repeating no longer displays a  icon 
in its row label. 

Related topics

Formatting cells

Applying formatting to cells

Conditional formatting

Inserting page breaks

Keeping sections together

Setting the row height

Setting the column width
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Named cell ranges

Applying a space filler

Clearing contents

Working with styles

Inserting page breaks

Accountants Enterprise in Australia only

The page break option inserts a page break before the line it is used on. A page break 
can be created using the right-click menu in row headers. 

Page breaks are only applied if the formula you enter into the Page Break Editor is 
TRUE.

To insert a page break within Report Designer (on the Formats tab)

1. Open the Format Editor window for the Format that you want to insert page 
breaks. 

2. Click in the row label area (the grey left–hand column containing the row 
number) to select the row that you want to insert the page break. 

3. From the right–click menu, select Page Break. 

The Page Break Editor opens.

4. Select the Insert Page Break checkbox.

5. Enter a formula into Break when the following condition is true.

6. Click OK.

The row for which you have created the page break has a  icon. 

Related topics

Formatting cells

Applying formatting to cells

Conditional formatting

Repeat settings

Keeping sections together

Setting the row height

Setting the column width

Named cell ranges

Applying a space filler

Clearing contents

Working with styles
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Keeping sections together

Accountants Enterprise in Australia only

To keep sections together within a format in Report Designer (on the Formats tab)

1. Open the Format Editor window for the Format that you want to keep the 
sections together in. 

2. Highlight the rows in the row label area (the grey left–hand column containing 
the row number) to select the rows that you want to keep together. 

3. From the right–click menu, select Keep section together. 

The rows that you highlighted display with little triangles in the upper and lower 
left corners. 

Related topics

Formatting cells

Applying formatting to cells

Conditional formatting

Repeat settings

Inserting page breaks

Setting the row height

Setting the column width

Named cell ranges

Applying a space filler

Clearing contents

Working with styles

Setting the row height 

Accountants Enterprise in Australia only

Row height can be set in one of 2 ways: 

To set row height by dragging with the mouse

1. In the row label area (labelled 1, 2, 3, etc.), position the cursor over the bottom 
boundary of the row whose height you want to change. 
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The cursor changes to a double-headed arrow. 

2. Drag the boundary to where you want it to appear and release the mouse 
button. 

The row resizes. 

To set row height by specifying an exact value in the Row Height window 

1. In the row label area (labelled 1, 2, 3, etc), position the cursor over the row 
whose height you want to change. 

2. From the right–click menu, select Row Height. 

The Row Height window opens.

3. Edit the existing entry to display the desired row height. 

4. Click OK to apply your change. 

Note: The change is not saved until you save the Format. 

Related topics

Formatting cells

Applying formatting to cells

Conditional formatting

Repeat settings

Inserting page breaks

Keeping sections together

Setting the column width

Named cell ranges

Applying a space filler

Clearing contents

Working with styles

Units of measurement

Setting the column width 

Accountants Enterprise in Australia only

Column width can be set in one of two ways: 

To set column width by dragging with the mouse

1. In the column label area (labelled A, B, C, etc), position the cursor over the right-
hand boundary of the column whose width you want to change. 
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The cursor changes to a double-headed arrow. 

2. Drag the boundary to where you want it to appear and release the mouse 
button. 

The column resizes. 

To set column width by specifying an exact value in the Column Width window

1. In the column label area (labelled A, B, C, etc), position the cursor over the 
column whose width you want to change. 

2. From the right–click menu, select Column Width. 

The Column Width window opens.

3. Edit the existing entry to display the desired column width.

4. Click OK to apply your change. 

Note: The change is not saved until you save the Format. 

Related topics

Formatting cells

Applying formatting to cells

Conditional formatting

Repeat settings

Inserting page breaks

Keeping sections together

Setting the row height

Named cell ranges

Applying a space filler

Clearing contents

Working with styles

Units of measurement

Named cell ranges 

Accountants Enterprise in Australia only

Named cell ranges refer to a cell or range of cells in one Format within other Formats. 
By creating a named range for a cell selection you can go into the Format Editor 
window for a different Format and reference the named cell range. 

The Name box on the Format Editor toolbar is where you name a cell or range. Once 
named, the contents of the cell or range can be referenced in other Formats. 
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For example, cell B7 in one Format contains a total that you want to use in another 
Format. You select the cell B7 in the Format Editor window, enter a name for the 
range in the Name field, e.g., Total1, then press [Enter]. Total1 now appears in the 
Name drop-down list. If you open another Format and type =Total1 into a cell in the 
second Format, that cell displays the total from cell B7 in the first Format. 

In the Named Ranges window, accessed from the Named Ranges toolbar button,  
you can edit the name and cells to reference for a range, and delete ranges you no 
longer require. The Named Ranges window lists all the ranges that exist for the 
selected Format. 

Note: The actual total will not be displayed unless you preview a report that 
contains both Formats. The report will display #NAME or something similar, 
until you preview a report that contains the required Formats. 

Related topics

Formatting cells

Applying formatting to cells

Conditional formatting

Repeat settings

Inserting page breaks

Keeping sections together

Setting the row height

Setting the column width

Applying a space filler

Clearing contents

Working with styles

Working with formats

Applying a space filler

Accountants Enterprise in Australia only

The Space Filler is useful in conjunction with column templates. It places a marker in 
the Format header column, which is then used to resize the Format with respect to 
the page size and the amount of information shown on the page.

For first year accounts, it will allow the first column to appear on the right-hand side 
of the page instead of simply removing the second column from sight. 

Space fillers can be used to decrease the width of a column when additional columns 
are generated by a column template.

When you have added a Space Filler, a marker will be displayed to allow you to easily 
identify the columns that have been adjusted.
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To apply a space filler within Report Designer (on the Formats tab)

1. In the Explorer pane of the Formats tab, select the Format that you want to 
apply the Space Filler to. 

2. Right-click the column heading and select Space Filler.

3. Select the Apply Space Filler option.

4. Enter the Minimum Column Width, which specifies the smallest allowable 
column width to be used during preview. 

The setting is used when the column is adjusted to fit column templates on the 
same page and allows the format designer to control the appearance of the 
report.

5. Click OK.

Related topics

Formatting cells

Applying formatting to cells

Conditional formatting

Repeat settings

Inserting page breaks

Keeping sections together

Setting the row height

Setting the column width

Named cell ranges

Clearing contents

Working with styles

Clearing contents

Accountants Enterprise in Australia only

The Clear Contents option on the right-click menu option within the Format Editor 
will clear all the contents for the row or column that is selected.

Related topics

Formatting cells

Applying formatting to cells

Conditional formatting

Repeat settings

Inserting page breaks

Keeping sections together
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Setting the row height

Setting the column width

Named cell ranges

Applying a space filler

Working with styles

Notes and references

Accountants Enterprise in Australia only

You can:

 “Bookmarking cells in a format” (see page 181)

 “Creating notes and cross-references” (see page 182)

 “Creating a reference to account information (Chart Map)” (see page 184)

 “Creating a reference to non-transactional client information (Database Map)” 
(see page 185).

Bookmarking cells in a format 

Accountants Enterprise in Australia only

The Bookmarking (Note Reference) window is used to create bookmarks for rows 
which can then be used in note referencing and cross referencing. A bookmark is a 
name that you apply to a row in a Format to identify that row for referencing 
purposes. You can only bookmark one row at a time. 

When you create a bookmark for a row in a Format you need to enter a name. Use 
the Bookmark name field to provide a descriptive name for the bookmark you are 
creating. 

Note: A bookmark name must be unique within a Format – you cannot have 2 
bookmarks with the same name within the one Format. The name must be no 
more than 40 characters in length. 

There is also a Note Reference checkbox where you define whether the bookmark 
will be used as a note reference. 

To apply a bookmark within Report Designer (on the Formats tab)

1. Open the Format Editor window for the Format containing the row you want to 
bookmark. 

2. Click in the row label area (the grey left–hand column containing the row 
number) to select the row that you want to apply the bookmark to. 

3. From the right–click menu, select Bookmark.
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The Bookmarking (Note reference) window opens. 

4. Enter a Bookmark name. 

This is what you will use to identify this row when you want to cross–reference 
to it or use it as a note reference. 

The entered Bookmark name can be up to a maximum of 40 characters. 

5. Select the Note reference checkbox, if you will use this bookmark as a note 
reference. 

6. Click OK to save the bookmark and return to the Format Editor window. 

The row for which you have created the bookmark will have a B displayed in its 

row label, . 

To apply the note, go to “Creating notes and cross-references” on page 182.

To remove a bookmark within Report Designer (on the Formats tab)

1. In the Format Editor window, click in the row label area (the grey left–hand 
column containing the row number) to select the row that you want to remove a 
bookmark from. 

2. From the right–click menu, select Bookmark.

The Bookmarking (Note reference) window opens. 

3. Deselect the Apply Bookmark checkbox. 

4. Click OK to save the changes and return to the Format Editor window. 

The bookmark will be removed. The row label will no longer contain the B. 

Related topics

Creating notes and cross-references

Creating a reference to account information (Chart Map)

Creating a reference to non-transactional client information (Database Map)

Creating notes and cross-references 

Accountants Enterprise in Australia only

A note may be appended to the section to which it refers or appended to the report 
as a whole. Notes are numbered sequentially and the number that has been assigned 
to a note appears in the note and in the body of the Format it applies to (the result is 
similar to end notes in word processing applications). This allows someone reading a 
report to identify the note that applies to the section of the report they are reading. 
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A cross-reference is a direction to the reader of a report to consult another section of 
the report for related or additional information. The page number of the row referred 
to is provided. 

Within Reporter you can create notes and cross-references using the bookmark 
feature. 

A bookmark is a name that you apply to a row in a Format to identify that row for 
referencing purposes. You use bookmarks to create cross-references and note 
numbering. Creating a bookmark involves selecting a row and then applying a 
bookmark to that row. A bookmark can then be referenced from elsewhere in your 
Format, to provide a cross-reference to the page number on which the contents of 
the bookmarked row appear. 

A bookmark name must be unique within a Format — you cannot have 2 bookmarks 
with the same name within the one Format.

A B in a row label indicates that a bookmark has been set for that row. 

Before you can add a note or cross–reference to a Format, the information you want 
to reference needs to have been bookmarked. For information on how to do this see 
“Bookmarking cells in a format” on page 181.

To create a note or a cross–reference within a format in Report Designer (on the 
Formats tab)

1. Open the Format Editor window for the Format containing the cell you want to 
add a note or reference to.

2. Click in the cell and type:

=NOTE(<Bookmark name>) to add a note reference. 

In this case a sequential number will be used to show the link between the cell 
and bookmarked row. 

or

=INOTE(<Bookmark name>) to add a note reference to be used for repeating 
rows.

or

=REF(<Bookmark name>) to add a cross–reference. 

In this case a page number will be used to show the link between the cell and 
bookmarked row. 

1. Click Save on the Format Editor toolbar. 

Related topics

Bookmarking cells in a format

Creating a reference to account information (Chart Map)

Creating a reference to non-transactional client information (Database Map)



Designing reports

MYOB AE Reporter | Version 3.4 User Guide | 184

Working with formulas

Creating a reference to account information (Chart Map) 

Accountants Enterprise in Australia only

References to account information within Formats are created using links to Chart 
Map folders. 

The easiest way to reference a Chart Map item from within a Format is to drag and 
drop the folder that contains the required account range from the Chart Map tab tree 
list into the Format Editor window. 

Drag a Chart Map field into a format 

When you drag a Chart Map folder into a cell in the Format Editor window, the folder 
name is prefixed with an =CM. For example, =CM.Notes.LandResale.Interest. 

Dragging a Chart Map folder into a cell where there is already a Chart Map folder will 
append the existing folder name with a ‘+’ and the newly added folder will be added 
to the end, providing a total for the account ranges referenced. 

Entering a formula using a Chart Map 

You can type a Chart Map reference directly into a cell by entering an equals ‘=’ sign 
followed by the path to the Chart Map folder. However, if a row is set to repeat for a 
Chart Map folder, to obtain individual account balances (rather than the folder total), 
you will need to use =AMOUNT, not =CM folder path. 

To obtain the description of the individual accounts, use =DESCRIPTION. Other 
variables you can use within repeating rows are: 

 =CODE 

 =MAINCODE 

 =SUBCODE 

 =PREFIX 

 =ALTDESCRIPTION 

 =LEVEL.

Related topics

Bookmarking cells in a format

Creating notes and cross-references

Creating a reference to non-transactional client information (Database Map)

Working with formulas

About the Formats Editor

Previewing formats
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Creating a reference to non-transactional client information (Database Map)

Accountants Enterprise in Australia only

References to non-transactional data within Formats are created using links to 
Database Map items. 

The easiest way to reference a Database Map item from within a Format is to drag 
and drop the required table or field from the Database Map tab tree list into the 
Format Editor window. 

Drag a Database Map field into a format 

When you drag a Database Map field into a cell in the Format Editor window, the 
table name is prefixed with an =DB. For example, 
=DB.Miscellaneous.CurrencySymbol. 

Dragging a Database Map item into a cell where there is already a Database Map item 
will append the existing item with a ‘+’ (or ‘&" "&’ depending on the item type) and 
then the newly added Database Map item, providing a total for the items referenced. 

Entering a conditional formula using a Database Map item 

Since printing is dependent on the print condition being true, it is important to avoid 
any contradicting conditions in a formula. Conditional formulas using Database Map 
items must be entered using the following formula syntax: 

DB.TableName.FieldName=Condition. 

It is crucial to enter the correct spelling for the TableName and FieldName 
components of the formula. Where the spelling of these items is incorrect, the 
condition will always fail and the element will never be included in the printout. 

Related topics

Bookmarking cells in a format

Creating notes and cross-references

Creating a reference to account information (Chart Map)

Working with formulas

About the Formats Editor

Previewing formats

Chart Map

Accountants Enterprise in Australia only

The Chart Map is a list of mappings to account ranges stored within the Report 
Designer. You can use Chart Map items to quickly and easily add account ranges to a 
Format for use in reports. 
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The Chart Map is used to assign logical names to the account codes used in the source 
General Ledger application. These logical names are then referenced in Formats and 
in turn displayed within the reports generated with Reporter. This is the link between 
the accounts data used within a report and the source General Ledger application 
that supplies the data.

All the available Chart Map items for the ledger you have open are listed in the Chart 
Map tab within the Report Designer window. From the Chart Map tab you can view 
the available Chart Map items, select one for viewing or editing, create a new Chart 
Map item or copy or delete an existing one. 

The easiest way to add a Chart Map item to a Format is to drag and drop the item from 
the tree in the Chart Map tab into a cell in the Format Editor window.

The Chart Map tab is a tree display which contains the following types of items: 

 Folders 

Folders are used to logically group account range mappings and shortcuts. This 
makes it easy to find the mapping you want. Folders can contain child folders, an 
account range or shortcut which references another folder in the Chart Map. 
There can be any number of folder levels. As the values in a child folder are 
accumulated in their parent folder, you can reference a higher level Chart Map 
folder in a Format or report and get all the account ranges contained in the top 
level folder and any other folders below it.

 Account ranges 

These are the actual links to the account ranges within the selected ledger. By 
using links to the account ranges it is assured that the accounts figures required 
in a report are current, as the information is pulled from the ledger at the time 
the report is run, rather then stored from a previous reading. 

 Shortcuts 

These are used to prevent multiple mappings to the same account range. Once 
an account mapping is added to the Chart Map, and the mapping is required 
somewhere else, it can be done via a shortcut to the original mapping. 

As with reports, Formats and Database Map items, there is a hierarchy within the 
Chart Map. MYOB provides you with a number of Master Chart Map items. These can 
be edited and saved at a different hierarchy level. You can also create your own Chart 
Map items at either the Practice or Client level. 

 Master Chart Map items 

Master level Chart Maps are provided with the Reporter software. These cover 
the AASB accounting requirements for certain entity types and sizes. Master 
level Chart Map items cannot be edited or created, however you can use them 
as a basis for creating Practice or Client level Chart Map items. Each year MYOB 
will provide you with an updated Master Chart Map to cover any AASB changes 
that have been introduced. 
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Within the Chart Map tab in the Report Designer window, the Master level is 
distinguished by a red icon with a M. The icon also indicates whether it is a 

Master level account range mapping , a folder  or a shortcut . 

 Practice Chart Map items 

Practice level Chart Map items are those created by the report designer within 
your practice. Practice level Chart Map items can be created from scratch or 
based on a Master Chart Map item. 

The Practice level Chart Map item is distinguished by a yellow icon with a P. The 

icon also indicates whether it is a Practice level account range mapping , a 

folder  or a shortcut . 

 Client Chart Map items

Client level Chart Map items are those created for the reporting purposes of a 
specific client. The client Chart Map items will only be available for use for that 
particular client. Client Chart Map items can be created from scratch or based on 
an existing Master or Practice Chart Map item. 

The Client level Chart Map item is distinguished by a blue icon with a C. The icon 

also indicates whether it is a Client level account range mapping , a folder 

 or a shortcut . 

 Mixed hierarchy Chart Map items

When you edit the child components of a Master or Practice level folder, only 
the child components are saved to a lower level, while the Master or Practice 
level folder remains at its current level of the hierarchy. In this case, you have 
folders at one level with child components at another level. The following icon 
combinations appear when a parent folder or table contains child components 
of mixed hierarchy: 

 Master level folder with Practice level children  

 Master level folder with Client level children  

 Master level folder with Practice and Client level children  

 Practice level folder with Client level children . 

Note: Within the Report Designer window you can only see Chart Map items that 
exist at the hierarchy level you entered the software through and above. That 
is, if you enter Report Designer from your ledger software at the Practice level 
then you will only see Master and Practice level Chart Map items listed. If you 
enter via the menu option then you will see all three levels of Chart Map 
items. 
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Related topics

Making changes to the Chart Map

Chart Map tab

Chart Map editor

Chart Map browser

Chart Map properties

Displaying specific levels of the Chart Map

Chart Map folders

Chart Map account ranges

Viewing account details from a previewed format or report

Chart Map shortcuts

Making changes to the Chart Map 

Accountants Enterprise in Australia only

Report Designer provides you with a number of Master level Chart Map items 
(folders, shortcuts and account range mappings). You can customise these to suit 
your practice requirements or the requirements of an individual client. There are, 
however, a few things you should be aware of before you start to customise these 
items. 

 If you add a new folder, shortcut or account range mapping to a Master Chart 
Map folder, the new mapping is saved at the Practice or Client level, while the 
Master Chart Map folder to which the new mapping was added remains a 
Master. In this situation the Master folder icon changes to indicate the presence 
of a non-master child component. For example: 

 If you change a folder within a Master level folder while working at the 
Practice level, the new mapping will be a Practice level item and the Master 

level folder icon will change to . 

 If you change a folder within a Master level folder while working at the 
Client level, the new mapping will be a Client level item and the Master level 

folder icon will change to . 

 If you change a folder within a Master level folder while working at the 
Practice level, then change it again at a later date while at the Client level, 
the Master level folder will contain both Practice and Client level child 

components and the Master level folder icon will change to . 

 If you edit a Chart Map item that has lower level child components, e.g., you 
rename a Practice level folder which contains Client level items, the Client level 
child items will become ‘orphans’ and are lost. To avoid this, use the right–click 
menu in the Chart Map Explorer pane to copy the folder to be edited to the 
current level before the edits are applied at the higher level. In this way, the child 
components are retained in the lower level version of the folder. The copied 
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folder will be saved at the Practice or Client level depending on the level at 
which you opened Report Designer. 

 If the accounts range mappings within a Chart Map folder need to be changed, 
the changes you make to the Chart Map will differ, depending on whether you 
want to reference additional accounts or reference fewer accounts than are 
currently contained in the folder in question. 

If you want to reference additional accounts, you just need to add one or more 
account ranges to the folder (bearing in mind that any parent folders or Formats 
that reference that folder will also reference the additional accounts). If you 
want to reference fewer accounts than are currently being referenced, you need 
to copy the entire folder to the level at which you are working (Practice or 
Client). You will then be able to edit or delete the account ranges at that level. 
Bear in mind that if you copy the folder to the Practice or Client level, it will not 
be updated with any updates that might be issued 

 If you want to reference accounts or account ranges in your reports that are not 
currently included in the Chart Map, you will need to either add the account or 
range to an existing folder or create a new folder and then add the account or 
accounts to that. You need to bear in mind that it is Chart Map folders, not 
individual account ranges that are referenced in Formats. Remember also that a 
Chart Map has several layers and that if you add a range to a folder, the folders 
above will then also include the range you have added. 

 When you edit a Chart Map item and it is saved to a lower level (Practice or 
Client level) with its original name, the Master item no longer displays in the 
Chart Map tab. It is replaced by the Practice or Client version. The Master 
version remains in the background and is reinstated if the Client and/or Practice 
versions are deleted or renamed. The Master item will display when Report 
Designer is opened from client ledgers for which a Client version of the item has 
not been created. 

Note: If you modify a Chart Map item that is referenced by a Format, you will also 
need to modify the Format accordingly as there is no flow-through update to 
the Format when a Chart Map item is changed. For example, if you change the 
Chart Map folder ‘Sales’ to ‘Income’, any references within Formats to the 
Chart Map folder ‘Sales’ will not automatically be changed to ‘Income’, and 
will therefore fail. 

Related topics

Chart Map

Chart Map tab

Chart Map editor

Chart Map browser

Chart Map properties

Displaying specific levels of the Chart Map



Designing reports

MYOB AE Reporter | Version 3.4 User Guide | 190

Chart Map folders

Chart Map account ranges

Viewing account details from a previewed format or report

Chart Map shortcuts

Creating a reference to account information (Chart Map)

Chart Map tab 

Accountants Enterprise in Australia only

The Chart Map tab on the Report Designer window contains the Chart Map tree and 
a Chart Map toolbar. The Chart Map tree lists all the Master level Chart Map items 
(folders, shortcuts and account range mappings) provided with Reporter, along with 
any Chart Map items you have created at a Practice level. In addition, the Client level 
Chart Map items created for the selected client will also be listed. 

You can make changes to Chart Map items using the Chart Map Editor window and 
view account ranges using the Chart Map Browser. 

From the Chart Map tab you can: 

 Create new Chart Map items.

 Edit existing Chart Map items. 

 Delete Chart Map items. 

You can only delete Client and Practice items. You cannot delete a Master folder 
or any of its account ranges or shortcuts. To delete a Practice or Client item, you 
need to open the Report Designer at the level at which the item was deleted.

 Use the Chart Map Browser to view descriptions and balances for all accounts 
under the selected Chart Map item. 

 Access the Search window. 

When working in the Chart Map tab there are 2 work areas:

 the left-hand Explorer pane which displays the Chart Map tree

 the right-hand Design pane. 

Right-click menu

In addition to the toolbar, there is also a right-click menu available in the Chart Map 
tab. This contains the same options as the toolbar, but in addition also contains: 

Option Description

Copy This is standard Windows copy functionality. You can 
copy and paste between Chart Maps and also between 
different ledgers.
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Copy to Client / 
Practice

Use this option to save the currently selected Chart Map 
item to the level at which you opened Report Designer 
(Client or Practice). This option will read Copy to Client if 
you opened Report Designer at the Client level, allowing 
you to save a Practice level or Master level item at the 
Client level. If you opened Report Designer at the 
Practice level it will read Copy to Practice, allowing you 
to save a Master level item at the Practice level. 

Copy to clipboard Saves the complete Chart Map tree structure to the 
Windows clipboard. Content can be pasted into other 
applications such as Notepad, Microsoft Excel or Word 
for viewing and printing.

Cut This is standard Windows cut functionality. You can copy 
and paste between chart maps and also between 
different ledgers.

This option will not be available for Master level items.

Go to Folder Use this option to jump to the source folder of the 
selected shortcut. 

This option is only available when a shortcut is selected. 

Paste This is standard Windows paste functionality. 

Paste as Shortcut Use this option to paste the copied Chart Map item as a 
shortcut in the selected Chart Map item. 

This option is only available if the copied Chart Map item 
is a folder. 

Properties Select this option to access the Chart Map Properties 
window where you can add, view or edit the notes that 
have been added to the selected Chart Map item. To add 
or edit notes simply type into the Description field and 
then click the Apply button to save your entry. If Report 
Designer is not open at the required hierarchy level to 
edit the properties, then the window will open as read–
only. 

Show Master Chart 
Map

Select this option to view the matching Master level 
Chart Map item for the currently selected Practice or 
Client level item. The Master level Chart Map window 
will be opened, with the Chart Map tree displayed to 
show the location of the Master level item. 

Option Description
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Related topics

Chart Map

Making changes to the Chart Map

Chart Map editor

Chart Map browser

Chart Map properties

Displaying specific levels of the Chart Map

Chart Map folders

Chart Map account ranges

Viewing account details from a previewed format or report

Chart Map shortcuts

Chart Map editor 

Accountants Enterprise in Australia only

The Chart Map Editor is the work area where you view, add and edit the Chart Map 
items (folders, account range mappings and shortcuts) that are listed in the Chart 
Map tab of the Report Designer window. 

You can open the Chart Map Editor using any one of the following methods: 

 double-clicking a folder, shortcut or account range in the Chart Map tree. 

 clicking the Add Chart Map Item  or Edit Chart Map Item  buttons on 
the Chart Map toolbar. 

 selecting a Chart Map item in the tree and using the Edit option on the right–
click menu. 

 selecting a Chart Map item and pressing [Enter] to open the Chart Map item for 
editing in the Chart Map Editor. 

Show Practice Chart 
Map

Select this option to view the matching Practice level 
Chart Map item for the currently selected Client level 
item. The Practice level Chart Map window will be 
opened, with the Chart Map tree displayed to show the 
location of the Practice level item. This option is not 
available if Report Designer is open at the Practice level. 

View Dependencies This option enables you to see which formats use a 
particular Chart Map folder.

Option Description
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Use the Expand (+) button to expand all the nodes on the Chart Map tree. To expand 
only a particular node on the Chart Map tree, click the Expand (+) button to the left 
of that node.

Use the Collapse (-) button to collapse all the nodes on the Chart Map tree so that 
only the top level nodes are displayed. To collapse only a particular node on the Chart 
Map tree, click the Collapse (-) button to the left of that node.

The Chart Map Editor window has different fields and options within it depending on 
the type of Chart Map item you are working with. The top part of the window contains 
radio buttons which identify the Item Type you are working with. The options here 
are:

 “Chart Map folders” (see page 196)

 “Chart Map account ranges” (see page 199)

 “Chart Map shortcuts” (see page 205).

The fields displayed in the bottom portion of the window will change depending on 
the option selected. 

Related topics

Chart Map

Making changes to the Chart Map

Chart Map tab

Chart Map browser

Chart Map properties

Displaying specific levels of the Chart Map

Chart Map folders

Chart Map account ranges

Viewing account details from a previewed format or report

Chart Map shortcuts

Chart Map browser 

Accountants Enterprise in Australia only

The Chart Map Browser provides descriptions and balances for all the accounts in the 
selected account range for the currently selected Chart Map item in the Chart Map 
tab. Where there are multiple levels below the selected Chart Map item in the tree, 
all accounts contained in the selected Chart Map items are displayed. 

The system calculates the total for each account with the designated balance type in 
the account ranges for each designated reporting period. 
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To open the Chart Map Browser, select the Chart Map item in the tree that you want 

to view account details for, then select the View Account Details button  on the 
toolbar. 

Related topics

Chart Map

Making changes to the Chart Map

Chart Map tab

Chart Map editor

Chart Map properties

Displaying specific levels of the Chart Map

Chart Map folders

Chart Map account ranges

Viewing account details from a previewed format or report

Chart Map shortcuts

Chart Map properties 

Accountants Enterprise in Australia only

The Chart Map Properties window is where you can add, view or edit the notes that 
have been added to the selected Chart Map item. The Chart Map Properties window 
is accessed by selecting the Chart Map item in the tree list of the Explorer pane, then 
the Properties options from the right–click menu. 

To add or edit notes simply type into the Description field and then click the Apply 
button to save your entry. 

Note: If Report Designer is not open at the required hierarchy level to edit the 
properties, then the window will open as read–only. 

Related topics

Chart Map

Making changes to the Chart Map

Chart Map tab

Chart Map editor

Chart Map browser

Displaying specific levels of the Chart Map

Chart Map folders

Chart Map account ranges

Viewing account details from a previewed format or report
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Chart Map shortcuts

Displaying specific levels of the Chart Map 

Accountants Enterprise in Australia only

You can display the Chart Map at the:

Master level

When you are working in the Chart Map, it is sometimes useful to be able to view the 
corresponding higher level item for a Chart Map item. For example, if you are editing 
a Client level account range, you may want to know which account ranges are 
included in the Master level version of the same item. Using the Master level Chart 
Map window you can quickly and easily view this information. 

The Master level Chart Map window is accessed by selecting the Show Master Chart 
Map option on the right-click menu within the Chart Map Explorer pane. Just select 
the Practice or Client level item you want to view the corresponding Master 
information for, then click the menu option. 

The Master level Chart Map window will be opened, with the Chart Map tree 
displayed to show the location of the Master level item which corresponds with the 
selected Practice or Client level item. 

If no corresponding Chart Map item exists, the next available parent is selected in the 
Master level Chart Map window. If no parent exists, the first Chart Map item is 
selected. 

You can also copy items from the Master level Chart Map window by selecting the 
required item in the window then clicking Copy on the right–click menu. You can then 
paste this at the Client or Practice level (depending on the level at which you opened 
Report Designer) at the desired location of the Chart Map tree in the Explorer pane. 

Practice level

When you are working in the Chart Map, it is sometimes useful to be able to view the 
corresponding higher level item for a Chart Map item. For example, if you are editing 
a Client level account range, you may want to know which account ranges are 
included in the Practice level version of the same item. Using the Practice level Chart 
Map window you can quickly and easily view this information. 

The Practice level Chart Map window is accessed by selecting the Show Practice 
Chart Map option on the right–click menu within the Chart Map Explorer pane. Just 
select the Client level item you want to view the corresponding Practice information 
for, then click the menu option. 

The Practice level Chart Map window will be opened, with the Chart Map tree 
displayed to show the location of the Practice level item which corresponds with the 
selected Client level item. 
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If no corresponding Chart Map item exists, the next available parent is selected in the 
Practice level Chart Map window. If no parent exists, the first Chart Map item is 
selected. 

You can also copy items from the Practice level Chart Map window by selecting the 
required item in the window then clicking Copy on the right–click menu. You can then 
paste this at the Client level at the desired location of the Chart Map tree in the 
Explorer pane. 

Note: This option is not available if Report Designer is open at the Practice level. 

Related topics

Chart Map

Making changes to the Chart Map

Chart Map tab

Chart Map editor

Chart Map browser

Chart Map properties

Chart Map folders

Chart Map account ranges

Viewing account details from a previewed format or report

Chart Map shortcuts

Chart Map folders 

Accountants Enterprise in Australia only

When you create a new Chart Map folder, the level you are logged in to Report 
Designer will determine the hierarchy level of the new folder. For example, if you 
opened Report Designer at the Client level, the new folder will be a Client level folder. 

You may find that you need to rename a Chart Map folder or move it to sit under 
another folder or at another level of the tree. 

If you edit a Chart Map folder that has lower level child components, e.g., you rename 
a Practice level folder which contains Client level items, the child items will become 
‘orphans’ and are lost. To avoid this, use the right–click menu in the Chart Map 
Explorer pane to copy the folder to be edited to the current level before the edits are 
applied at the higher level. In this way, the child components are retained in the lower 
level version of the folder. The copied folder will be saved at the Practice or Client 
level depending on the level at which you opened Report Designer. 
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Note: If you modify a Chart Map item that is referenced by a Format, you will also 
need to modify the Format accordingly as there is no flow-through update to 
the Format when a Chart Map item is changed. For example, if you change the 
Chart Map folder ‘Sales’ to ‘Income’, any references within Formats to the 
Chart Map folder ‘Sales’ will not automatically be changed to ‘Income’, and 
will therefore fail. 

You may also find that you need to delete a Chart Map folder that is no longer 
required. If you want to delete a folder that contains shortcuts, account ranges or 
other folders, then all those child items will be deleted along with the parent folder. 

Note: You cannot delete Master level folders. 

To create a new folder within Report Designer (on the Chart Map tab)

1. In the Chart Map tab, select the New Chart Map Item toolbar button .

or

Select New from the right- click menu

or

Select File > New from the menu. 

The Chart Map Editor window opens. 

2. In the Item Type area of the Chart Map Editor window, select the Folder radio 
button. 

3. In the Folder Name field, enter the name for the new folder.

A maximum of 255 characters can be entered. 

Note: Spaces and the following symbols are not allowed as part of the 
folder name: \ / @ [ ] ( ) ! % ^ * - + = { } < > , “ ‘

4. In the Parent Folder list box, select the path to the folder that the new folder will 
go in. 

For example, to add a folder under the BalanceSheet.Assets folder, select 
BalanceSheet.Assets in the list box. 

Note: To add a folder to the main branch of the Chart Map tree, select 
<None> from the list. 

5. Click Apply. 

The new folder will be added to the path you selected. 
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Note: If you select a parent folder for the new folder and enter a folder 
name that is the same as an existing folder at that level in the same 

parent folder, an error tag,  will be displayed next to the Folder 
Name field. You will need to enter another name for the folder or 
change the parent folder. 

To edit a Chart Map folder within Report Designer (on the Chart Map tab)

1. In the Chart Map tab, select the folder that you want to edit and click the Edit 

Chart Map Item toolbar button .

or

Select Edit from the right -click menu 

or

Select File > Edit from the menu. 

The Chart Map Editor window opens showing the details for the selected folder. 

2. Make any required changes to the folder name by overtyping the existing text in 
the Folder Name field. 

A maximum of 255 characters can be entered. 

Note: Spaces and the following symbols are not allowed as part of the 
folder name: \ / @ [ ] ( ) ! % ^ * - + = { } < > , “ ‘

3. If you want to change the location of the selected folder, select the required path 
for the folder in the Parent Folder list box. 

For example, to move the folder under the BalanceSheet.Assets folder, select 
BalanceSheet.Assets in the list box. 

Note: To move a folder to the main branch of the Chart Map tree, select 
<None> from the list. 

4. Click Apply to implement and save your changes. 

Note: If you select a parent folder and enter a folder name that is the 
same as an existing folder in the same parent folder at the same 

level, an error tag,  will be displayed next to the Folder Name 
field. You will need to enter another name for the folder or change 
the parent folder. 
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To delete a Chart Map folder within Report Designer (on the Chart Map tab)

1. In the Chart Map tab, select the folder that you want to delete and click the 

Delete Chart Map Item toolbar button .

or 

Select Delete from the right-click menu 

or

Select File > Delete from the menu. 

A message will be displayed asking you to confirm your actions. You may need to 
click the Expand (+) icon next to the relevant nodes to expand the portion of the 
Chart Map tree that contains the item you want to delete. 

Note: Click the View Dependencies button if you want to view a list of all 
the components (Formats and reports) that use the Chart Map 
item. You can then decide if any action needs to be taken (a Save 
As or Copy to retain any child components perhaps) before you 
confirm the delete. 

2. Click Yes to continue with the deletion.

The folder will be removed from the Chart Map tab. 

Related topics

Chart Map

Making changes to the Chart Map

Chart Map tab

Chart Map editor

Chart Map browser

Chart Map properties

Displaying specific levels of the Chart Map

Chart Map account ranges

Viewing account details from a previewed format or report

Chart Map shortcuts

Column templates

Chart Map account ranges 

Accountants Enterprise in Australia only

Account ranges are added to folders within the Chart Map tree. A folder can contain 
multiple account ranges. 
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You can edit account ranges in the Chart Map Editor window. From the Chart Map 
Editor window, you can add new account ranges to those already included, delete 
ranges previously added, or change the mapping information for a range. 

You can delete an account range either directly from the Chart Map tree in the 
Explorer pane or using the Chart Map Editor window. 

To add a new account range to a Chart Map folder within Report Designer (on the 
Chart Map tab)

1. From the Chart Map tree in the Explorer pane select the Chart Map folder you 
want to add an account range to and click the New Chart Map Item toolbar 

button .

or

Select New from the right–click menu. 

The Chart Map Editor window opens. 

2. In the Item Type field select the Account ranges radio button. 

The Folder Name field will display the parent folder selected in the Explorer 
pane. If required, you can change the parent folder by selecting another one 
from the list box. 

3. Click the Add New Account Range button . 

The cursor will be placed in the Start field ready for you to enter the account 
range. 

4. Enter the starting account range into the Start fields. 

5. Enter the last account of the required range into the End fields. 

6. Select or deselect one or both of the following checkboxes:

 Include Credits — credit amounts from the client’s ledger will be included in 
the amounts.

 Include Debits — debit amounts from the client’s ledger will be included in 
the amounts.

as required.

7. Enter the increment value(s) into the Account Code Stepping fields if stepping is 
required. 

There are 2 options for stepping within a range:

 Main Code Increment 

 Sub Code Increment 
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So that you can control which accounts and sub-accounts are included in a 
range. If you do not require all the account codes within the selected account 
range, you can apply stepping to only include the account codes which fit the 
stepping pattern you define here. For example, only every second account. 

The Main Code Increment option is used to exclude accounts that are not 
required in the range. For example, if the start range is 100 and the end range is 
200, then a main code increment of 2 would result in only the even numbered 
accounts between 100 and 200 being included in the account range.

The Sub Code Increment option is used to increment the sub-code portion of the 
account range while retaining the control account range.

When stepping has been applied to a range, the stepping used is displayed in 
square brackets to the right of the range in the Range pane, e.g., 600 - 650 [4/1] 
would indicate a Main Code Increment of 4 and a Sub Code Increment of 1.

8. Click Apply to save your changes and add the new account range to the parent 
folder. 

You can continue to add more ranges to the same folder if required. To add a 
range to another folder simply select the folder in the Parent Folder list box and 
repeat the above steps. Otherwise click Close to close the Chart Map Editor 
window. 

Note: If you create an account range that is the same as another account 

range in the same parent folder at the same level, an error tag,  
will be displayed next to the Account Code Range field. You will 
need to change the account range. 

To edit an account range in a Chart Map folder within Report Designer (on the Chart 
Map tab)

1. From the Chart Map tree in the Explorer pane select the account range you want 

to edit and click the Edit Chart Map Item toolbar button .

or

Select Edit from the right–click menu. 

You may need to click the Expand (+) icon next to the relevant Chart Map folders 
to expand the portion of the Chart Map tree that contains the account range you 
want to edit. 

The Chart Map Editor window opens with the account range displayed and the 
parent folder selected. 

2. Edit the start and end values for the account range.

3. Select or deselect the Include Credits and Include Debits checkboxes, as 
required.
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4. Select the stepping as required. 

5. Click Apply to save your changes. 

6. You can continue to edit ranges in the same folder or another folder. 

To edit a range in another folder, simply select the folder in the Parent Folder list 
box and repeat the above steps. 

Ensure that the Account Ranges radio button is selected after you have changed 
the selected parent folder. Otherwise, click Close to close the Chart Map Editor 
window. 

Note: You cannot save changes to a Master account range. Any changes made will 
be saved as a new Client or Practice account range. The Master will continue 
to display in the chart map, along with the new range. 
If you create an account range that is the same as another account range in 

the same parent folder at the same level, an error tag,  will be displayed 
next to the Account Code Range field. You will need to change the account 
range. 

To delete an account range within Report Designer (on the Chart Map tab)

Note: You cannot delete Master level account code mappings.

1. In the Chart Map tree, select the account range or the parent folder of the 
account range that you want to delete. 

2. Double–click the item to open the Chart Map Editor window.

or

Click the Edit Chart Map Item toolbar button .

or 

Select Edit on the right–click menu. 

The Chart Map Editor window opens. 

3. In the Account Ranges area of the window, select the actual range you want to 
delete. 

4. Click the Delete button . 

A confirmation message appears. 

5. Click Yes to confirm the deletion. 

The account range is removed from the parent folder. 
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Related topics

Chart Map

Making changes to the Chart Map

Chart Map tab

Chart Map editor

Chart Map browser

Chart Map properties

Displaying specific levels of the Chart Map

Chart Map folders

Viewing account details from a previewed format or report

Chart Map shortcuts

Column templates

Viewing account details from a previewed format or report 

Accountants Enterprise in Australia only

When you preview a Format or report in the Report Designer window you can drill 
down on a value obtained from a Chart Map reference. To view a list of the accounts 
from which the displayed total was obtained, simply move the cursor over the value 
you want to drill down on. The cursor changes to a pointing hand. 

When you click on a value the Drill Down window opens containing the following 
fields: 

Field Description

Amount Displays the account balance. 
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Click Close to exit the Drill Down window and return to the Format or Report preview. 

Related topics

Chart Map

Balance Type Specify the balance type of the general ledger values 
that you want to be displayed in the selected cell(s) or 
column. The default balance type is Actuals.

Balance Type is set for a cell range on the Balances tab 
of the Format Cells window.

The balance types available for Accounts are:

•  actuals

•  opening balance

•  closing balance

•  cash

•  receipts

•  payments

•  non-cash movements

•  quantity

•  opening balance (quantity)

•  closing balance (quantity)

•  budget year to date

•  budget period.

The balance types available for MAS are:

•  actuals

•  receipts

•  payments

•  cash

•  bal2

•  budget (current)

•  budget-bal2 (current)

•  budget (projected)

•  budget-bal2 (projected).

Code Displays the account code for the account. 

Description Displays the account description, sourced from the 
application from which Reporter was opened. 

Period Indicates whether a balance is for the current or 
previous period. 

Field Description
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Making changes to the Chart Map

Chart Map tab

Chart Map editor

Chart Map browser

Chart Map properties

Displaying specific levels of the Chart Map

Chart Map folders

Chart Map account ranges

Chart Map shortcuts

Creating a reference to account information (Chart Map)

Previewing reports from the Report Designer

Previewing formats

Chart Map shortcuts 

Accountants Enterprise in Australia only

A shortcut is a Chart Map item that is used within a Chart Map Folder to reference the 
account ranges specified under another Chart Map Folder (and any account ranges in 
any folders under that). For example, the Chart Map Folder ‘Sales’ is referred to in the 
‘OperatingProfit’ Chart Map Folder. In this way, account ranges only need to be 
added to the Chart Map once. If the accounts assigned to ‘Sales’ are modified, this 
modification is reflected in the reference to ‘Sales’ in the ‘OperatingProfit’ folder. This 
reduces the amount of editing required when the Chart Map is modified, as changes 
need only be made to the folder that is referenced by the shortcuts. If you attempt to 
edit or delete an account range under a folder which is referenced by a shortcut, you 
will be prompted to confirm your change. For any further referencing required, a 
shortcut can be used, reducing the duplication of effort and maintaining consistency 
of data.

The same hierarchy rules apply to shortcut icons as other icons. As Master shortcuts 
are changed, they are saved at the Practice or Master level, depending on the level at 
which you opened the Report Designer window.

You can add new shortcuts to Master, Practice or Client level folders. The shortcut will 
be added to the selected parent folder at the level at which you opened Report 
Designer (Practice or Client). If you select a higher level folder that the level you 
opened Report Designer at, the parent folder icon will change to show it contains 
lower level items within it. For example, a Master level folder with a Client level 

shortcut will have the icon . 

You can edit shortcuts if you want to change where the shortcut within a folder is 
pointing to. 
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To create a new shortcut within Report Designer (on the Chart Map tab) 

1. From the Chart Map tree in the Explorer pane select the Chart Map folder you 
want to add a shortcut to and click the New Chart Map Item toolbar button 

.

or 

Select New from the right–click menu. 

The Chart Map Editor window opens. 

2. In the Item Type field, select the Shortcuts radio button. 

The Folder Name list box will change to display the location and name of the 
selected parent folder for the shortcut. 

The Shortcuts field will list any shortcuts already contained within the selected 
parent folder. 

If required you can change the selected parent folder by selecting another folder 
from the list box. 

3. From the blank list box in the Shortcuts field, select the path to the folder you 
want the new shortcut to point to. 

or

You can drag the required folder from the Explorer pane to the Shortcuts field. 

4. Click Apply. 

The new shortcut will be added to the parent folder in the Chart Map tree. 

Note: If you create a shortcut that is the same as another shortcut in the same 

parent folder at the same level, an error tag,  will be displayed. You will 
need to change the shortcut before the Apply button is enabled. 
In addition to the above method you can also drag and drop shortcuts within 
the Chart Map tree. When you drag an item to another location within the 
Chart Map tree a pop-up menu will be displayed from where you can select 
whether to move the item (only available if the dragged item can be edited at 
the current level), create a copy of it or create a shortcut (if the dragged item 
is a folder). 

To edit a shortcut within Report Designer (on the Chart Map tab)

5. From the Chart Map tree in the Explorer pane select the Chart Map parent 
folder or shortcut you want to edit and click the Edit Chart Map Item toolbar 

button .

or

Select Edit from the right–click menu. 
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The Chart Map Editor window opens showing the parent folder for the selected 
shortcut in the Parent Folder list box and all the shortcuts it contains within the 
Shortcuts field.

Alternatively, you can select the shortcut you want to edit within the Chart Map 
Editor window by selecting the parent folder in the Folder Name list box. 

6. In the Shortcuts field, select the shortcut whose path you want to change. 

7. From the list box, select the path to the folder you want the shortcut to point to. 

8. Click Apply to save your changes. 

Note: If you edit a shortcut to be the same as another shortcut in the same parent 

folder at the same level, an error tag,  will be displayed. You will need to 
change the shortcut before the Apply button is enabled. 

To delete a shortcut within Report Designer (on the Chart Map tab)

1. From the Chart Map tree in the Explorer pane select the shortcut you want to 

delete and click the Edit Chart Map Item toolbar button .

or 

Select Edit from the right–click menu. 

The Chart Map Editor window will be displayed showing the parent folder for 
the selected shortcut in the Parent Folder list box, and all the shortcuts it 
contains within the Shortcuts field. 

Alternatively, you can select the shortcut you want to delete within the Chart 
Map Editor window by selecting the parent folder in the Folder Name list box. 

2. Select the shortcut you want to delete in the Shortcuts field.

3. Click the Delete button . 

A message will be displayed asking you to confirm your actions. 

4. Click Yes to confirm the deletion. 

The shortcut will be removed from the parent folder in the Chart Map tree. 

Related topics

Chart Map

Making changes to the Chart Map

Chart Map tab

Chart Map editor

Chart Map browser
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Chart Map properties

Displaying specific levels of the Chart Map

Chart Map folders

Chart Map account ranges

Viewing account details from a previewed format or report

Database Map

Accountants Enterprise in Australia only

The Database Map is the storage area for the non-transactional information required 
to create reports. Database Map tables hold the actual client data which is then used 
by any report or Formats that reference the Database Map fields. The data required 
to populate the Database Map for a client will initially need to be manually entered 
from your clients General Ledger in a once-only data input exercise. 

As with reports, Formats and Chart Map items, there is a hierarchy within the 
Database Map. MYOB provides you with a number of Master Database Map items. 
These can be changed and saved at a different hierarchy level. You can also create 
your own Database Map items at either the Practice or Client level (the level at which 
you enter Report Designer is the level that new or edited Database Map items will be 
saved at). 

The non–transactional data stored in the Database Map is organised into tables. The 
tables, in turn, are organised into folders. These folders, tables and data fields are 
displayed in the Explorer pane of the “Database Map tab” on page 212 as a tree list. 
Each table contains a number of data entry fields. For example, the ClientDetails table 
contains fields such as EntityType, ClientName and ABN. Tables and table entries are 
edited in the “Database Map editor” on page 215. 

The data stored in Database Map tables can be saved at either the Master, Practice 
or Client level. Data supplied by MYOB is saved at the Master level. When you edit or 
create new Database Map items they will be saved at either the Practice level or 
Client level, depending on the level at which you opened Report Designer. Data saved 
at the Practice level will only be accessible when Report Designer is opened at the 
Practice level. Data saved at the Client level will only be accessible when Report 
Designer is opened at the Client level. 

 Master Database Map items 

Master level Database Map items are provided with the Reporter software. 
These cover the AASB accounting requirements for certain entity types and sizes. 
Master level Database Map items cannot be edited or created, however you can 
use them as a basis for creating Practice or Client level Database Map items. 
Each year MYOB will provide you with an updated Master Database Map to 
cover any AASB changes that have been introduced. 
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Within the Database Map tab in the Report Designer window, the Master level 
items are distinguished by a red icon. The icon also indicates whether it is a 

Master level folder , table  or table data field . 

 Practice Database Map items 

Practice level Database Map items are those created by the report designer 
within your practice. Practice level Database Map items can be created from 
scratch or based on a Master Database Map item. 

Practice level Database Map icons are yellow. The icon also indicates whether it 

is a Practice level folder , a table  or a table data field . 

 Client Database Map items 

Client level Database Map items are those created for the reporting purposes of 
a specific client. The Client level Database Map items will only be available for 
use for that particular client. Client level Database Map items can be created 
from scratch or based on an existing Master or Practice Database Map. 

Client level Database Maps icons are blue. The icon also indicates whether it is a 

Client level folder , a table  or a table data field . 

 Mixed hierarchy Database Map items 

When you edit the child components of a Master or Practice level folder, only 
the child components are saved to a lower level, while the Master or Practice 
level folder remains at its original level of the hierarchy. In this case, you have 
folders at one level with child components at another level. The following icon 
combinations appear when a parent folder contains child components of mixed 
hierarchy: 

 Master level folder with Practice level children  

 Master level folder with Client level children 

 Master level folder with Practice and Client level children  

 Practice level folder with Client level children . 

 Master level table with Practice level children  

 Master level table with Client level children  

 Master level table with Practice and Client level children  

 Practice level table with Client level children . 
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Note: Within the Report Designer window you can only see Database Map items 
that exist at the hierarchy level you entered the software at, and above. That 
is, if you enter Report Designer from your General Ledger software at the 
Practice level then you will only see Master and Practice level reports listed. 
If you enter via the Client level option then you will see all three levels of 
Database Map items. 

Related topics

Making changes to the Database Map

Database Map tab

Database Map editor

Database Map properties

Displaying specific levels of the Database Map

Database Map folders

Adding a new Database Map table

Adding a field to a Database Map table

Editing a field in a Database Map table

Adding client and practice non-transactional data to the database

Adding data to a database table

Editing a list for a data field

Editing a Database Map item

Deleting an item from the Database Map

Repeating rows for Database Map data

Reviewing the retain value settings

Making changes to the Database Map 

Accountants Enterprise in Australia only

When you first receive Report Designer, you will be provided with a number of 
Master level Database Map items (folders, tables and fields). You can customise these 
to suit your practice requirements or the requirements of an individual client. There 
are, however, a few things you should be aware of before you start to customise 
these items. 

 If you add a new table or table field to a Master Database Map folder, the new 
field or table is saved at the Practice or Client level, while the Master Database 
Map folder to which the new item was added remains a Master. In this situation, 
the Master folder icon changes to indicate the presence of a non-master child 
component. For example: 
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 if you change a table or field within a Master level folder while working at 
the Practice level, the new item will be a Practice level item and the Master 

level folder icon will change to . 

 if you change a table or field within a Master level folder while working at 
the Client level, the new item will be a Client level item and the Master level 

icon will change to . 

 if you change a table or field within a Master level folder while working at 
the Practice level, then change it again at a later date while at the Client 
level, the Master level folder may contain both Practice and Client level child 
components and the Master level icon will change to the higher level. In this 
way, the child components are retained in the lower level version. The 
copied item will be saved at the Practice or Client level depending on the 
level at which you opened Report Designer. 

 If you edit a multi record table and change it to a single record table, any fields 
that contain more than one data record will be changed to only have one data 
record for the field. In this instance, the first record listed for a field will be 
retained, while the other records will be deleted. 

A warning message will be shown where you can confirm your actions before 
any data is lost. 

Multi record tables are tables that can have more than one data record stored 
per field (i.e., more than one value can be entered for the data fields in the 
table). For example, if you have a table containing a data field for the name of 
the directors of a company, you may need to add several directors to this. By 
making a table a multi record table, the system will allow you to add multiple 
entries to the data field ‘Directors’.

To make a table a multi record table, just select the Allow Multiple Records 
checkbox in the Database Map Editor window. When this checkbox is selected, 
it enables the Key checkbox in the window. If the table is multi record, at least 
one data field must be a key.

If a table will only require one value per field, leave the checkbox blank (e.g., if 
all the data fields in the table only need a Yes or No value or a date).

 When you edit a Database Map item and it is saved to a lower level (Practice or 
Client level) with its original name, the Master item no longer displays in the 
Database Map tab. It is replaced by the Practice or Client version. The Master 
version remains in the background and is reinstated if the Client and/or Practice 
versions are moved, renamed or deleted. The Master item will display when 
Report Designer is opened from client ledgers for which a Client version of the 
item has not been created. 
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Note: If you modify a database map item that is referenced by a Format, you will 
also need to modify the Format accordingly as there is no flow-through 
update to the Format when a Database Map item is changed. For example, if 
you change the Database Map folder ClientDetails to EntityDetails, any 
references within Formats to the Database Map folder ClientDetails will not 
automatically be changed to EntityDetails, and will therefore fail. 

Related topics

Database Map

Database Map tab

Database Map editor

Database Map properties

Displaying specific levels of the Database Map

Database Map folders

Adding a new Database Map table

Adding a field to a Database Map table

Editing a field in a Database Map table

Adding client and practice non-transactional data to the database

Adding data to a database table

Editing a list for a data field

Editing a Database Map item

Deleting an item from the Database Map

Repeating rows for Database Map data

Reviewing the retain value settings

Database Map tab 

Accountants Enterprise in Australia only

The Database Map tab on the Report Designer window contains the Database Map 
tree and a toolbar. The Database Map tree lists all the Master level Database Map 
items (folders, tables and table data fields) provided with Reporter, along with any 
Database Map items you have created at a Practice level. In addition, if you have 
opened Report Designer at the Client level, any Client level Database Map items 
created for the selected client will also be listed. 

You can make changes to Database Map items using the Database Map Editor 
window, which is opened from the Database Map tab. 

From the Database Map tab you can: 

 Create new Database Map folders and tables.

 Add table field. 
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 Edit existing Database Map tables and table data. 

 Delete Database Map items.

You can only delete Client and Practice items. You cannot delete a Master folder 
or any of its tables or data. To delete a Practice or Client item, you need to open 
Report Designer at the level at which the item was created.

 Enter the selected client’s data for the Database Map table fields.

 Define Database Map item properties. 

When working in the Database Map tab there are 2 work areas:

 the left-hand Explorer pane which displays the Database Map tree 

 the right-hand Design pane. 

In addition to the toolbar, there is also a right–click mouse menu available in the 
Database Map tab. This contains some of the functions that are on the toolbar and in 
addition also contains: 

Option Description

Copy This is standard Windows copy functionality. You can copy 
and paste between database maps and also between 
different ledgers.

Copy to Client / 
Practice

Use this menu item to save the currently selected 
Database Map item to the level at which you opened 
Report Designer (Client or Practice). This menu option will 
read Copy to Client if you opened Report Designer at the 
Practice level, allowing you to save a Practice level or 
Master level item at the Client level. If you opened Report 
Designer at the Practice level it will read Copy to Practice, 
allowing you to save a Master level item at the Practice 
level. 

The new level version of the Database Map item will 
conceal the higher level version until such a time that the 
lower level version is renamed or deleted. 

Copy to clipboard Saves the complete Database Map tree structure to the 
Windows clipboard. Content can be pasted into other 
applications such as Notepad, Microsoft Excel or Word for 
viewing and printing.

Cut This is standard Windows cut functionality. This option will 
not be available for Master level items. You can copy and 
paste between database maps and also between different 
ledgers.

Paste This is standard Windows paste functionality. 
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Related topics

Database Map

Making changes to the Database Map

Database Map editor

Database Map properties

Displaying specific levels of the Database Map

Database Map folders

Adding a new Database Map table

Adding a field to a Database Map table

Editing a field in a Database Map table

Adding client and practice non-transactional data to the database

Adding data to a database table

Editing a list for a data field

Editing a Database Map item

Deleting an item from the Database Map

Repeating rows for Database Map data

Properties Select this option to access the Database map properties 
window where you can add, view or edit the notes that 
have been added to the selected item. To add or edit notes 
simply type into the Description field and then click the 
Apply button to save your entry. If Report Designer is not 
open at the required hierarchy level to edit the properties, 
then the window will open as read–only.

Save As Use this menu item to create a copy of the currently 
selected item. The copy will be saved to the level at which 
Reporter is currently open, that is, Practice or Client. This 
copy can then be changed without affecting the original. 

Show Master 
Database Map

Select this option to view the matching Master level 
Database Map item for the currently selected Practice or 
Client level item. The Master level Database Map window 
will be opened, with the Database Map tree displayed to 
show the location of the corresponding Master level item. 

Show Practice 
Database Map

Select this option to view the matching Practice level 
Database Map item for the currently selected Client level 
item. The Practice level Database Map window will be 
opened, with the Database Map tree displayed to show 
the location of the corresponding Practice level item. This 
option is not available if Report Designer is open at the 
Practice level.

Option Description
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Reviewing the retain value settings

Database Map editor 

Accountants Enterprise in Australia only

The Database Map Editor is the work area where you view, add and edit the Database 
Map items (folders, tables and table fields) that are listed in the Database Map tab of 
the Report Designer window. It is also where you enter and maintain the data to be 
used to populate the table fields when a report is generated. Data can be entered at 
both the Practice and Client level, depending on the level at which you opened Report 
Designer for the particular session. 

Note: Database data can also be entered and maintained via the Generating 
Reports window. 

Use the Expand (+) button to expand all the nodes on the Database Map tree. To 
expand only a particular node on the Database Map tree, click the Expand (+) button 
to the left of that node.

Use the Collapse (-) button to collapse all the nodes on the Database Map tree so that 
only the top level nodes are displayed. To collapse only a particular node on the 
Database Map tree, click the Collapse (-) button to the left of that node.

You can open the Database Map Editor using any of the following methods: 

 Double-clicking an item in the Database Map tree.

 Clicking one of the following:

 New Database Map Folder,  

 New Database Map Table,  

 Edit Database Map Item button,  on the Database Map toolbar.

 Selecting a Database Map folder, table or field and pressing Enter or clicking Edit 
on the right–click menu to open that folder or table for editing. 

 The Database Map Editor window has different fields and options within it 
depending on the type of Database Map item you are working with. When 
working with folders or tables and their fields, you will be working in the Design 
View of the Database Map Editor window. In addition, when entering the actual 
data values to be used in the tables for the selected client ledger, you will need 
to change the window to the Data View. 

 Select one of the following options to view the Database Map Editor window: 

 Design View 
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This view is used to add and edit folders and tables in the Database Map. 
There are 2 fields in the Database Map Editor — Folder Name and Parent 
Folder. 

Note: If you change a Master level table by adding lower level child 
components to it, you may lose those changes in the event of any 
updates to the Master Database Map items being issued by MYOB. 
To prevent this you can save the Master level table to a lower level 
before applying any changes. 
Text fields cannot contain spaces and the following symbols: \ / @ 
[ ] ( ) ! % ^ * - + = { } < > , “ ‘ 

 Data View 

The Data View display of the Database Map Editor window is where you 
enter the actual data values for the fields in the selected table. It is also used 
to view and edit data in a Database Map table. These data values will be the 
values that are used in the reports when reports are generated for the client 
whose data you are entering. 

When a data field is designed, it is defined by a name, a type and a field 
description. The type of field selected controls how data is entered into that 
field in the Data View, e.g., whether text or numbers can be entered or the 
maximum number of characters that can be entered. 

The layout of the Data View window varies, depending on whether the 
selected table has been set to contain multiple records or a single record in 
the Design View. If multiple records are contained in the selected table, 
then the Data View window will be split to show the data fields at the 
bottom of the window and the various values entered for them in the top 
part of the window. If only single records are allowed in the table, then only 
the data fields information is displayed in the window.

Note: When a report is generated for the selected client, if the field being 
referenced does not contain any client data, the Practice level data 
is used in Client level Formats. Where a database field contains data 
at both the Practice and Client level, a Format accessed at the Client 
level will use the data that was entered at that level. 
Text fields cannot contain spaces and the following symbols: \ / @ 
[ ] ( ) ! % ^ * - + = { } < > , “ ‘ 

Click the Table Data / Table Design button to change between the Design View 
and the Data View of the Database Map Editor window when you are working 
with a table. The Table Data / Table Design button is disabled when you are 
adding or editing a folder.

Related topics

Database Map
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Making changes to the Database Map

Database Map tab

Database Map properties

Displaying specific levels of the Database Map

Database Map folders

Adding a new Database Map table

Adding a field to a Database Map table

Editing a field in a Database Map table

Adding client and practice non-transactional data to the database

Adding data to a database table

Editing a list for a data field

Editing a Database Map item

Deleting an item from the Database Map

Repeating rows for Database Map data

Reviewing the retain value settings

Database Map properties 

Accountants Enterprise in Australia only

The Database Map Properties window is where you can add, view or edit the notes 
that have been added to the selected Database Map item. The Database Map 
Properties window is accessed by selecting the Database Map item in the tree, then 
selecting the Properties option from the right–click menu. 

To add or edit notes simply type into the Description field and then click the Apply 
button to save your entry. 

Note: If you do not have the required permissions to alter the Database Map item 
properties or Report Designer is not open at the required hierarchy level to 
edit the properties, then the window will open as read–only. 

Related topics

Database Map

Making changes to the Database Map

Database Map tab

Database Map editor

Displaying specific levels of the Database Map

Database Map folders

Adding a new Database Map table

Adding a field to a Database Map table

Editing a field in a Database Map table



Designing reports

MYOB AE Reporter | Version 3.4 User Guide | 218

Adding client and practice non-transactional data to the database

Adding data to a database table

Editing a list for a data field

Editing a Database Map item

Deleting an item from the Database Map

Repeating rows for Database Map data

Reviewing the retain value settings

Displaying specific levels of the Database Map 

Accountants Enterprise in Australia only

You can display the Database Map at the:

Master level

When you are working in the Database Map, it is sometimes useful to be able to view 
the corresponding higher level item for a Database Map item. For example, if you are 
editing a Client level table, you may want to know which data fields are included in 
the Master level version of the same item. Using the Master level Database Map 
window you can quickly and easily view this information. 

The Master level Database Map window is accessed by selecting the Show Master 
Database Map option on the right–click menu within the Database Map Explorer 
pane. Just select the Practice or Client level item you want to view the corresponding 
Master information for, then click the menu option. 

The Master level Database Map window will be opened, with the Database Map tree 
displayed to show the location of the Master level item which corresponds with the 
selected Practice or Client level item. 

If no corresponding Database Map item exists, the next available parent is selected in 
the Master level Database Map window. If no parent exists, the first Database Map 
item is selected. 

You can also copy items from the Master level Database Map window by selecting 
the required item in the window then selecting Copy on the right–click menu. You can 
then paste this at the Client or Practice level (depending on the level at which you 
opened Report Designer) at the desired location of the Database Map tree in the 
Explorer pane. 

Practice level 

When you are working in the Database Map, it is sometimes useful to be able to view 
the corresponding higher level item for a Database Map item. For example, if you are 
editing a Client level table, you may want to know which data fields are included in 
the Practice level version of the same item. Using the Practice level Database Map 
window you can quickly and easily view this information. 
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The Practice level Database Map window is accessed by selecting the Show Practice 
Database Map option on the right–click menu within the Database Map Explorer 
pane. Just select the Client level item you want to view the corresponding Practice 
information for, then click the menu option. 

The Practice level Database Map window will be opened, with the Database Map 
tree displayed to show the location of the Practice level item which corresponds to 
the selected Client level item. 

If no corresponding Database Map item exists, the next available parent is selected in 
the Practice level Database Map window. If no parent exists, the first Database Map 
item is selected. 

You can also copy items from the Practice level Database Map window by selecting 
the required item in the window, then selecting Copy on the right–click menu. You 
can then paste this at the Client level at the desired location of the Database Map tree 
in the Explorer pane. This option is not available if Report Designer is open at the 
Practice level. 

Related topics

Database Map

Making changes to the Database Map

Database Map tab

Database Map editor

Database Map properties

Database Map folders

Adding a new Database Map table

Adding a field to a Database Map table

Editing a field in a Database Map table

Adding client and practice non-transactional data to the database

Adding data to a database table

Editing a list for a data field

Editing a Database Map item

Deleting an item from the Database Map

Repeating rows for Database Map data

Reviewing the retain value settings

Database Map folders

Accountants Enterprise in Australia only

When you create a new Database Map folder, the level you are logged in to the 
Report Designer will determine the hierarchy level of the new folder. For example, if 
you opened Report Designer at the Client level, the new folder will be a Client level 
folder. 
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To create a new folder within Report Designer (on the Database Map tab)

1. In the Database Map tab, select the New Database Map Folder toolbar button, 

.

or 

Select New Folder from the right–click menu.

or

Select File > New Folder on the menu. 

The Database Map Editor window opens. 

2. In the Folder Name field, enter the name for the new folder.

A maximum of 255 characters can be entered. 

Note: Spaces and the following symbols are not allowed as part of the 
folder name: \ / @ [ ] ( ) ! % ^ * - + = { } < > , “ ‘

3. In the Parent Folder list box, select the path for the new folder. 

For example, to add a folder under the ‘Notes.IncomeTax’ folder, select 
‘Notes.IncomeTax’ in the list box. 

Note: To add a folder to the main branch of the Database Map tree, select 
<None> from the list. 

4. Click Apply. 

The new folder will be added to the path you selected. 

Note: If you select a parent folder for the new folder and enter a folder name that 
is the same as an existing folder at that level in the same parent folder, an 

error tag,  will be displayed next to the Folder Name field. You will need 
to enter another name for the folder or change the parent folder. 

To edit a Database Map folder 

You may find that you need to rename a Database Map folder or move it to sit under 
another folder or at another level of the tree. 

If you edit a Database Map folder that has lower level child components, e.g., you 
rename a Practice level folder which contains Client level items, the child items will 
become orphans and are lost. To avoid this, use the right–click menu in the Database 
Map Explorer pane to copy the item to be edited to the current level before the edits 
are applied at the higher level. In this way, the child components are retained in the 
lower level version. The copied item will be saved at the Practice or Client level 
depending on the level at which you opened Report Designer. 
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Note: If you modify a Database Map item that is referenced by a Format, you will 
also need to modify the Format accordingly as there is no flow-through of the 
update to the Format when a Database Map item is changed. For example, if 
you change the Database Map folder CashFlow to Income, any references 
within Formats to the Database Map folder CashFlow will not automatically 
be changed to Income, and will therefore fail. 

To edit a Database Map folder within Report Designer (on the Database Map tab): 

1. In the Database Map tab, select the folder that you want to edit and click the 

Edit Database Map Item toolbar button, .

or 

Select Edit from the right–click menu.

or

Select File > Edit on the menu. 

The Database Map Editor window opens showing the details for the selected 
folder. 

2. Make any required changes to the folder name by overtyping the existing Folder 
Name. 

A maximum of 255 characters can be entered. 

Note: Spaces and the following symbols are not allowed as part of the 
folder name: \ / @ [ ] ( ) ! % ^ * - + = { } < > , “ ‘

3. If you want to change the location of the selected folder, select the required path 
for the folder in the Parent Folder list box. 

For example, to add a folder under the ‘Notes.IncomeTax folder’, select 
‘Notes.IncomeTax’ in the list box. 

Note: To move a folder to the main branch of the Database Map tree, 
select <None> from the list. 

4. Click Apply to implement and save your changes. 

Note: If you select a parent folder for the new folder and enter a folder 
name that is the same as an existing folder at that level in the same 

parent folder, an error tag,  will be displayed next to the Folder 
Name field. You will need to enter another name for the folder or 
change the parent folder. 
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Related topics

Database Map

Making changes to the Database Map

Database Map tab

Database Map editor

Database Map properties

Displaying specific levels of the Database Map

Adding a new Database Map table

Adding a field to a Database Map table

Editing a field in a Database Map table

Adding client and practice non-transactional data to the database

Adding data to a database table

Editing a list for a data field

Editing a Database Map item

Deleting an item from the Database Map

Repeating rows for Database Map data

Reviewing the retain value settings

Adding a new Database Map table 

Accountants Enterprise in Australia only

When creating a new table, Report Designer must be open at the level at which you 
want to create it. That is, if you want to create a table at the Practice level, open 
Report Designer from your General Ledger software. 

To open the Report Designer at the Practice level (for MAS users)

1. Open the ledger for a client. 

This client’s information will be used when you preview and print the reports. 

2. Select Reports > Reporter > Design Practice reports. 

To open the Report Designer at the Practice level (for Accounts users)

1. Open the Configuration window.

Select Start > Programs > MYOB Accountants Enterprise > Configuration.

2. Select Configure > Accounts > Report Designer.

3. Select the entity that you want to design the reports for.

4. Click Next.
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To create a Client level table from your General Ledger software

1. Select Reports > Reporter > Design Client reports. 

To create a new table within Report Designer (on the Database Map tab) 

1. In the Database Map tab, click the New Database Map Table toolbar button, 

. 

The Database Map Editor window opens. 

2. In the Table Name field, enter the name for the new table. 

Note: Spaces and the following symbols are not allowed as part of the text 
field: \ / @ [ ] ( ) ! % ^ * - + = { } < > , “ ‘

3. Select the Allow Multiple Records checkbox, if required. 

Use the Allow Multiple Record checkbox to specify whether data fields within a 
table can contain multiple records (i.e., more than one value will be required per 
data field). For example, if you have a table containing a data field for the names 
of the Directors of a company, you may need to add several directors to this. By 
checking this box the system will allow you to add multiple entries to the data 
field, Directors.

Selecting this checkbox enables the Key checkbox in the window. If the table is a 
multi record, at least one data field must be a key.

Leave the checkbox blank if the table will only contain data fields that require 
one value per field.

4. From the Parent Folder list box, select the path and folder that you want the 
new table to reside under. 

To create a table at the highest level, with no parent folder, select <None> in this 
field. 

5. Click the Add New Field button, , to begin adding the required fields to the 
table. 

See “Adding a field to a Database Map table” on page 224 for more information.

6. After defining each field, click Apply to add the field to the Table Definition area. 

The area will be cleared ready for you to enter the next field. 

7. When all the fields have been defined, click Close.

The new table and its fields will be displayed in the tree list in the Explorer pane. 
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To make a copy of an existing table

As an alternative to creating a new table from scratch, you can create a copy of an 
existing table then edit it to suit your requirements. The copied table will be saved to 
the level at which you opened Report Designer. Use the Copy to Practice\Client level 
option on the right–click menu. When you create a copy of a table all the fields will 
be copied with it. 

Note: When creating a new table the mandatory fields are Table Name and at least 
one Table Definition (Name and Type). 

Related topics

Database Map

Making changes to the Database Map

Database Map tab

Database Map editor

Database Map properties

Displaying specific levels of the Database Map

Database Map folders

Adding a field to a Database Map table

Editing a field in a Database Map table

Adding client and practice non-transactional data to the database

Adding data to a database table

Editing a list for a data field

Editing a Database Map item

Deleting an item from the Database Map

Repeating rows for Database Map data

Reviewing the retain value settings

Adding a field to a Database Map table 

Accountants Enterprise in Australia only

You can add fields to an existing or newly-created table. When you create a new 
table, you need to add fields to it before data can be added to the table. The ability 
to add fields provides your practice with the flexibility of being able to supplement 
the categories of information that Reporter currently stores with any additional 
information that your practice might want to store and include in reports. 

You can add a field to a table of any level (Client, Practice and Master). Fields added 
will belong to the level at which they were added. For example, if you add a field at 
the Client level, you will not see that field if you open Report Designer at the Practice 
level, even if it was a Practice level table you added it to. 
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To add a field to a table within Report Designer (on the Database Map tab) 

1. Open the Database Map Editor window for the table you want to add a field to. 

2. Click the Add New Field button, . 

The cursor will be placed in the Name field ready for you to start defining the 
new field. 

3. Enter the name for the new field. 

4. In the Type list box, select the type that will define the data to be added to the 
field. 

The available options are:

 Date (dd/mm/yyyy)

 Decimal (0.00)

 List — when this option is selected the ellipsis button is enabled. Click the 
ellipsis button to create or edit the available list of options that can be 
selected when the value is being entered for this field. 

See “Editing a list for a data field” on page 231.

 Memo — you can enter a maximum of 65 000 characters as a memo.

 Number — decimal places are not allowed.

 Text — a maximum of 60 characters is allowed for the text value.

 Yes / No.

5. Enter an explanation of the field in the Description edit box, if required. 

Use this field to enter a description of the data the selected field is to contain. 
This text will be displayed at the bottom of the Database Map Editor in Data 
View mode, when a field is selected. It will assist the person entering the data to 
understand what needs to be entered in a given field. The description entered 
will appear in both the Data View of the Report Designer and the Non-
transactional Data window in Generating Reports.

6. Enter a default value in the Default field, if required. 

Enter the data field value you want to be displayed by default when a record is 
being entered into the table. The person entering the data can choose to accept 
the default or replace it with another value.

7. If you are creating a multi record table, select the Key checkbox if the field is to 
be a key field for the table. 

For multi record tables, you need to define one or more fields in the table to be 
used to match up records over different years. The Key field is only enabled for 
multi record tables. By default, the Key is assigned to the first field in the table.
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8. Select the Retain Value checkbox if you want the data entered for the field to be 
retained during a roll forward. 

Select the Retain Value checkbox if you want the data entered into a field to be 
retained after a roll forward to a new year.

9. Click the Apply button. 

The new field will be added to the list in the Table Definition area of the window 
and the area cleared ready for you to enter the next field. 

10. Repeat Step 2. to Step 9. until all the required fields have been entered. 

Note: You can also drag and drop fields between tables in the Explorer pane of the 
Database Map tab. Simply click the field in the tree and drag it to the table 
that you want to move the field to. You will not be able to move a field to a 
table if a field of the same name already exists in the table. 

Related topics

Database Map

Making changes to the Database Map

Database Map tab

Database Map editor

Database Map properties

Displaying specific levels of the Database Map

Database Map folders

Adding a new Database Map table

Editing a field in a Database Map table

Adding client and practice non-transactional data to the database

Adding data to a database table

Editing a list for a data field

Editing a Database Map item

Deleting an item from the Database Map

Repeating rows for Database Map data

Reviewing the retain value settings

Editing a field in a Database Map table 

Accountants Enterprise in Australia only

If the fields that have been added to a table need to be changed, you can do this in 
the Database Map Editor window. 

You can add a field to a table of any level (Client, Practice and Master). Fields added 
will belong to the level at which they were added. For example, if you add a field at 
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the Client level, you will not see that field if you open Report Designer at the Practice 
level, even if it was a Practice level table you added it to. 

To edit a field in a table within Report Designer (on the Database Map tab)

1. Open the Database Map Editor window for the table you want to edit fields for. 

2. To add a new field, select the Add New Field button . 

The cursor will be placed in the Name field ready for you to start defining the 
new field. 

See “Adding a field to a Database Map table” on page 224.

3. If you want to delete a field from the table:

a. Select the field in the Table Definition area of the window 

b. Click the Delete button . 

A message will be displayed asking you to confirm your actions. 

c. Click Yes to confirm the deletion. 

Note: If there is only one field in a table the Delete button will be 
disabled. 

4. If you want to edit a field:

a. Select it in the Table Definition area of the window or double–click it in the 
tree list in the Explorer pane.

b. Make the changes required to the Name, Type, Description and Default 
settings. 

5. If you need to edit or define a list, click the List… button . 

See “Editing a list for a data field” on page 231.

6. If you are editing a multi record table, make sure at least one field is defined as a 
Key by selecting the Key checkbox for the key field. 

7. Select the Retain Value checkbox for a field if you want the data entered for it to 
be retained during a roll forward. 

8. Click the Apply button as you finish editing each field. 

The edited field will be updated in the list in the Table Definition area of the 
window. 
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Related topics

Database Map

Making changes to the Database Map

Database Map tab

Database Map editor

Database Map properties

Displaying specific levels of the Database Map

Database Map folders

Adding a new Database Map table

Adding a field to a Database Map table

Adding client and practice non-transactional data to the database

Adding data to a database table

Editing a list for a data field

Editing a Database Map item

Deleting an item from the Database Map

Repeating rows for Database Map data

Reviewing the retain value settings

Adding client and practice non-transactional data to the database

Accountants Enterprise in Australia only

Formats contain references to fields in the Database Map that you need to populate 
with data in order for the reports to be produced correctly. You can enter data at 
either the individual Client level or at the Practice level. 

Any data that is common to a number of ledgers should be entered at the Practice 
level. For example, your firm’s name and address details would be entered at the 
Practice level. This data will then be available to all the clients, except where it is 
overridden by data for the same field entered at the Client level. In this case, the data 
entered for a specific client will be used instead of the Practice level data. This only 
applies to tables with a single record. For tables with multiple records, e.g., the 
Director table, both Practice level and Client level data may be available at the Client 
level. 

The Data View display of the Database Map Editor window is where you enter the 
actual data values for the fields in the selected table. 

Note: We do not advise you to enter data at the Practice level for multiple record 
tables, unless you want that data to be available to all clients. 

The icon on the right-hand side of the Level column in the Data View of the Database 
Map Editor indicates the level at which data was entered in the Database Map. Data 
supplied by MYOB and not changed by your practice will display with the red M icon. 
Data entered at the Practice level will display with a green P on a yellow background. 
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Data entered at the Client level will display with a dark blue stick figure against a light 
blue background. 

Related topics

Database Map

Making changes to the Database Map

Database Map tab

Database Map editor

Database Map properties

Displaying specific levels of the Database Map

Database Map folders

Adding a new Database Map table

Adding a field to a Database Map table

Editing a field in a Database Map table

Adding data to a database table

Editing a list for a data field

Editing a Database Map item

Deleting an item from the Database Map

Repeating rows for Database Map data

Reviewing the retain value settings

Adding data to a database table 

Accountants Enterprise in Australia only

Report Designer must be open at the level at which you want to enter data. 

To open the Report Designer at the Practice level (for MAS users)

1. Open the ledger for a client. 

This client’s information will be used when you preview and print the reports. 

2. Select Reports > Reporter > Design Practice reports.

To open the Report Designer at the Practice level (for Accounts users)

1. Open the Configuration window, Start > Programs > MYOB Accountants 
Enterprise > Configuration.

2. Select Configure > Accounts > Report Designer.

3. Select the entity that you want to design the reports for.

4. Click Next.
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To enter data that just applies to the selected client from your General Ledger 
software

1. Select Reports > Reporter > Design Client reports.

Note: You can also add data from your General Ledger main menu by 
selecting Reports > Reporter > Enter non–transactional data or 
from the Generate Reports main window by selecting the Non–
transactional data button. 

To add data to a table within Report Designer (on the Database Map tab)

1. In the Explorer pane of the Database Map tab, select the table to which you 
want to add data. 

2. Double-click the table.

or

Select Edit from the right–click menu or toolbar. 

The Database Map Editor window opens. 

3. Click the Table Data button at the bottom of the window. 

The window will change to display the Data View. 

4. In the Value column for the fields, enter or select the value(s) to be applied to 
that field. 

For tables that can contain multiple records, click the Add button in the Record 
Selection area at the top of the window to add each new record. 

Note: What you can enter into the Value column will depend on the type 
defined for each field. For example, if the field is set to ‘Date’, you 
will only be able to enter a value that fits the date format. 

5. Click Apply to save your changes. 

Related topics

Database Map

Making changes to the Database Map

Database Map tab

Database Map editor

Database Map properties

Displaying specific levels of the Database Map

Database Map folders

Adding a new Database Map table
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Adding a field to a Database Map table

Editing a field in a Database Map table

Adding client and practice non-transactional data to the database

Editing a list for a data field

Editing a Database Map item

Deleting an item from the Database Map

Repeating rows for Database Map data

Reviewing the retain value settings

Editing a list for a data field 

Accountants Enterprise in Australia only

The List window is where you add, edit or delete items to be displayed in the list of 
available values for a data field in a table. When someone is entering a data value in 
a table field they can use this list (accessible via a drop-down) to select the required 
value. For example, in a Title field, you might want to restrict the values that can be 
input to Mr, Mrs, Miss and Ms. Therefore, you would create a list for the Title data 
field so only one of the defined values can be selected. 

If you expect one value to be more commonly selected than any other, you can enter 
it in the Default field. The field in question will then be automatically completed with 
the default value. The person entering data will be able to edit the default value (or 
select it from a drop-down). 

Note: The List button  is only enabled when List is selected in the Type field. 

To edit a list within Report Designer (on the Database Map tab)

1. In the Database Map Editor window, select the table containing the list you 
want to create or edit. 

The table fields are displayed. 

2. In the Table Definition area of the window, select the field you want to edit the 
list for. 

This field must be defined as List in the Type field. 

If you are creating a new field, select List in the Type list box. 

3. Click the List… button . 

The List window opens. 

4. To add a value to the list, simply type the value into the blank perforated line. 

5. To edit a value, just overtype the existing value in the list. 
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6. To delete an item, select it then click the Delete button . 

7. To change the order of values in the list, select an item then use the Move Up 
and Move Down buttons to reorder the list. 

8. When you have completed the tasks, click OK to return to the Database Map 
Editor window. 

The values will now be displayed in the Data View when data is being entered 
into the field. 

9. Click Apply to save your changes. 

Related topics

Database Map

Making changes to the Database Map

Database Map tab

Database Map editor

Database Map properties

Displaying specific levels of the Database Map

Database Map folders

Adding a new Database Map table

Adding a field to a Database Map table

Editing a field in a Database Map table

Adding client and practice non-transactional data to the database

Adding data to a database table

Editing a Database Map item

Deleting an item from the Database Map

Repeating rows for Database Map data

Reviewing the retain value settings

Editing a Database Map item

Accountants Enterprise in Australia only

If you edit a Database Map component that is at a higher level than that at which you 
are logged into Report Designer (e.g., you open Report Designer at the Client level 
and edit a Master or Practice level component) then the changed component will be 
saved at the level you are working at. The icons will change to show the new level of 
the edited components. 
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To edit a Database Map component within Report Designer (on the Database Map 
tab)

1. In the Explorer pane, select the table or folder that you want to edit. 

2. Double–click the item, click the Edit Database Item toolbar button, .

or

Select Edit from the right–click menu. 

The Database Map Editor window opens showing the details for the selected 
item. 

3. To rename a table, overtype the existing name in the Table Name field. 

4. To rename a folder, overtype the existing name in the Folder Name field. 

5. To change the position of the item in the Database Map tree, use the Parent 
Folder list box to select the path and folder that you want the table or folder to 
reside under.

To move the item to the highest level, with no parent folder, select <None> in 
this field. 

6. Edit the fields in a table as required. 

See “Editing a field in a Database Map table” on page 226 for details.

7. When all the changes have been made, click the Apply button to save them. 

Note: If you change the Allow Multiple Records status of a table from multi record 
to single record, a warning message will be displayed. 
To retain all entered data records for the fields in the table, click No. You will 
be returned to the Database Map Editor window where the Allow Multiple 
Records checkbox is still selected.
If you click Yes, each field in the table will be converted to a single record field. 
All fields in the table will be changed to only have one stored value. Only the 
value from the first record in the Design View of the Database Map Editor 
window will be retained for each field with multiple records. The other data 
records will be deleted.

Related topics

Database Map

Making changes to the Database Map

Database Map tab

Database Map editor

Database Map properties

Displaying specific levels of the Database Map
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Database Map folders

Adding a new Database Map table

Adding a field to a Database Map table

Editing a field in a Database Map table

Adding client and practice non-transactional data to the database

Adding data to a database table

Editing a list for a data field

Deleting an item from the Database Map

Repeating rows for Database Map data

Reviewing the retain value settings

Deleting an item from the Database Map 

Accountants Enterprise in Australia only

You may find that you need to delete a Database Map folder, table or field that is no 
longer required. If you want to delete a table all the fields within it will also be 
deleted. You must open Report Designer at the level at which the item to be deleted 
is stored. For example, if you want to delete a Client level table, you must open 
Report Designer at the Client level. 

Note: You cannot delete Master level items. You could, however, save the Master 
item at a lower level and then edit the copied version. 

To delete a folder table or field directly within Report Designer (on the Database 
Map tab)

1. In the Database Map tab, select the item that you want to delete.

2. Click the Delete Database Map Item toolbar button, .

or

Select Delete from the right-click menu. 

You may need to click the Expand (+) icon next to the relevant nodes to expand 
the portion of the Database Map tree that contains the item you want to delete. 
A message will be displayed asking you to confirm your actions. 

Note: Click the View Dependencies button if you want to view a list of all 
the components (Formats and reports) that use the Database Map 
item. You can then decide if any action needs to be taken (a Save 
As or Copy to retain any child components perhaps) before you 
confirm the delete. 

3. Click Yes to continue with the deletion. 
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The item will be deleted from the Database Map tab. 

Note: You can also delete table fields from the Database Map Editor window. 
Simply highlight the field you want to delete in the Table Definition area of 

the window and click the Delete button . 

Related topics

Database Map

Making changes to the Database Map

Database Map tab

Database Map editor

Database Map properties

Displaying specific levels of the Database Map

Database Map folders

Adding a new Database Map table

Adding a field to a Database Map table

Editing a field in a Database Map table

Adding client and practice non-transactional data to the database

Adding data to a database table

Editing a list for a data field

Editing a Database Map item

Repeating rows for Database Map data

Reviewing the retain value settings

Repeating rows for Database Map data

Accountants Enterprise in Australia only

You apply repeating to a Database Map item within a Format when the Database Map 
table you are referencing in the Format is a multi record table. The repeat setting 
allows room for all the data values entered for the fields in the table. 

If the Database Map table is a single record table, you do not need to apply any 
repeating. 

To repeat rows for Database Map data within Report Designer (on the Database 
Map tab) 

1. Create a Database Map reference in the cell that forms the intersection between 
the row in which you want the first value displayed and the column in which you 
want the values to appear.

For example, =DB.FinancialLiabilities.FinterestRateAmount. 
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Consult the table entry on the Database Map if you need to make sure that the 
table and field names you are entering are correct. 

2. Right–click on the row label (grey column) of the row in which you entered the 
Database Map reference. 

3. Select Repeat from the right–click menu. 

The Repeat Settings window opens.

4. Select the Repeat for Database Map Table option. 

5. In the list box, select the path to the folder containing the database field to 
which you created a reference. 

6. Click OK to apply your changes and close the Repeat Settings window. 

Note: Your changes are not saved until you save the format. 

7. To view the results click the Preview button. 

You should see a row displayed for each record in the database. If you see a 
formula displayed (i.e., ‘=<table name>.<field name>’) then you have made an 
error in entering the table and field names, which you will need to correct. 

Note: You can set a print condition on the row you have set to repeat. This condition 
will be applied individually to each row that is returned. 
The data that is displayed when the report is run will depend on the level 
(Client or Practice) at which you are running Report Designer, the client 
ledger from which you have opened it, and whether or not the table you are 
referencing is set to contain multiple values. 

Related topics

Database Map

Making changes to the Database Map

Database Map tab

Database Map editor

Database Map properties

Displaying specific levels of the Database Map

Database Map folders

Adding a new Database Map table

Adding a field to a Database Map table

Editing a field in a Database Map table
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Adding data to a database table
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Editing a list for a data field

Editing a Database Map item

Deleting an item from the Database Map

Repeat settings

Reviewing the retain value settings

Reviewing the retain value settings

Accountants Enterprise in Australia only

The Retain Value setting controls whether a data value is rolled forward from the 
Database Map into the next year or not. Logically, when Masters are created the 
Retain Value checkbox is only checked if it makes sense to retain the value.

By default, when customised fields are added to tables at either the Practice or Client 
level the Retain Value field is checked, although your designer may have unchecked 
it if the value is not to be rolled forward. To be sure, you will need to review the 
Retain Value field for each customised Practice or Client level field prior to rolling 
forward.

To review the Retain Value Settings

1. From within your client ledger, either:

For the Practice Level, click Reports > Reporter > Design Practice Level Reports.

or

For the Client Level, click Reports > Reporter > Design Client Level Reports.

The Report Designer opens.

2. Click the Database Map tab.

3. Double click the table that you want to view.

The Database Map Editor appears on the right-hand side.

4. Select the Retain Value checkbox. 

You can also deselect the checkbox.

5. Click Apply.

Related topics

Database Map

Making changes to the Database Map

Database Map tab

Database Map editor

Database Map properties
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Displaying specific levels of the Database Map

Database Map folders

Adding a new Database Map table

Adding a field to a Database Map table

Editing a field in a Database Map table

Adding client and practice non-transactional data to the database

Adding data to a database table

Editing a list for a data field

Editing a Database Map item

Deleting an item from the Database Map

Repeat settings

Repeating rows for Database Map data

Errors in tables

Accountants Enterprise in Australia only

Table shape does not match message

The Table shape does not match message is displayed when you try to move or paste 
a field from a multi record table to a single record table. It can also appear when you 
move or copy a field from a multi record table to another multi record table, where 
the number of records in the source table is greater than the number in the 
destination table.

For example, if the field in the source table ‘Directors’ has 5 directors names entered 
as data and you try to move this field to the table ‘CompanyDirectors’ that only has 3 
records defined, then the Table shape does not match message will be displayed. In 
this situation, you can choose either:

 Yes — select the Yes button to continue with moving or pasting the field. 
Associated data that can be moved s moved / copied to the destination folder. 
Associated data that does not fit in the destination table is lost. You can then go 
and redefine the lost values for the field.

 No — if you want to keep all the data already entered for the field, select the No 
button. The field will not be moved / copied.

Multiple records found message

The Multiple Records Found message is displayed if you edit a table which has been 
defined as a multi record table and change it to a single record table. In other words, 
you deselect the Allow Multiple Records checkbox on the Database Map Editor 
window.

If you deselect the Allow Multiple Records checkbox for a multi record table where 
more than one record exists, then a warning message will be displayed.

If you select:
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 No — if you want to retain all the data records entered for the fields in the table, 
then select No to this message. You will be returned to the Database Map Editor 
window where the Allow Multiple Records checkbox will still be selected.

 Yes — if you choose Yes, each field in the table will be converted to a single 
record field. All the fields in the table will be changed to only have one stored 
value. Only the value from the first record in the Design View of the Database 
Map Editor window will be retained for each field with multiple records. The 
other data records will be deleted.

Data type mismatch message

The Data type mismatch message is displayed when you try to change the type that 
was previously defined for a field in a table and the new type you select for the field 
is incompatible with the data that has already been entered for the field. For 
example, if a field in a table has been defined as a Yes/No field and data has been 
entered into the field so it has a value of yes or no, you cannot then change this field 
type to be a numeric or decimal field, as the yes or no values the field already contains 
will not be accepted in the field if it is a numeric or decimal field. In this case, the 
system will display the Data type mismatch message to tell you that the type you 
have selected for the field cannot retain the data already entered in the field. In this 
situation you can choose either:

 Yes — select the Yes button to continue with the field type change. The data 
already entered for the field will be lost. You can then redefine the new values 
for the field.

 No — If you want to keep the existing data in the field, select the No button. You 
will be returned to the Database Map Editor window and the field type will be 
as it was before you changed the selection in the Type list box.

Related topics

Database Map

Making changes to the Database Map

Database Map tab

Database Map editor

Database Map properties

Displaying specific levels of the Database Map

Database Map folders

Adding a new Database Map table
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Editing a Database Map item
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Deleting an item from the Database Map

Repeat settings

Repeating rows for Database Map data
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Maintaining Reporter

Accountants Enterprise in Australia only

There are a number of options in relation to protecting your reports and client data. 
The way in which you implement these options will depend on your practice, 
particularly your existing backup routines and practice work flow.

MYOB recommends that you back up client data on a regular basis, in particular:

 before working on a client's data, especially when processing a large amount of 
client data.

 After doing significant amount of work on a client's data.

 Prior to performing critical functions, such as year end rollover.

 Prior to installing software or updates to the Masters.

General Ledger users will be used to backing up each client ledger as a regular part of 
their work routine. This will automatically back up any client specific Reporter 
components and the non-transaction data for the client. 

For more information on backing up and restoring your client ledgers, see your 
General Ledger help system.

Roll Forward should only be done by your System Administrator. 

For more information, go to the Administrator Guide.

Related topics

Restoring from the trash can

Starting a new year

Generating reports

Designing reports

Restoring from the trash can

Accountants Enterprise in Australia only

Review archived items in the Trash Can and if applicable, restore. Having rolled 
forward, the ledger year displays the same as the Reporter year, even though the 
ledger has not been rolled forward. If at any time you close and re-open Reporter, the 
Reporter year will try to match the current ledger year. Ensure that you are viewing 
the correct Reporter year as you complete the restore of Trash Can items.

To restore from the Trash Can at the Client level for both MAS and Accounts users

1. Open the ledger of the entity type that you want to design reports for. 
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2. Select Reports > Reporter > Design Client reports.

The Report Designer opens.

3. Click the Database Map tab. 

4. Click Tools > Trash Can.

5. Select what you want to restore from the list.

6. Click Restore.

To restore from the Trash Can at the Practice level for MAS users

1. Open the ledger for a client. 

This client’s information will be used when you preview and print the reports. 

2. Select Reports > Reporter > Design Practice reports.

The Report Designer opens.

3. Click the Database Map tab. 

4. Click Tools > Trash Can.

5. Select what you want to restore from the list.

6. Click Restore.

To restore from the Trash Can at the Practice level for Accounts users

1. Select Start > Programs > MYOB Accountants Enterprise > Configuration.

The Configuration window opens.

2. Select Configure > Accounts > Report Designer.

3. Select the entity that you want to design the reports for.

4. Click Next.

The Report Designer opens.

5. Click the Database Map tab. 

6. Click Tools > Trash Can.

7. Select what you want to restore from the list.

8. Click Restore.
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Related topics

Generating reports

Designing reports

Maintaining Reporter

Starting a new year

Starting a new year

Accountants Enterprise in Australia only

When you have completed the end of year process, you can prepare your system for 
a new year. 

The hierarchy levels in Reporter enable you to enter Practice level data, that is then 
applied to all clients within your practice, and Client data that is specific to a single 
client. In entering the Practice level data your aim is to minimise data entry for all 
users, to minimise data errors and to achieve consistency in the way reports are 
presented. Practice level data includes items such as Year and Period start and end 
dates.

To update practice data for a new year

1. Click on the Database Map tab.

2. Select the ClientDetails table.

3. Click on the View/Edit Database Map Data icon.

4. Enter the correct information for the following data for the practice:

YearStartDate 

YearEndDate

PeriodStartDate

PeriodEndDate

5. Click Apply.

Related topics

Generating reports

Designing reports

Restoring from the trash can

Maintaining Reporter
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Moving from Freeform to Reporter

Accountants Enterprise in Australia only

What is Reporter?

With MYOB AE Reporter, you can quickly and easily produce sophisticated reports for 
your practice and your clients that draw on your AE MAS ledger data. Reporter 
enables you to meet statutory reporting requirements with confidence, as MYOB 
provides an annual compliance update. 

AE Reporter is flexible enough for you to customise reports to your requirements and 
to create reports to meet your clients’ management needs.

How do I check if I already have Reporter?

In an AE MAS ledger, Reporter is installed to your workstation if the menu option 
Reports > Reporter > Generate Reports is available.

How do I determine which version I have installed?

Open Reporter for any ledger, and from the Help menu select About MYOB AE 
Reporter.

To open Reporter, in an AE MAS ledger click Reports > Reporter > Generate Reports.

How do I install Reporter?

Refer to the Installation Guides page for information on installing each version of 
Reporter.
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Installation Guides

Accountants Enterprise in Australia only

To install Reporter, follow the installation steps below.

Download links for Reporter can be found at my.MYOB > My products > Downloads > 
AE Reporter - MAS.

Step Guide Link

1. Install Reporter 3.3. Reporter 3.3 Installation guide Reporter 3.3 Installation Guide (PDF)

2. Perform a workstation 
installation after installing 
Reporter 3.3.

Reporter 3.3 Installation guide Reporter 3.3 Installation Guide (PDF)

3. Install Reporter 3.3.7. Reporter 3.3.7 Installation 
guide

MYOB AE Reporter 3.3.7 MAS Install 
Guide (PDF)

4. Install Reporter 3.4. Reporter 3.4 Installation guide MYOB AE Reporter MAS 3.4 AU 
Installation Guide (PDF)

5. Perform a workstation 
installation after installing 
Reporter 3.4.

Reporter 3.4 Installation guide MYOB AE Reporter MAS 3.4 AU 
Installation Guide (PDF)

6. Install Reporter 3.4.5. Reporter 3.4.5 Installation 
guide

MYOB AE Reporter MAS 3.4.5 AU 
Installation Guide (PDF)

http://downloads.myob.com/Public/AD/AU/Reporter MAS - AU/3.3/Reporter3.3InstallationGuide.pdf
http://downloads.myob.com/Public/AD/AU/Reporter MAS - AU/3.3.7/MYOB AE Reporter 3.3.7 MAS - Install Guide.pdf
http://downloads.myob.com/Public/AD/AU/Reporter MAS - AU/3.3.7/MYOB AE Reporter 3.3.7 MAS - Install Guide.pdf
http://downloads.myob.com/Public/AD/AU/Reporter MAS - AU/3.4/MYOBAEReporterMAS3_4_AU_Installation_Guide.pdf
http://downloads.myob.com/Public/AD/AU/Reporter MAS - AU/3.4/MYOBAEReporterMAS3_4_AU_Installation_Guide.pdf
http://downloads.myob.com/Public/AD/AU/AE/AE_Reporter/3.4.5/MYOBAEReporterMAS3_4_5_AU_Installation_Guide.pdf
http://downloads.myob.com/Public/AD/AU/AE/AE_Reporter/3.4.5/MYOBAEReporterMAS3_4_5_AU_Installation_Guide.pdf
https://my.myob.com/Pages/Default.aspx
http://downloads.myob.com/Public/AD/AU/Reporter MAS - AU/3.3/Reporter3.3InstallationGuide.pdf
http://downloads.myob.com/Public/AD/AU/Reporter MAS - AU/3.4/MYOBAEReporterMAS3_4_AU_Installation_Guide.pdf
http://downloads.myob.com/Public/AD/AU/Reporter MAS - AU/3.4/MYOBAEReporterMAS3_4_AU_Installation_Guide.pdf
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Frequently Asked Questions (FAQs)

Accountants Enterprise in Australia only

 General

 Generating Reports

 Changing components of the report via Non-transaction data

 Customising reports

General

Accountants Enterprise in Australia only

How do I check if I already have Reporter?

In an AE MAS ledger, Reporter is installed to your workstation if the menu option 
Reports > Reporter > Generate Reports is available.

How do I determine which version I have installed?

Open Reporter for any ledger, and from the Help menu select About MYOB AE 
Reporter.

To open Reporter, in an AE MAS ledger click Reports > Reporter > Generate Reports.

How do I install Reporter?

Refer to the Installation Guides page for information on installing each version of 
Reporter.

Generating Reports

Accountants Enterprise in Australia only

How do I open reporter?

AE Reporter is opened within AE MAS. To open Reporter, in an AE MAS ledger click to 
the Reports > Reporter > Generate Reports.

Note that AE Reporter opens outside the AE MAS window.

How do I generate reports?

Click the Reports tab, and select the reports you wish to generate in the Reporter 
window. From there, you can preview the report, print reports, and export report 
information to several file formats. 

See Generating reports for more information.



Frequently Asked Questions (FAQs)

MYOB AE Reporter | Version 3.4 User Guide | 247

How do I preview reports?

Click the Reports tab, and select the reports you wish to generate in the Reporter 
window. From there, you can preview reports in the Report Preview window and 
check the report before printing or exporting to a file.

See Previewing reports for more information.

How do I export reports?

Click the Reports tab, and select the reports you wish to generate in the Reporter 
window. From there, you can export reports to *.doc, *.xls, or *.pdf format. This can 
also be done from the Report Preview window.

See Exporting reports for more information.

How do I apply rounding?

You can display reports with amounts rounded by selecting the Apply Rounding 
checkbox, which is found in the Report Settings option.

See Applying rounding for more information.

How do I display account codes?

You can display account codes on a generated report by selecting Show account 
codes in the Report Settings option.

See Showing and hiding account codes for more information.

How do I select different column configurations?

In AE Reporter, you can select different column configurations. In the Reports tab, go 
to the Column Templates pane, and select the column configuration you wish to use. 
The report will be generated using the selected column template.

How do I refresh the data in my reports?

Use the Refresh Ledger Data menu option to refresh the report balances with any 
changes that have been made to a balance since the report was run. Changes are 
retrieved from the ledger balances on which the report is being run and displayed in 
the report.

With this option, you can make changes in your General Ledger software when you 
have Reporter open, and then click Tools > Refresh Ledger Data to update the 
balances without having to close Reporter. Refreshing the data updates the report 
preview.

Changing components of the report via Non-transaction data

Accountants Enterprise in Australia only
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What is Non-transaction data?

In AE Reporter, the term “non-transaction data” is used to refer to the specific 
disclosure items required for a report that are not provided by the underlying General 
Ledger. 

For example, the statutory details for your client (such as lease details) have to be 
entered using the database tables within Reporter to incorporate them into reports. 

Before you run a report for a client you must enter these values for the non-
transaction data fields so they can be used when reports are generated.

See Non-transaction data for more information.

How do I add the Client Name?

On the Non-transaction data tab, go to the item #EntityDetails > ClientDetails and 
enter the details in ClientName1 (and ClientName2 and ClientName3 as required), 
then click Apply.

How do I enter the Report Dates?

On the Non-transaction data tab, go to the item #EntityDetails > ClientDetails and 
enter the dates in YearStartDate and YearEndDate, then click Apply.

How do I generate Non Reporting entity reports?

On the Non-transaction data tab, go to the item #EntityDetails > ClientDetails and for 
EntityType, select Non Reporting, then click Apply.

How do I exclude the Cover Page from a report?

On the Non-transaction data tab, go to the item #EntityDetails > ClientDetails and for 
CoverPage, select No, then click Apply.

How do I include a Cashflow Report in my report?

On the Non-transaction data tab, go to the item #EntityDetails > 
ReportingExtraDetails and for CashFlowReport, select Yes, then click Apply.

How do I nominate Profit & Loss Appropriation Statement or Income Statement?

To generate the Profit & Loss Appropriation Statement, on the Non-transaction data 
tab, go to the item #EntityDetails > ReportingExtraDetails and for 
ProfitandLossAppropriation, select Yes, then click Apply.

To generate the Income Statement, on the Non-transaction data tab, go to the item 
#EntityDetails > ReportingExtraDetails and for ProfitandLossAppropriation, select No, 
then click Apply.

How do I always generate a Trading Profit and Loss Statement in my report?

On the Non-transaction data tab, go to the item #EntityDetails > 
ReportingExtraDetails and for ForceTradingP&L, select Yes, then click Apply.
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How do I set up my Audit report?

On the Non-transaction data tab, go to the item #EntityDetails > ClientDetails and for 
Audited, select Yes, then click Apply.

Next, on the Non-transaction data tab, enter a selection for either a Qualified 
Opinion or Unqualified Opinion in the item #EntityDetails > ReportingExtraDetails > 
QualifiedOpinion and click Apply.

Finally, on the Non-transaction data tab, complete the items in the folder 
OtherReports > AuditReport and click Apply.

How do I set up the Directors Declaration?

On the Non-transaction data tab, complete the items in the folder OtherReports > 
Director and click Apply.

On the Non-transaction data tab, complete the items in the folder OtherReports > 
DirectorsDeclaration and click Apply.

How do I set up the Compilation Report?

First, on the Non-transaction data tab, complete the items in the folder OtherReports 
> CompilationReport and click Apply.

Next, on the Non-transaction data tab, complete the items in the folder 
OtherReports > Director and click Apply.

How do I set up Secretarial Reports?

First, on the Non-transaction data tab, complete the items in the folder OtherReports 
> SecretarialDetails, and click Apply.

Next, on the Non-transaction data tab, complete the items in the folder 
OtherReports > Director and click Apply.

Customising reports

Accountants Enterprise in Australia only

What types of reports are available?

The report templates available in Reporter and provided by MYOB are referred to as 
the Masters. The Masters are in addition to any report templates created within your 
company, Practice level report templates, or Client level report templates. 

Client level report templates are for the reporting purposes of a specific client. The 
client report will only be available for use within the Generating Reports window for 
the particular client the template was created for. Client report templates can be 
created from scratch, or based on an existing report template of any level.
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When creating or editing reports you will work with Formats. These are the building 
blocks you use to create the content of the reports. See Formats for more 
information.

The Chart Map is a list of mappings to account ranges stored within the Report 
Designer that are utilised in the Formats. See Chart Map for more details.

How do I customise the report paragraph text?

You can customise paragraph text in the Report Designer window.

In an AE MAS ledger click Reports > Reporter > Design Client Reports. The Report 
Designer window displays. From there, you can edit a Format using the Format Editor.

See Editing a format for more information.

How do I customise the accounts included in an item?

You can customise the accounts in an item by using the Chart Map Editor. Here you 
can view, add, and edit Chart Map items. This can be accessed via the Report 
Designer.

In an AE MAS ledger click Reports > Reporter > Design Client Reports. The Report 
Designer window displays. From there, you can make changes to the Chart Map.

See Making changes to the Chart Map for more information.
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